Jump to content

Ghost touches and unresponsive area on lower screen


Recommended Posts

47 minutes ago, _DW_ said:

hmm static build up maybe

That would be my guess too. It was evolving over a few days, at first cleaning up the screen was helping until it got so bad it didn't help anymore. It was like the screen was reading my fingers even though they were 1cm from it.

Edited by Slion
  • Thanks 1
Link to post
Share on other sites
  • Replies 127
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Just a quick follow up... F(x)tec Support sent my replacement screen out on Friday, I received it less than 24 hours later, replaced it as per their video instruction, and it's now working perfec

I still did not use the new display too much, but I feel I have a working Pro1 again. 🙂 I mostly notice the working of touch panel is smooth again, so I was not able to enter my unlock pattern while

Alright.... I received my screen today, replaced it. Phone works again as it should!

Posted Images

30 minutes ago, Slion said:

That would be my guess too. It was evolving over a few days, at first cleaning up the screen was helping until it got so bad it didn't help anymore. It was like the screen was reading my fingers even though they were 1cm from it.

It usually reads my fingers a few mm above. Have you got a screen-protector on? (I see the hoovering-read with and saw it without before). But could be a matter of the material of the protector how bad it is?

Link to post
Share on other sites
3 hours ago, EskeRahn said:

It usually reads my fingers a few mm above. Have you got a screen-protector on? (I see the hoovering-read with and saw it without before). But could be a matter of the material of the protector how bad it is?

Nope, no screen protector.

  • Thanks 1
Link to post
Share on other sites
On 6/20/2020 at 11:55 AM, Slion said:

This morning it went mad again. Turned it off for one hour did not help. It's unusable ATM. I have to contact support.

It was off most of the afternoon yesterday. Used that time to customise another a new  leather case. Turned it back on in the evening now using that new case as I'm suspecting the other case could be causing static build up. So far so good but let's see how long it holds. Last time it took like 24h for the problem to come back.

  • Thanks 1
Link to post
Share on other sites
32 minutes ago, Slion said:

The problem did come back last night. Pro1 is switched off. I still need to contact support.

Try turning on "Show taps" in the developer options (accessible from Settings/System after clicking the build number in About a few times). If it is static build up you should see random activations I think, if problem with the touch screen like some other (me included) hass experienced, it will probably only be along a few rows/columns of the screen.

  • Thanks 2
Link to post
Share on other sites
46 minutes ago, hka said:

Try turning on "Show taps" in the developer options (accessible from Settings/System after clicking the build number in About a few times). If it is static build up you should see random activations I think, if problem with the touch screen like some other (me included) hass experienced, it will probably only be along a few rows/columns of the screen.

Looks like is mostly on one row. Just turned it back on and it's still acting up. Totally unusable, could not even reach the debug settings.

  • Sad 1
Link to post
Share on other sites

Sounds same as me, installed an app called Partial Screen to block effected parts of the screen. But not really trusting third party screen overlay so not entering anything sensitive on the touch screen with it on. But it made the phone useable while waiting for replacement screen from fxtec.

  • Like 2
Link to post
Share on other sites
53 minutes ago, hka said:

Sounds same as me, installed an app called Partial Screen to block effected parts of the screen. But not really trusting third party screen overlay so not entering anything sensitive on the touch screen with it on. But it made the phone useable while waiting for replacement screen from fxtec.

What was the solution from fxtec? Did they send you a screen for you to replace?

Link to post
Share on other sites
20 minutes ago, Slion said:

What was the solution from fxtec? Did they send you a screen for you to replace?

Not yet, but they told me they will.

  • Like 1
Link to post
Share on other sites
33 minutes ago, Slion said:

Sounds same as me, installed an app called Partial Screen to block effected parts of the screen.

Interesting maybe I could implement something like that in Fx Service too 😁

I just contacted support, let's see how well they deal with that.

Regardless that does not bode well for the longevity of that device if it needs a screen replacement every six months it's going to get boring real fast.

Link to post
Share on other sites
3 minutes ago, Slion said:

Interesting maybe I could implement something like that in Fx Service too 😁

...

That would be nice, some simple things that are a bit annoying with the Partial Screen app but it was the only one I could find.

  • Like 1
Link to post
Share on other sites
9 hours ago, Slion said:

Regardless that does not bode well for the longevity of that device if it needs a screen replacement every six months it's going to get boring real fast.

It may happen the screen has quality problems but it may most likely reveal in a few weeks or a few months.

However, I hope it is only a minority and it is most likely not happen later on.

Anyway, my phone is almost seven months old so I really hope its display will remain working...
Also, if it would be a common issue, this forum would be full of this problem - I hope replacing the screen will resolve this issue permanently.

Edited by VaZso
  • Like 2
Link to post
Share on other sites
40 minutes ago, Slion said:

Was there a thread somewhere with instructions on how to replace the screen?

Here is a teardown made by a forum member here.

Also, if you contact F(x)tec, then they can provide a service document to do this replacement.

  • Like 1
  • Thanks 1
Link to post
Share on other sites
On 6/22/2020 at 8:17 AM, Slion said:

Looks like is mostly on one row. Just turned it back on and it's still acting up. Totally unusable, could not even reach the debug settings.

OH! Just a thought. I have often problems using the touch while charging, Could that explain what you see?

  • Like 1
Link to post
Share on other sites
1 minute ago, EskeRahn said:

OH! Just a thought. I have often problems using the touch while charging, Could that explain what you see?

Nope, I hardly ever use my phone while charging.

Link to post
Share on other sites
5 minutes ago, Slion said:

Nope, I hardly ever use my phone while charging.

But it could be somehow related that the touch is sensitive to the electric potential, and as other have suggested static charge.

Try (for the test) to make sure you are grounded by holding e.g. a water pipe, and see if that effects anything.
(It could be the fabric of the clothes we are wearing, and the humidity in the air that make the static charge we build up change)

  • Like 1
Link to post
Share on other sites
3 minutes ago, EskeRahn said:

Try (for the test) to make sure you are grounded by holding e.g. a water pipe, and see if that effects anything.

I'll give it a shot when I get a chance. Sadly, for now my Pro1 is often turned off as I'm waiting for support to come back to me with a solution.

Edited by Slion
Link to post
Share on other sites
55 minutes ago, EskeRahn said:

OH! Just a thought. I have often problems using the touch while charging, Could that explain what you see?

If the charger is not really good (maybe noisy) it can happen.
I have also experienced it with older phones and not really good charger.

  • Thanks 1
Link to post
Share on other sites
8 minutes ago, VaZso said:

If the charger is not really good (maybe noisy) it can happen.
I have also experienced it with older phones and not really good charger.

Yes it is not original

Link to post
Share on other sites
  • EskeRahn changed the title to Ghost touches and unresponsive area on lower screen

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Terms