Jump to content

Ghost touches and unresponsive area on lower screen


Recommended Posts

  • Replies 242
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Just a quick follow up... F(x)tec Support sent my replacement screen out on Friday, I received it less than 24 hours later, replaced it as per their video instruction, and it's now working perfec

Alright.... I received my screen today, replaced it. Phone works again as it should!

I still did not use the new display too much, but I feel I have a working Pro1 again. 🙂 I mostly notice the working of touch panel is smooth again, so I was not able to enter my unlock pattern while

Posted Images

So what is your Fx key mapped too? Is it not the Android traditional 🔎?
On my Galaxy Tab S6 🔎+D takes me to the home screen too.
Did you try 🔎 + Esc too?

Actually the official Android shortcut is 🔎+Enter apparently.

Screenshot_20201119-214248.thumb.png.fd32006c2dead27b6474811718b2d9fe.png

If all fail I could possibly hard code such shortcut in Fx Service.

Edited by Slion
Link to post
Share on other sites
57 minutes ago, Slion said:

So what is your Fx key mapped too? Is it not the Android traditional 🔎?
On my Galaxy Tab S6 🔎+D takes me to the home screen too.
Did you try 🔎 + Esc too?

Actually the official Android shortcut is 🔎+Enter apparently.

Screenshot_20201119-214248.thumb.png.fd32006c2dead27b6474811718b2d9fe.png

If all fail I could possibly hard code such shortcut in Fx Service.

I've never figured out what the magnifying glass key is on the Pro1.  😄  The F logo key on AICP (and I think Lineage, but don't remember clearly) doesn't do anything that I've discovered.

  • Like 1
Link to post
Share on other sites

I tried in KeyEvent under AICP-Q and LineageOS, no code returned from the Logo key.
In Lineage 17.1 Logo+Enter is Home, but nothing happens in AICP-Q
In Lineage 17.1 Logo+BS is back but nothing happens in AICP-Q

Other listed shortcuts like Logo-N works on both, but is handled so deep that no KeyEvents are fired.

On qwertZ Logo+Minus shows the shortcut list, on shifted QwertY it is Logo+Fn+P.

Link to post
Share on other sites
  • 3 weeks later...

Sooo... back on topic (but AICP is still going to come up)... As I had indicated above, things kept getting worse and worse. I referred to them as demon possessions because the touches would end up firing off in bunches, launching apps, pulling down the notification shade, launching things from there, etc.  It went from happening after 2 hours of using my Pro1 to 1 hour after to 5-20 minutes of use with only turning off the phone for a while worked.  It was essentially unusable.  I contacted Chen and her had me open the phone up and check all the connections (man, is this phone easy to open up), but no joy.  So I've been working on getting FxTec to send a new display (which has been slow going).

Yesterday, @tdm made an update to AICP.  My phone had been off and adb sideloading takes a minimum of handling the phone and pressing the screen-- most of it is just what's going on over USB.  So, foolishly, I decided to risk the update. That was yesterday afternoon.  My phone has been on ever since. I've only seen two, very brief and inconsequential flashes of ghost touched but otherwise my Pro1 has been rock solid.

So... what happened? 

We've seen this happen in enough cases that I really think it's a hardware problem, but was there a software aggravation that got somehow corrected by flashing AICP (might have nothing specifically to do with AICP, just a move to a new partition and the rewriting pf the data)?

I really don't know if the demons will be back-- I kind of can't help but suspect they will, which is why I will still try to get a warranty replacement.  But I sure m scratching my head.

Most of all, I am so happy to be using my Pro1 again. So far so good the first 24 hours.

 

Edited by Hook
  • Like 3
Link to post
Share on other sites
24 minutes ago, Hook said:

Most of all, I am so happy to be using my Pro1 again. So far so good the first 24 hours.

Interesting story, I am curious what you will notice in the coming days.

Anyway, when I have replaced my screen bought at Aliexpress, the problem was disappeared without any modification in software.

However, when I have opened the phone and separated the display of its frame, I have noticed at one of the top/bottom edges (I mean at sorter side), maybe near the place where ghost inputs became better after I touched it - I am unsure if it was the opposite side or the bottom what helped when I pressed it...

...so I have noticed some (relatively high amount of) pocket dirt-like dirt at that side between the edge of the screen and the display frame, so I am curious if that kind of issue may be the cause or the display itself... however, I was not curious enough to experiment with my daily driver and glue the same display back to its frame, but I still kept it for some kind of spare - it should still work.

So I suspect that kind of dirt may cause such an issue (and this problem may not exists on all devices), so it may be interesting to check also in other phones, however, that needs the separation of frame and display, so at a complete change (display and frame together), it may not be revealed.

Anyway, I have tried to write it to F(x)tec but apparently they didn't really hear me at [email protected] address.

  • Like 3
Link to post
Share on other sites

I got 4, almost 5 days of my glorious Pro1 and then the demons came back yesterday, the same day support asked me to send it to them.  So my Pro1 has gone off to the UK and I will be sadly keyboardless for a while for the first time in a year (except that I haven't really been able to use it much for 6 weeks anyway.)  😞

Edited by Hook
  • Like 1
  • Sad 2
Link to post
Share on other sites
26 minutes ago, Slion said:

I feel sorry for you. I wonder why they did not send you a replacement screen?

I do too. They said something to the effect of they had no way to know for sure that would solve the problem.  Sounds like a change in policy to me.  I worry a little bit because the problem is sometimes intermittent. 

  • Like 1
  • Sad 1
Link to post
Share on other sites
3 hours ago, Hook said:

I do too. They said something to the effect of they had no way to know for sure that would solve the problem.  Sounds like a change in policy to me.  I worry a little bit because the problem is sometimes intermittent. 

I have a feeling they may want to investigate the problem deeper.
I am sure a simple replacement of the screen will solve your problem, but they may want to change the screen assembly of your phone, then test the original display to see the potential source of the fault.

However, if I remember well, you are in the USA, which may bring up some additional customs problem, however, their current state of Brexit may bring the same problems also for EU members...

Edited by VaZso
  • Like 2
Link to post
Share on other sites
1 hour ago, VaZso said:

I have a feeling they may want to investigate the problem deeper.
I am sure a simple replacement of the screen will solve your problem, but they may want to change the screen assembly of your phone, then test the original display to see the potential source of the fault.

However, if I remember well, you are in the USA, which may bring up some additional customs problem, however, their current state of Brexit may bring the same problems also for EU members...

You are right, of course, especially as more of these cases pop up.  They may want to go and do a deeper cause analysis.  I don't begrudge them that. It's inconvenient (and a little more expensive) for me, but I can see why they are doing it.  Ran into no problems with shipping to the UK... no new extra tariff on my end, don't know about their end.

  • Like 1
Link to post
Share on other sites
16 minutes ago, Hook said:

You are right, of course, especially as more of these cases pop up.  They may want to go and do a deeper cause analysis.  I don't begrudge them that. It's inconvenient (and a little more expensive) for me, but I can see why they are doing it.  Ran into no problems with shipping to the UK... no new extra tariff on my end, don't know about their end.

Maybe there is a way of stating it is a repair and not a new order, I don't know if there is a special declaration in customs about this kind of shipment.

The UK is currently problematic because of Brexit will take effect in 1st of January, even if they don't have agreement with EU and still they have no agreement but the end of the year is almost here.
I don't know if they started to establish agreements with other countries (but I think so) for example with the USA but actual state of the Brexit process is not good at all as the worst-case scenario is getting very close being without agreement...

Edited by VaZso
  • Like 1
Link to post
Share on other sites
7 hours ago, Hook said:

You are right, of course, especially as more of these cases pop up.  They may want to go and do a deeper cause analysis.  I don't begrudge them that. It's inconvenient (and a little more expensive) for me, but I can see why they are doing it.  Ran into no problems with shipping to the UK... no new extra tariff on my end, don't know about their end.

Why is it more expensive for you?

Link to post
Share on other sites
5 hours ago, Jacob_S said:

Why is it more expensive for you?

Because I paid to ship from US to UK rather then they just shipping me a part at their expense. 😉  They will pay for the return trip for my phone.

 

Edited by Hook
  • Thanks 1
Link to post
Share on other sites
2 minutes ago, Hook said:

Because I paid to ship from US to UK rather then they just shipping me a part at their expense. 😉  They will pay for the return trip for my phone.

 

Ah, ok, I see. Didn't think about that. Different laws here in Germany 😉

  • Like 1
  • Confused 1
Link to post
Share on other sites
23 hours ago, Jacob_S said:

Ah, ok, I see. Didn't think about that. Different laws here in Germany 😉

It's the same in Germany, you would have to pay the shipping costs. At least I had to 😁

Edited by Slion
  • Like 1
Link to post
Share on other sites
3 hours ago, Slion said:

It's the same in Germany, you would have to pay the shipping costs. At least I had too 😁

When it's a repair under legal warranty (Gewährleistung) and not under the voluntary warranty the company gives you (Garantie), then the company has to pay for all expenses caused by the process, including shipping TO the company.

Usually you pay for shipping first and get the money refunded after the defect was confirmed.

Edited by Jacob_S
Added last paragraph
  • Like 2
Link to post
Share on other sites
2 minutes ago, Jacob_S said:

When it's a repair under legal warranty (Gewährleistung) and not under the voluntary warranty the company gives you (Garantie), then the company has to pay for all expenses caused by the process, including shipping TO the company.

Good to know. I should really try explain that to FxTec and another company based in Lithuania too 😁

  • Haha 2
Link to post
Share on other sites
1 minute ago, Slion said:

Good to know. I should really try explain that to FxTec and another company based in Lithuania too 😁

I once had that with Blackberry after sending in my Priv for repair (loooong story). They asked for some news article confirming my claims about the legal situation, but then refunded without problems. So good luck 😉

  • Like 2
Link to post
Share on other sites
4 hours ago, Slion said:

It's the same in Germany, you would have to pay the shipping costs. At least I had too 😁

(I think it is a general EU thing, the interesting thing would be to know if commitments made with purchases while UK was still in the EU will still be binding after Brexit, including cross boundary transportation? - and no one knows what new purchases next year will be bound by....)

  • Like 2
Link to post
Share on other sites

Okay, so out of the blue I received a replacement screen for my Pro1 just now.

I'm gonna need a while to get it out of all that bubble wrap though. 😅

 

Update-Edit: It's working! Finally got 100% screen estate again. Took me more time to apply a new screen protector than replacing the screen itself. And the two connectors popped off "like little legos".

Now off to work out a way to return the old screen...

Edited by Wheeljack
  • Like 4
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Terms