Jump to content

Ghost touches and unresponsive area on lower screen


Recommended Posts

  • Replies 185
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Just a quick follow up... F(x)tec Support sent my replacement screen out on Friday, I received it less than 24 hours later, replaced it as per their video instruction, and it's now working perfec

Alright.... I received my screen today, replaced it. Phone works again as it should!

Just to tie my story up, just got an email from FX that they have replaced my display and are shipping it back to me (FedEx to US).  Only a month, I'm very happy! 😄   I was worried with lockdown it wo

Posted Images

On 1/9/2021 at 12:40 PM, hka said:

Six months after replacing the screen the ghosts are back:( Same location as last time.

That's some bad luck. Are you still under warranty?  How did you get it fixed last time?

Link to post
Share on other sites
4 hours ago, Slion said:

That's some bad luck. Are you still under warranty?  How did you get it fixed last time?

Last time I got a new screen from fxtec and replaced it myself. Sent a mail to support again and asked if they could send another one (and if they have checked with their supplier about fixing the root cause).

  • Like 4
Link to post
Share on other sites

They turned me down for sending a display after first considering it.  They indicated that they are no longer confident that just replacing the screen addresses the underlying issue.  Hence, my Pro 1 is now at their offices.

With a number of these issues popping up, they may want to do a more thorough investigation.  Doesn't mean it won't turn out to be the display, but I think they want to look more deeply into it.

Hope you do get the new display, however.

  • Like 3
Link to post
Share on other sites
8 minutes ago, Hook said:

With a number of these issues popping up, they may want to do a more thorough investigation.  Doesn't mean it won't turn out to be the display, but I think they want to look more deeply into it.

When I have replaced my screen with one bought at Aliexpress, I have noticed some dust at one of the shorter sides.

I think it may be in connection with the problem... or may not.
However, that time official support did not seem to be interested...

Anyway, if I will have a similar issue with my current display, I may try to replace it with my original one first...

  • Like 3
Link to post
Share on other sites
10 minutes ago, VaZso said:

When I have replaced my screen with one bought at Aliexpress, I have noticed some dust at one of the shorter sides.

I think it may be in connection with the problem... or may not.
However, that time official support did not seem to be interested...

Anyway, if I will have a similar issue with my current display, I may try to replace it with my original one first...

It's possible, but I would expect the effect of that would be more along the lines of causing touches to be inaccurate.  That used to happen a lot with Palm PDA digitizers and the cure most times was to run the corner of an index card carefully around under the bezel.  But, as I say, the effect was to make the digitizer inaccurate (you would tap one place but it would be interpreted as tapping at a different location).  Not clear why crud would trigger an avalanche of touches across the screen on it's own, while just sitting on a desk.

Not saying you are wrong.  Just raising a question. I'm certainly not an expert on any of this.

Edited by Hook
  • Like 2
Link to post
Share on other sites
1 minute ago, Hook said:

It's possible, but I would expect the effect of that would be more along the lines of causing touches to be inaccurate.  That used to happen a lot with Palm PDA digitizers and the cure most times was to run the corner of an index card carefully around under the bezel.  But, as I say, the effect was to make the digitizer inaccurate (you would tap one place but it would be interpreted as tapping at a different location).  Not clear why crud would trigger an avalanche of touches across the screen on it's own.

Not saying you are wrong.  Just raising a question. I'm certainly not an expert on any of this.

I am also unsure and that is also a reason why I have not disassembled my phone again for testing - that is my daily driver...

However, the dirt ("pocket dirt") seemed to be relatively high amount and I am also unsure which short end was it.
However, the problem was closer to the bottom end and when I have pressed the lower left corner, ghost touches have disappeared or improved for me for a while.

So I am also just guessing but as more people having the same issue, it would be more important to know the valid reason...
I still think it is most likely a display issue, but if the assembly process is similar, a similar gap may exists of different phones and dust may cause jokes... so it simply may worth a try.

  • Like 2
Link to post
Share on other sites
  • 4 weeks later...

Just to tie my story up, just got an email from FX that they have replaced my display and are shipping it back to me (FedEx to US).  Only a month, I'm very happy! 😄   I was worried with lockdown it would take longer.  Thank you, FxTec.

  • Like 5
  • Thanks 1
Link to post
Share on other sites

So unfortunately, the same ghost touches started happening to me yesterday. I was hoping it would be related to the cold after I had been outside. (Currently everything is covered in snow here). 

But after using the factory kit I have noticed that I am having the dead touch row in the same position as well. Got mine in February last year.

Screenshot_20210209-222816.png

Edited by altwouss
Add screenshot
  • Like 1
  • Sad 2
Link to post
Share on other sites
10 hours ago, altwouss said:

So unfortunately, the same ghost touches started happening to me yesterday. I was hoping it would be related to the cold after I had been outside. (Currently everything is covered in snow here). 

But after using the factory kit I have noticed that I am having the dead touch row in the same position as well. Got mine in February last year.

Screenshot_20210209-222816.png

Thanks for sharing. Now that Fxtec has repaired a few devices with this problem, do we know more about the cause? Is it just a failure of the display or is it some failure caused by the proximity with other components (design failure)?

Edited by OKSun
  • Like 1
Link to post
Share on other sites
3 hours ago, OKSun said:

Thanks for sharing. Now that Fxtec has repaired a few devices with this problem, do we know more about the cause? Is it just a failure of the display or is it some failure caused by the proximity with other components (design failure)?

We don't know what they have found, but it is clearly display-related problem - most probably a display fault, but I may think also a small possibility which may be fixing related...
...but it is clearly not related to other components and I don't think it is a design failure.

  • Like 1
  • Thanks 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Terms