Jump to content

Recommended Posts

I could not find Disney+ in the Play Store for my Pro1. It's available and works fine on my Huawei P30 Pro. Is that the same for everyone or is it because I'm running the compromised OTA that was made available for a short time? 

Link to post
Share on other sites

Hmmm interesting.  I don't see it in play store, and I thought I'd hidden all my compromises  (Play protect certified, pass safetynet, etc).

Someone with stock 0306 will have to let us know if its there for them....

 

edit: argh, Im not passying safetynet actually

Edited by Craig
  • Like 1
Link to post
Share on other sites
10 hours ago, Slion said:

I could not find Disney+ in the Play Store for my Pro1. It's available and works fine on my Huawei P30 Pro. Is that the same for everyone or is it because I'm running the compromised OTA that was made available for a short time? 

It is because of the OTA that causes play store issues.  If you are rooted with Magisk, go into the Downloads section in Magisk Manager and install SafetyPatch.

If you aren't rooted, then you need to jump through some hoops to install it outside the play store, because it uses split APKs/App Bundles.  

I am running it fine on the Pro1 through the Play Store with the first method and the 20200304 OTA.

I have also installed it on 2 unrooted Pixel 4 XLs that have unlocked bootloader, which makes them not pass safetynet, hence can't see Disney Plus or Netflix in the Play Store.

  • Like 1
Link to post
Share on other sites

Shouldn't it be possible to download and backup the apk with some backup program (p.e. Titanium Backup)? I've installed plenty of apps that way which were not supposed to be compatible with my phone.

Or are there in-app problems to be expected as well?

PS: A pc emulator might work just as well for downloading. If we have access to the files, I could even imagine extracting the apk from there.

  • Like 1
Link to post
Share on other sites
2 hours ago, SchattengestaIt said:

Shouldn't it be possible to download and backup the apk with some backup program (p.e. Titanium Backup)? I've installed plenty of apps that way which were not supposed to be compatible with my phone.

Titanium does not work with the packaging method they use for the Disney Plus app.  Swift Backup and some other apps do work with the new format.

You can also install it outside the play store by downloading the file and using a special installer. It is not an apk file, so you can't just open it with android or a file browser and install it the way we always have.

I downloaded it from the Apk pure site and then used their apk pure app to install it.  I then removed the apk pure app, as it is full of ads and gave me a lot of hesitation having it on the phones I was installing it on.  I tried it a few months ago and failed.  I tried it a month ago and it worked. Either the Disney app changed or the apk pure app changed and allowed it to work.

Quote

Or are there in-app problems to be expected as well?

I have not encountered that.  After it installed, it was business as usual.  Log in with the Disney account info and everything worked.

Quote

PS: A pc emulator might work just as well for downloading. If we have access to the files, I could even imagine extracting the apk from there.

Installing it in an emulator or real device that can install it from the Play store and then backing it up with a modern backup tool that can handle split apks/app bundles can work.  It just won't work with titanium backup or other old apps that haven't been updated to handle the new packaging methods.

  • Thanks 2
Link to post
Share on other sites
10 minutes ago, michael.bosscha said:

Odd, I've downloaded and executed the app just fine. I'm running stock Android and the last OTA I got was the one that fixed the keyboard, nothing else.

Something was broken for early adopters of that OTA, it was fixed later on. I'm one of the unlucky few to run the broken one. Good to know it runs on yours then. Hope they push a new OTA soon.

  • Like 2
Link to post
Share on other sites
2 hours ago, Slion said:

Something was broken for early adopters of that OTA, it was fixed later on. I'm one of the unlucky few to run the broken one. Good to know it runs on yours then. Hope they push a new OTA soon.

Yes, those that got the 20200304 (on Oct. security patch level) has problems, those that got the 20200306 (On Sep.) does not. I hope it wont be long before we get a new update uniting the two, on a newer security level.

  • Like 3
Link to post
Share on other sites
  • 3 weeks later...
36 minutes ago, andrepereira1768 said:

My phone is as out of the box with one ota update.

I think you've got a few more updates to go.  Keep rebooting and updating (until 0306).

Edited by Craig
  • Like 1
Link to post
Share on other sites
  • 1 year later...
3 hours ago, JosefinaElliott said:

Odd, I've downloaded and executed the app just fine.

It should be an issue we do not see today, it seemed to be related to a specific update 20200304 .

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

Terms