Jump to content
tdm

LineageOS 16.0 Official Builds: Discussion

Recommended Posts

7 minutes ago, EskeRahn said:

Just a wild guess, You haven't by any chance something limiting the network access that need an explicit open? I use "Netguard", more advanced options are available if rooted. But sometimes I forget to poke a hole when an app usually not needing net-access for what ever reason does need it for other purposes than stealing our data.

Thanks, I haven't installed anything of that type (actually could be a good idea).

For both apps I've granted full permissions, but when I use the airline app the "Privacy Guard" keeps a notification stating that my private data will be protected from the app. I wonder if I could give this app a little more access. But I don't know how to configure "Privacy Guard" / SELinux on LOS. In the settings area, the entry for Privacy Guard is only sort of informative. Not many settings available.

Share this post


Link to post
Share on other sites
41 minutes ago, agent008 said:

Thanks, I haven't installed anything of that type (actually could be a good idea).

For both apps I've granted full permissions, but when I use the airline app the "Privacy Guard" keeps a notification stating that my private data will be protected from the app. I wonder if I could give this app a little more access. But I don't know how to configure "Privacy Guard" / SELinux on LOS. In the settings area, the entry for Privacy Guard is only sort of informative. Not many settings available.

In Privacy Guard, Ellipsis (top right), Advanced you can select an app and select to allow&disallow stuff, but I do not see network access on the list?

Share this post


Link to post
Share on other sites
1 hour ago, agent008 said:

Hi. After another day using LOS, I think there might be a cumulative delay between accepting fingerprints. This is a wild guess, but maybe your code is adding up the delay intervals instead of resetting them after a successful unlock?

I'm no programmer but can help you with testing, I'm willing to install another version of this code that would provide logging for your analysis if you think it's necessary.

My fingerprint reader sometimes won't respond. I have to use the power button and swipe. A few seconds after that, the sensor will work again.
And still my inputs get eaten. Just now it spooked around, which is why I'm editing. Also I just noticed my hotmail account isn't syncing anymore.
Maybe a fresh install next weekend.

Edited by DieBruine
  • Thanks 1

Share this post


Link to post
Share on other sites
1 minute ago, EskeRahn said:

In Privacy Guard, Ellipsis (top right), Advanced you can select an app and select to allow&disallow stuff, but I do not see network access on the list?

Exactly. I couldn't find anything related to network access. But maybe could be storage-related. Ie. the app contacts network, does what it needs (creates a hash for example) and then fails to save it.

Share this post


Link to post
Share on other sites
41 minutes ago, DieBruine said:

My fingerprint reader sometimes won't respond. I have to use the power button and swipe. A few seconds after that, the sensor will work again.
And still my inputs get eaten. Just now it spooked around, which is why I'm editing. Also I just noticed my hotmail account isn't syncing anymore.
Maybe a fresh install next weekend.

Your experience is consistent with mine. When you talçk about "eaten inputs" you mean on the physical keyboard? As in, the first few (2 or 3) keypresses get ignored, then the very next one gets repetaed 3x or 4x. I got this a few times too.

I don't wanna come across as complaining. What I'm really interested in doing is help iron out these small wrinkles as bes as I can.

  • Like 1

Share this post


Link to post
Share on other sites

One thing I have noticed is my banking app stops accepting finger prints meaning it ask's if it's ok to use fingerprints to login.  Not sure if this happens after an update or not will ensure I check after the next one.

Share this post


Link to post
Share on other sites

Okay, I'm not sure what I am doing wrong, but it seems I still have quite a bit of issues.

My upgrade path was a long way... from early testing builds until the first official nightly and two days ago, I flashed to the latest nightly.

The first nightly was working pretty good for me. Long battery time, no real bugs. I have never used the fingerprint reader though.

Seeing that the fingerprint reader should work pretty well with the latest nightly, I decided to upgrade, and that's where my issues begin.

First: What's the best way to upgrade?
I simply tried to update the rootfs with the latest nightly, thinking it should keep my google apps.

That's when the first problem happened: Google Play Services were constantly crashing.

So I reinstalled them with MindTheGapps.

They didn't crash anymore - the PlayStore always complained that it doesn't work. So I uninstalled all upgrade for the Google apps - which made them work again (of course, I also tried deleting cache / data before that as well).

Okay. So Google Apps are working again.

However, now I do have a huge battery drain. The About 1% per 10 minutes when the phone is lying on the table with screen off, etc.
According to the battery monitor, it's not an app that drains the battery. And I didn't have the issue with the first nightly - and upgrading hasn't changed my apps.

Then I tried to use the fingerprint reader. It works fine - but unfortunately, it forgets the registered fingerprints on a reboot.

So these are my two remaining issues: Battery drain and forgetting fingerprints on reboots.

Is there something I can do to debug this (is there a tool that can report what REALLY eats up my battery?)

Or should I backup everything, go back to factory settings, check if everything is fine and then reinstall the system?

Thanks for your help 😄

Share this post


Link to post
Share on other sites

@EvilDragon:

For the battery drain, you can start by getting a logcat and looking for something crashing constantly, or perhaps get a shell and run "top".

 

For the fingerprint reader, it sounds like your persist fingerprint data is full.  Try deleting /persist/data/fingerprint (you will need root) and then reboot.  Now you should be able to enroll fingerprints and have them saved.

 

  • Thanks 2

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Terms