Jump to content

LineageOS 16.0 Official Builds: Discussion


Recommended Posts

On 8/29/2020 at 7:59 PM, tdm said:

 

The device is rather busy for a couple minutes after boot.  So the issue is probably load related (as I think we have all suspected for some time).  I'm currently out of town, but I'll try to get you a debug kernel next week that shows what keys are being pressed and released.  You can correlate that to your typing to see if the issue is in the kernel or in Android.

 

I just wanted to point out that it doesn't matter what I try. It's always like this. My son for instance doens't even use the keyboard because of this bug. All phones in our household show this bug. Just tell me how I can heelp and I will.

Link to post
Share on other sites
  • Replies 655
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

I am pleased to announce that the Pro1 has received official support in LineageOS 16.0.   You can find the builds and installation instructions on the official LineageOS Downloads page.

Lineage recovery will offer to install from sdcard if, and only if, a physical sdcard is present and it is able to be read without any decryption (eg. it is not used as adoptable storage).  

In my opinion LineageOS 16 was a very important OS for the Pro1 that brought the best out of the device at a moment when stock couldn't (yet) . Although not a developer, I can well imagine it also bro

Posted Images

I've just updated to the newest build (20200831). The Lineage page doesn't list any changes since last week, so I don't expect anything to act different except the notification going away.

I have now activated the option to auto-delete the update file after updating. Maybe that's why I didn't get the prompt to restart my phone to finish installation. I restarted manually then and everything was fine afterwards.

  • Like 2
Link to post
Share on other sites
2 hours ago, Wheeljack said:

I've just updated to the newest build (20200831). The Lineage page doesn't list any changes since last week, so I don't expect anything to act different except the notification going away.

Thanks. Just downloaded the files, and are currently flashing have just flashed with no issues...

  • Like 1
Link to post
Share on other sites
1 hour ago, internationaltraitor said:

sorry for the noobness, but under settings>system>advanced>updater on the phone, i can download the new aug31 build. is this like the regular way of updating or do i have to update through pc, usb like the initial flash process with fastboot, command prompt etc.

You can do both. But currently the OTA does a total download, not an incremental one, so it is rather slow (in the order of an hour), but if you flash it manually it is a bit more work, but is done in minutes.
When using flashing that includes installing google-apps, people have reported loss of the personal settings for some of these google-apps. (I have not noticed this myself, so I guess I do not use the particular google-apps in question, or use them with default settings, and thus never notice the issue)

  • Like 2
Link to post
Share on other sites
7 hours ago, EskeRahn said:

(I have not noticed this myself, so I guess I do not use the particular google-apps in question, or use them with default settings, and thus never notice the issue)

Ditto here.  I only sideload and I always reflash MindTheGapps even though it is said you don't need too (also reflash addonsu).  I've never noticed any lost settings... then again, I don't use many Gapps (Maps and Contacts are about it). 

  • Thanks 1
Link to post
Share on other sites
20 minutes ago, Hook said:

Ditto here.  I only sideload and I always reflash MindTheGapps even though it is said you don't need too (also reflash addonsu).  I've never noticed any lost settings... then again, I don't use many Gapps (Maps and Contacts are about it). 

 

Currently sideload does not keep addons, so you must do the following:

1. sideload the new Lineage zip.

2. reboot recovery to switch slots.

3. sideload gapps and/or su.

4. reboot into android.

This process takes about 5 minutes.

 

OTA keeps addons, so just install and reboot.  But since it is done in the background, it can take up to an hour or so.

 

  • Like 3
  • Thanks 1
Link to post
Share on other sites
6 minutes ago, tdm said:

 

Currently sideload does not keep addons, so you must do the following:

1. sideload the new Lineage zip.

2. reboot recovery to switch slots.

3. sideload gapps and/or su.

4. reboot into android.

This process takes about 5 minutes.

 

OTA keeps addons, so just install and reboot.  But since it is done in the background, it can take up to an hour or so.

 

Yes, thanks.  That is what I do exactly.  🙂  (I do the same procedure with my Samsung TAB S with Lineage.)

Link to post
Share on other sites

Is it possible to install Magisk from Lineage's recovery? If not, what's a good alternative to AdAway?

I've encountered a weird bug. Wi-Fi wouldn't turn on, and rebooting from the power menu didn't work, I had to force reboot by holding the power button for a long time.

Edited by hxkafg
Link to post
Share on other sites
1 hour ago, hxkafg said:

Is it possible to install Magisk from Lineage's recovery? If not, what's a good alternative to AdAway?

I've encountered a weird bug. Wi-Fi wouldn't turn on, and rebooting from the power menu didn't work, I had to force reboot by holding the power button for a long time.

You can download a flashable Magisk from here:

https://github.com/topjohnwu/Magisk/releases/

You flash it as in step 3 of @tdm's list above.

Then you just download the Magisk Manager as I recall.  Been a while since I used this as I switched to addonsu, but I'll probably have to go back to Magisk I think with LOS 17. 

Edited by Hook
  • Thanks 2
Link to post
Share on other sites

Hi all, I just updated to 20200831 by downloading the zip file from LOS website to my sdcard, and then applying the update via Recovery.

This time around I tried opengapps 'aroma' flavour so I could tweak which google apps I really want. Turned out installing not much, and especially ommitting gboard so I could take advantage of LOS's AOSP keyboard (sticky Shift, SYM shortcut, etc.).

So, if anyone is wondering whether they can use opengapps-aroma? IT WORKS.

Oh, by the way. The Lineage stock apps seem to be cool. I ended up installing a minimal set o Gapps and feel good I did it since the LOS counterparts are good.

  • Like 6
Link to post
Share on other sites

questions for los users...how is it by you with keyboard backlight? Are you able to set backlight brightness?

....and how about backlight when phone is closed?

i have forgot to test it because i was on los for only few  days and now i am on aex.

By me is keyboard backlight on with display on.

EDIT EDIT...i see now, sometime is capslock button stuck or works like vice versa...if this happens then i have problem with kb on/off backlight

Edited by CornholioGSM
Link to post
Share on other sites
1 hour ago, CornholioGSM said:

questions for los users...how is it by you with keyboard backlight? Are you able to set backlight brightness?

....and how about backlight when phone is closed?

i have forgot to test it because i was on los for only few  days and now i am on aex.

By me is keyboard backlight on with display on.

EDIT EDIT...i see now, sometime is capslock button stuck or works like vice versa...if this happens then i have problem with kb on/off backlight

 

Yeah, caps lock is a funny thing. The kernel controls the LED, but user space has the logic. So they can, and sometimes do, get out of sync.

 

  • Like 1
Link to post
Share on other sites
6 hours ago, marmistrz said:

Is the 20200831 OTA safe to install? there was a lot of trouble with 20200824 (system not booting), wondering if anyone had similar issues with 20200831

Or should I just flash the update with adb sideload?

 

Lineage, like a lot of custom ROMs out there, builds on a schedule regardless of whether there are any actual changes.

 

There are exactly zero actual code changes between 20200824 and 20200831.  All of the changes in that week are administrative (adding supported devices, updating the wiki, etc.)  So that means:

 

 - You do not need to update, there is nothing actually updated.  Feel free to dismiss the OTA notification.

 

 - The update should not cause any issues if it is applied correctly and successfully.

 

  • Thanks 3
Link to post
Share on other sites
On 8/31/2020 at 4:14 AM, DieBruine said:

I just wanted to point out that it doesn't matter what I try. It's always like this. My son for instance doens't even use the keyboard because of this bug. All phones in our household show this bug. Just tell me how I can heelp and I will.

 

Here is the debug kernel: http://files.nwwn.com/android/pro1/boot-keylog.img

 

The file /sys/devices/soc/c17a000.i2c/i2c-6/6-0058/keylog records the last 256 key press/release events, one per line. The line format is:

xxxxxxxx dK

Where:

xxxxxxxx is the time stamp in jiffies (1/100 sec), in hex.

d is the direction, > for press, < for release.

K is the key (without modifiers).

 

It will only log the normal keys, not the gpio keys (shift, ctrl, alt, logo).

 

You will need root access to read the file. I suggest an adb root session.

 

If the kernel is showing missed or duplicate keys, the kernel or the hardware is at fault. If the kernel is showing correct keys, android is at fault.

 

  • Thanks 5
Link to post
Share on other sites
On 9/6/2020 at 5:17 AM, tdm said:

 

If the kernel is showing missed or duplicate keys, the kernel or the hardware is at fault. If the kernel is showing correct keys, android is at fault.

 

Sorry, still busy renovating my garage 🥴.
Flashed the boot just this morning. Everything I type shows up double in de keylog. Some keys how up as question marks.

This is what I typed:
die overgang
De moet ik nu dus gaan herstellen voordat ik de berging kan afmaken

Ai, ben echt veel tegengekomen

 

Log included.... 

In the second line, "De moet" it should state "Die moet".

keylog

Edited by DieBruine
  • Thanks 1
Link to post
Share on other sites
9 hours ago, DieBruine said:

Sorry, still busy renovating my garage 🥴.
Flashed the boot just this morning. Everything I type shows up double in de keylog. Some keys how up as question marks.

This is what I typed:
die overgang
De moet ik nu dus gaan herstellen voordat ik de berging kan afmaken

Ai, ben echt veel tegengekomen

 

Log included.... 

In the second line, "De moet" it should state "Die moet".

keylog 2.99 kB · 2 downloads

 

The keys are double because there is one entry for press and one entry for release.  Backspace, DEL, and a couple others will show "?".

 

Yes, in your log, at the start of the second line, it missed the "i" completely.  I find it interesting that most of the time you hold a key for about 10 to 20 jiffies, but those particular lines are the same timestamp:

 

0000551c <D
0000551c >E
0000551c >

 

In other words, the log says you released D, then pressed E and space all within the same 0.01 second interval.  That seems unlikely.  But only you can know for sure what happened.

 

In order to detect multiple simultaneous key presses, the keyboard driver switches to polling mode while any key is pressed.  This means it scans the keyboard periodically to see if there have been any changes to the keyboard state.  The default poll interval is 40ms, which should be plenty of time to detect most changes.  But you seem to be a pretty fast typist and perhaps your kernel gets too busy at times.  Try setting the fast poll option in the device settings and see if that helps at all.  And another log of missed keys might also be helpful.

 

  • Like 3
Link to post
Share on other sites
12 hours ago, tdm said:

 

That log was a bad example, first thing after reboot. Afterwards the keyboard went haywire again, but I didn't have my laptop with me. I can already tell you it didn't help to switch to fast polling, just by this edit. While I'm typing this response, I have had three special characters, a couple of missed letters and one enter...

keylog

Edit:

Could you change the boot.img to log a 1000 or even 100000 characters? This is another bad example. The first three sentences produced the errors. The last two had no errors. But those are the ones with the last 256 characters. I don't mind logging 10000 characters. It just gives me a little bit more time to get the log from my device. 256 characters is a bit on the low side I think. 

"I have had three special charactErs" -> This "E" did not register. 

Edited by DieBruine
Link to post
Share on other sites
17 minutes ago, DieBruine said:

That log was a bad example, first thing after reboot. Afterwards the keyboard went haywire again, but I didn't have my laptop with me. I can already tell you it didn't help to switch to fast polling, just by this edit. While I'm typing this response, I have had three special characters, a couple of missed letters and one enter...

keylog 2.99 kB · 0 downloads

Edit:

Could you change the boot.img to log a 1000 or even 100000 characters? This is another bad example. The first three sentences produced the errors. The last two had no errors. But those are the ones with the last 256 characters. I don't mind logging 10000 characters. It just gives me a little bit more time to get the log from my device. 256 characters is a bit on the low side I think. 

"I have had three special charactErs" -> This "E" did not register. 

 

Well, if fast poll does not help, I am wondering if there is some sort of hardware issue. The only two things I can think to try are:

(1) making the keyboard poll code into a thread that runs at high priority. This would be fairly easy but I doubt it would change much.

(2) not using polling at all. This would severely limit the ability to detect certain key combinations, like the bad old original stock keyboard driver. I don't think you or anyone else would want that.

 

Regarding the log size, I can make it larger but I think it would need to be in /proc. I think files in /sys are limited to 4kb in size.

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Terms