Jump to content

LineageOS 16.0 Official Builds: Discussion


Recommended Posts

Thank you!

I actually don't know how this fixed because I only did a few bits of what you suggested and then I rebooted and it works again! OMFG Android is a touchy nightmare. I know lots of you have put a lot of work in to Lineage but seriously.......!

 

Anyway, Eske, thank you for being so speedy!

  • Like 2
Link to post
Share on other sites
  • Replies 580
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

I am pleased to announce that the Pro1 has received official support in LineageOS 16.0.   You can find the builds and installation instructions on the official LineageOS Downloads page.

Lineage recovery will offer to install from sdcard if, and only if, a physical sdcard is present and it is able to be read without any decryption (eg. it is not used as adoptable storage).  

Sorry guys, I'm a bit busy with work lately, plus just had a couple kids birthdays.  But I'll get the kernel with stock keyboard driver as soon as I can.  

Posted Images

Hi everyone,

 

I would like to back up the phone to my computer, as I now have it, kind of, set up like I would like it to run.

 

I currently have LOS and installed the Google apps: I've found the Backup page in settings and it backs up to Google Drive.  If I needed to wipe the phone in the future, when I restore it will it just look exactly like it does now? E.g. Apps, settings, the fine details of Nova Launcher, etc?

If I decide to try LOS WITHOUT GOOGLE or SAILFISH, I presume that the above backup will no longer be of use!

How do I backup the phone in another way? I see something like TWRP mentioned in these forums... is this what I need to be researching?

If I want to try LOS without the Google services, can I delete them somehow from the current installation of LOS, or do I need to do a fresh install, missing out the Google apps/services?

If I want to try Sailfish, what do I use to back up the phone so that I can easily restor it to LOS as it is now, rather than starting afresh with it?

 


Thanks,

James

  • Like 1
Link to post
Share on other sites
1 hour ago, jamescarruthers said:

Hi everyone,

 

I would like to back up the phone to my computer, as I now have it, kind of, set up like I would like it to run.

 

I currently have LOS and installed the Google apps: I've found the Backup page in settings and it backs up to Google Drive.  If I needed to wipe the phone in the future, when I restore it will it just look exactly like it does now? E.g. Apps, settings, the fine details of Nova Launcher, etc?

 

I believe the backup page you are seeing is for Google stuff.  It does not backup app data or system settings, as far as I know.

 

1 hour ago, jamescarruthers said:

If I decide to try LOS WITHOUT GOOGLE or SAILFISH, I presume that the above backup will no longer be of use!

How do I backup the phone in another way? I see something like TWRP mentioned in these forums... is this what I need to be researching?

 

A fully functional TWRP is one way to do a full backup of your data.  However, we do not have a fully functional TWRP yet -- the feature you need to make this work is data decryption, and I have not gotten that working yet.  It's pretty high on my todo-list though.

 

If you are familiar with Unix/Linux commands, you can use "dd" (paired with "gzip") to backup your data to a PC.  There really isn't any other option to do a full data backup right now.

 

1 hour ago, jamescarruthers said:

If I want to try LOS without the Google services, can I delete them somehow from the current installation of LOS, or do I need to do a fresh install, missing out the Google apps/services?

 

You need to do a fresh install.

 

1 hour ago, jamescarruthers said:

If I want to try Sailfish, what do I use to back up the phone so that I can easily restor it to LOS as it is now, rather than starting afresh with it?

 

This is not a full one-stop backup solution, but it may work for you.

 * For app data, use "adb backup".

 * For media (pictures etc.) backup to a PC over MTP/PTP.

 

  • Thanks 2
Link to post
Share on other sites
1 hour ago, jamescarruthers said:

I currently have LOS and installed the Google apps: I've found the Backup page in settings and it backs up to Google Drive.  If I needed to wipe the phone in the future, when I restore it will it just look exactly like it does now? E.g. Apps, settings, the fine details of Nova Launcher, etc?

Unfortunately no. Not all settings&data are restored.

SMS&MMS is one thing they do not handle well...

Link to post
Share on other sites
5 hours ago, tdm said:

 

I believe the backup page you are seeing is for Google stuff.  It does not backup app data or system settings, as far as I know.

 

 

A fully functional TWRP is one way to do a full backup of your data.  However, we do not have a fully functional TWRP yet -- the feature you need to make this work is data decryption, and I have not gotten that working yet.  It's pretty high on my todo-list though.

 

If you are familiar with Unix/Linux commands, you can use "dd" (paired with "gzip") to backup your data to a PC.  There really isn't any other option to do a full data backup right now.

 

 

You need to do a fresh install.

 

 

This is not a full one-stop backup solution, but it may work for you.

 * For app data, use "adb backup".

 * For media (pictures etc.) backup to a PC over MTP/PTP.

 

Much appreciated!

Link to post
Share on other sites

Also testing kbd-3 here on my QWERTZ. While button mashing I ran into the issue again where the keyboard completely locks up (save for the Alt key) - so I tried to reproduce it...

As far as I see, you can trigger this by pressing two keys at exactly the same time. I managed to lock the keyboard up after just a few tries with X+D or W+S with my big enough left thumb.

  • Thanks 3
Link to post
Share on other sites
1 hour ago, Wheeljack said:

Also testing kbd-3 here on my QWERTZ. While button mashing I ran into the issue again where the keyboard completely locks up (save for the Alt key) - so I tried to reproduce it...

As far as I see, you can trigger this by pressing two keys at exactly the same time. I managed to lock the keyboard up after just a few tries with X+D or W+S with my big enough left thumb.

Thanks I'll look into that.

 

  • Thanks 2
Link to post
Share on other sites
56 minutes ago, jamescarruthers said:

When I tried to load v2 of that file, the phone broke for some reason. It did ccome back to life though but I'm not quite sure what I did.

 

If I wait, will this come through the usual Lineage OS updates?

Yes, once we isolate the issue and fix it.

Link to post
Share on other sites
Quote

Also testing kbd-3 here on my QWERTZ. While button mashing I ran into the issue again where the keyboard completely locks up (save for the Alt key) - so I tried to reproduce it...

As far as I see, you can trigger this by pressing two keys at exactly the same time. I managed to lock the keyboard up after just a few tries with X+D or W+S with my big enough left thumb.

I confirm, 2 keys at same time, and keyboard locks up and then... rebooting the phone, no other ways ...

  • Thanks 1
Link to post
Share on other sites
On 10/10/2020 at 5:18 AM, tdm said:

IIRC, the keyboard backlight should always be on if, and only if, both the display is on and the slider is out.

The keyboard backlight code (and LED light code) is here:

https://github.com/LineageOS/android_device_fxtec_pro1/blob/lineage-16.0/light/Light.cpp

 

I must admit that, since posting my above comment about the keyboard backlight switching off, I have been unable to reproduce that behaviour ... 

I must have been doing something very unusual when that happened - I was messing a lot with my (rooted) chroot setup back then, maybe that can have some crazy side effects.

Whatever. Thanks for clarifying the backlighting logics for me and even pointing me to the code, tdm. If I ever reproduce the bug, knowing how things are supposed to behave will certainly be useful.

  • Like 1
  • Thanks 1
Link to post
Share on other sites
On 10/22/2020 at 5:18 AM, Linkandzelda said:

I'm currently running the first LOS official build with Magisk installed. How can I update to the latest OTA? I am worrying about bricking or something. Thanks

That's almost my setup, and I just use the build in OTA updater. I used one of the first official builds, had magisk installed, and no gapps or microg. I used the OTA to update to a build a couple of weeks later without issues, and have since just updated weekly without issues. 

There were some other comments a bit earlier about methods that should have a bit more backups. So if you're worried I'd recommend to check those out. But it's probably fine, and any "brick" from using the OTA should be relatively easy to fix I'm guessing. Hoping some others would chime in though.

Link to post
Share on other sites
16 hours ago, Zamasu said:

That's almost my setup, and I just use the build in OTA updater. I used one of the first official builds, had magisk installed, and no gapps or microg. I used the OTA to update to a build a couple of weeks later without issues, and have since just updated weekly without issues. 

There were some other comments a bit earlier about methods that should have a bit more backups. So if you're worried I'd recommend to check those out. But it's probably fine, and any "brick" from using the OTA should be relatively easy to fix I'm guessing. Hoping some others would chime in though.

Thanks for the info, do you know how I can make a full backup before doing anything? Also did you have to reinstall magisk? I currently have gapps installed.

Thanks

Link to post
Share on other sites
On 10/24/2020 at 2:32 AM, Linkandzelda said:

Thanks for the info, do you know how I can make a full backup before doing anything?

Short answer, no I don't know. Long answer, I use oandbackup from f-droid to create a backup of all apps, but I never tested it so I don't know if the backup actually works. There should also be a backup function in adb I think, and there's titanium backup, but I haven't really used both of those. 

On 10/24/2020 at 2:32 AM, Linkandzelda said:

Also did you have to reinstall magisk?

No. Only when I went from unofficial to official, when I used adb to flash it. I'd assume it works the same with gapps by the way. 

Link to post
Share on other sites
4 hours ago, Wheeljack said:

Installed lineage-16.0-20201026-nightly-pro1-signed via OTA. Phone still in working condition, nothing unusual to report 😉

Where can one actually see that version information?

I just realised that in my "Settings -> About phone" it says

"Build number: lineage_pro1-userdebug 9 PQ3A 190801.002 0450462ee2".

As every week, I also just did the OTA update, and the Updater does tell me that I am now on "LineageOS 16.0 / 26 October 2020" with no further updates available. So, where does that old build number come from on my system?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Terms