Jump to content

LineageOS 16.0 Official Builds: Discussion


Recommended Posts

18 hours ago, claude0001 said:

[...] I found out today that GPS is not working anymore. [...] I am presently on "16.0-20201026-NIGHTLY-pro1" [...]

OK. Problem solved (for now).

I re-flashed the same 16.0-20201026-NIGHTLY-pro1 via sideload and guess what: GPS is working again. Previously it had been installed via OTA update. No idea what may have gone wrong there.

Thanks to all for your support.

  • Thanks 3
Link to post
Share on other sites
  • Replies 642
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

I am pleased to announce that the Pro1 has received official support in LineageOS 16.0.   You can find the builds and installation instructions on the official LineageOS Downloads page.

Lineage recovery will offer to install from sdcard if, and only if, a physical sdcard is present and it is able to be read without any decryption (eg. it is not used as adoptable storage).  

In my opinion LineageOS 16 was a very important OS for the Pro1 that brought the best out of the device at a moment when stock couldn't (yet) . Although not a developer, I can well imagine it also bro

Posted Images

1 hour ago, claude0001 said:

OK. Problem solved (for now).

I re-flashed the same 16.0-20201026-NIGHTLY-pro1 via sideload and guess what: GPS is working again. Previously it had been installed via OTA update. No idea what may have gone wrong there.

Thanks to all for your support.

Are you using gapps or not?

Link to post
Share on other sites
3 hours ago, claude0001 said:

OK. Problem solved (for now).

I re-flashed the same 16.0-20201026-NIGHTLY-pro1 via sideload and guess what: GPS is working again. Previously it had been installed via OTA update. No idea what may have gone wrong there.

Thanks to all for your support.

Interesting. I'm using sideloading too so that could be why I did not see it, (gave up on OTA for Lineage a while back)

  • Like 1
Link to post
Share on other sites

  A LOS question from another thread

2 hours ago, proprog said:

I have no luck with LOS and swedish keyboard on my QWERTZ phone. Whatever I try I can not write the swedish characters and @ with the same configuration. One of them is always broken (at the moment I can write å, ä, ö but yellow key plus q just gives a capital Q). I have tried with and without FinQWERTY with no luck. All help is appreciated.

This is not limited to Swedish. How do we get to standard symbols like these? It is accessible when German is selected though.

Link to post
Share on other sites
1 hour ago, EskeRahn said:

  A LOS question from another thread

This is not limited to Swedish. How do we get to standard symbols like these? It is accessible when German is selected though.

I'm not super familiar with Intl keyboard layouts, but my guess is that keyboards for these languages are different than German. I setup the key map to match the labels, which I believe is German.

 

Since the key map is fully customizable, I could add options for the language in settings. Say, qwerty, qwertz/German, qwertz/Swedish, etc. But I would need help getting those right.

  • Thanks 1
Link to post
Share on other sites
10 minutes ago, tdm said:

I could add options for the language in settings. Say, qwerty, qwertz/German, qwertz/Swedish, etc. But I would need help getting those right.

That would be awesome, thanks. Danish and Swedish I tested seems quite close, but @ is unobtainable.
Let me try both on the qwerty and qwertz variant and get back to you ASAP.
(Swedish, Danish and Norwegian are identical except the three national letter keys that are already handled)

Link to post
Share on other sites
42 minutes ago, daniel.schaaaf said:

Is there a way to define a key on the hardware keyboard as a dead key? I would so much like to type ä, å, and the like by typing e.g. "dead key + a = ä" or "dead key + p =å". I couldn't figure out how to do this with Keyboard Mapper.

It is technically possible. @Anssi Hannula is doing this with FinQwerty, Though this is for Stock, it is open source and I can not imagine that it can not be modified to suit LOS

  • Thanks 1
Link to post
Share on other sites
1 hour ago, _DW_ said:

How come?  takes ages but it gets there eventually I just leave it to it 🙂

...uh new forum bug, threw away my answer....

But well just tried to say i do not recall the detail of what didn't work, but posted it here, so a matter of browsing this or the original thread....

 

Link to post
Share on other sites

Any chance of the upgraded keyboard files being in the version 17 LOS files? I had a really busy few days at work recently which would have been a pleasure on my Passport but were quite trying when typing fast on the Pro1 with LOS: random extra characters, deleting the odd few words and moving the cursor of its own accord now and again!

Link to post
Share on other sites
7 hours ago, jamescarruthers said:

Any chance of the upgraded keyboard files being in the version 17 LOS files? I had a really busy few days at work recently which would have been a pleasure on my Passport but were quite trying when typing fast on the Pro1 with LOS: random extra characters, deleting the odd few words and moving the cursor of its own accord now and again!

No but if I can get the issue sorted out and fixed I'll get that change in both versions. Are you willing to test?

Link to post
Share on other sites

I experienced some issues

Audio quality for calls is bad sometimes (robotic voice) both on speaker and bluetooth.

 

I had issues with LTE connections, might have been the settings since there were some many options. 

What information is needed to report this?

Link to post
Share on other sites
8 minutes ago, pebert said:

What information is needed to report this?

Anyway, can you find a way how you can reproduce it?

I mean a specific place, a way of holding the phone at the specific place, a specific way of using like in a moving vehicle, an active wlan or bluetooth connection, etc?

So, anything related.

Link to post
Share on other sites
On 11/6/2020 at 1:52 PM, VaZso said:

Anyway, can you find a way how you can reproduce it?

I mean a specific place, a way of holding the phone at the specific place, a specific way of using like in a moving vehicle, an active wlan or bluetooth connection, etc?

So, anything related.

I will install it again and test. 

 

  • Thanks 1
Link to post
Share on other sites

Wondering why no new OTA updates had been offered for a while, I checked

https://www.lineageoslog.com/16.0/pro1

There it says: "The selected device is not currently supported in LineageOS 16.0":

image.thumb.png.91c1aa20155fc567f8b32afe908db4d2.png

 

As one sees, it is also suggested that only LineageOS 17.1 is supported on the Pro1. However, a stable build of that does not seem to be available yet, as far as I know.

Have updates of 16.0 been abandoned in the process of porting 17.1 to the pro1?

 

Edited by claude0001
Link to post
Share on other sites
1 hour ago, Wheeljack said:

Something seems to be borked with the scheduler [...]

Well, on October 31 the target "pro1 userdebug lineage-17.1" was added to the build system while "pro1 userdebug lineage-16.0" was removed. That does not seem like a malfunction, it was done on purpose. See the diff here:

https://review.lineageos.org/c/LineageOS/hudson/+/290451/

Until the respective target is re-added, the build system will not compile 16.0 for our device anymore.

Independently of that, the build(s?) for 17.1 seem(s?) to have failed last Monday, as a patch to fix a build error was introduced on Monday evening:

https://review.lineageos.org/c/LineageOS/android_hardware_qcom_media/+/288323/

IMHO it would be good to keep building 16.0 for the Pro1 until 17.1 is known to be a fully stable replacement for it ...  

Edited by claude0001
  • Like 1
  • Thanks 2
Link to post
Share on other sites
On 11/9/2020 at 12:00 PM, claude0001 said:

[...] Have updates of 16.0 been abandoned in the process of porting 17.1 to the pro1? [...]

Bumping my question from above as the silence about this worries me a little bit. After all, LineageOS 16 is the very topic of this thread.

I was hoping to keep LOS 16 on my device for a while, not expecting it to be abandoned so quickly.

I worry that 17.1 will not work as a drop-in replacement for me due to the absence of AddonSU, which was a nicely integrated and low-profile root-management solution. I require permanent root access for several things (SSH server, Debian Chroot, cross-system file management), but I obviously do not want random apps to be able to su all the time.

I read about magisk of course, but it is not an "official" solution and a much heavier application - two facts I worry about in such a (safety-) critical system component. Also -- from what I read at least -- it is much more tricky to install (does not work with Lineage recovery, I guess) and integrates less nicely into Lineage (does not survive OTA updates?).

So ... could anyone with background knowledge comment on the future of 16.0? Do I have to prepare for the transition already? @tdm, maybe?  

Link to post
Share on other sites

I'm only seeing the 17.1 build in the queue for today.  I don't know if there were cases where 16 and 17 builds for the same device were run side by side.

On another note... I'm running 16.0 with MindTheGapps. What are my options when upgrading to 17.1 (since OpenGapps is recommended now)?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Terms