Jump to content

LineageOS 16.0 Official Builds: Discussion


Recommended Posts

17 minutes ago, EskeRahn said:

Hmm I'm not sure if the Pro1 got VoLTE or not.

Have a look at these two images from a Pro1 on Lineage (Dark) and stock (light) - same sim moved over, same place. Notice how it is greyed out in stock.

 

Screenshot_20200723-232827.png

Screenshot_20200723-232955_Settings.png

 

PS the "Preferred network type" follows the sim. Inserting another sim in Stock it says "LTE/WDCMA"

Except, on stock with a VoLTE enabled SIM, you can switch those sliders on and for those who have succeeded with Verizon (including me during the period it was working), that is how you got Verizon to work.  So, yes, it must be capable. That's not to say it couldn't b badly implemented.  I have no idea.

Link to post
Share on other sites
  • Replies 494
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

I am pleased to announce that the Pro1 has received official support in LineageOS 16.0.   You can find the builds and installation instructions on the official LineageOS Downloads page.

Lineage recovery will offer to install from sdcard if, and only if, a physical sdcard is present and it is able to be read without any decryption (eg. it is not used as adoptable storage).  

Nice!   Note that 17.1 will be relatively easy with 16.0 working.  It should be ready within a week or two.  Nolen and Ethan are making great progress.  

Posted Images

Just now, Hook said:

Except, on stock with a VoLTE enabled SIM, you can switch those sliders on and for those who have succeeded with Verizon (including me during the period it was working), that is how you got Verizon to work.  So, yes, it must be capable. That's not to say it couldn't b badly implemented.  I have no idea.

On mine it is opposite, they are greyed on stock.

Link to post
Share on other sites
3 minutes ago, EskeRahn said:

On mine it is opposite, they are greyed on stock.

Hmmmm. Interesting.  Do you know that your SIM is VoLTE enabled?  And I assume you have VolTE coverage? 

Link to post
Share on other sites
Just now, Hook said:

Hmmmm. Interesting.  Do you know that your SIM is VoLTE enabled?  And I assume you have VolTE coverage? 

The carrier should support VoLTE, but I have no idea if it is active on Lineage.

Link to post
Share on other sites

I looked at the fingerprint briefly, and noticed that one of my fingerprints keep getting it's md5sum changed.  I assume it's one, I have 3 fingerprints saved and each one is in the directory plus a .bak file.  Deleting them and re-adding them still gives the same result though.  I've tried setting the modify time back, and copying over the old files, but the apps still detect a fingerprint change.  I'm not sure if the md5sum should ever change or not, I really don't see why it would. I'll look into this some more.

  • Thanks 2
Link to post
Share on other sites

Hello, I'm using Lineage since build test18. Great work ! I have also two issues, one with sms/mms sending, it work but only when he wants. Perhaps I send a sms or mms in a few seconds, sometimes it doesn't send anything for two days. Maybe issue with operator I don't know (I'm in France, SFR Mobile) but it worked well with an old samsung.

Second issue is with time/date : everytime I shutdown the pro1 I have time reinitialised at 20 july, 4h17 am. So no awaking clock available, and I can't work with that if no network.

I have done a full reinstall with the last official Lineage (fastboot *.img and adb *.zip, with Mindthegapps and su-add) with complete wipe data, but it looks same as it was. Maybe somebody has an idea, something I can do ?

Thanks (and sorry for my bad english)

Link to post
Share on other sites
1 hour ago, raymo said:

Hello, I'm using Lineage since build test18. Great work ! I have also two issues, one with sms/mms sending, it work but only when he wants. Perhaps I send a sms or mms in a few seconds, sometimes it doesn't send anything for two days. Maybe issue with operator I don't know (I'm in France, SFR Mobile) but it worked well with an old samsung.

Second issue is with time/date : everytime I shutdown the pro1 I have time reinitialised at 20 july, 4h17 am. So no awaking clock available, and I can't work with that if no network.

I have done a full reinstall with the last official Lineage (fastboot *.img and adb *.zip, with Mindthegapps and su-add) with complete wipe data, but it looks same as it was. Maybe somebody has an idea, something I can do ?

Thanks (and sorry for my bad english)

 

The SMS/MMS issue is most likely an issue with your operator/carrier.  But even if it is the phone, all of the radio code is closed source and copied exactly from stock.  So I almost surely could not fix it.

 

Unfortunately, Qualcomm devices do not have an RTC.  So the date/time needs to be set at each boot.  Normally, the date/time can be set via either a broadcast from your operator/carrier or via NTP with a WiFi connection.  But when neither are available, the date/time is indeterminate.  Qualcomm does make some attempt to save the current date/time at shutdown, but this code is closed source so I do not know exactly how or why or when (or if!) it works.

 

  • Thanks 2
Link to post
Share on other sites

Thanks for your reply. I will check apn's config more in depth.
I'm surprised, no RTC in Qualcomm's device, that look strange for me. My HP48 is practically on schedule since 1993.

 

  • Haha 1
Link to post
Share on other sites

https://wiki.postmarketos.org/wiki/Qualcomm_Snapdragon_835_(MSM8998)#:~:text=MSM8998 (or Snapdragon 835) is,towards the end of 2018.

Real-time clock (RTC)

The RTC module found on the PM8998 PMIC block works with CONFIG_RTC_DRV_PM8XXX enabled. It can be easily tested from userspace like so:

# cd /sys/class/rtc/rtc0/
# echo $((`cat since_epoch`+120)) > wakealarm

After running that and fully powering down the device it should power on by itself soon afterwards (2 minutes later to be exact).

  • Like 1
  • Thanks 1
Link to post
Share on other sites
Posted (edited)
34 minutes ago, EskeRahn said:

https://wiki.postmarketos.org/wiki/Qualcomm_Snapdragon_835_(MSM8998)#:~:text=MSM8998 (or Snapdragon 835) is,towards the end of 2018.

Real-time clock (RTC)

The RTC module found on the PM8998 PMIC block works with CONFIG_RTC_DRV_PM8XXX enabled. It can be easily tested from userspace like so:

# cd /sys/class/rtc/rtc0/
# echo $((`cat since_epoch`+120)) > wakealarm

After running that and fully powering down the device it should power on by itself soon afterwards (2 minutes later to be exact).

Sorry, I misspoke.  Yes, there is an RTC.  Yes, it can be programmed to power on for an alarm.  No, it cannot keep time while off.

Edited by tdm
  • Like 1
  • Thanks 2
Link to post
Share on other sites
On 7/24/2020 at 12:17 AM, EskeRahn said:

The carrier should support VoLTE, but I have no idea if it is active on Lineage.

...Just ordered a new SIM from a provider I'm certain offers VoLTE, so will know in a few days if it works on Lineage (and stock), selecting LTE only as band. 🙂

  • Thanks 2
Link to post
Share on other sites
On 7/23/2020 at 1:30 PM, tdm said:

Nothing uses 3G anymore.  You should be fine.  But VoLTE is working on Verizon, I believe, so it will probably also work on AT&T.  Give it a shot.

So I put my sim in an AT&T iPhone 7 and had them activate VoLTE.  Put it back in my pro1, but still no luck.  Rebooted, but now it's hung again on the boot....no adb at this point either....again.  What do I need to do to get that enable on boot again?  I'm just making a new build for now and gonna flash it, hoping it resolves but clearly something else is going on as this is the second time this happened.  Logcat would REALLY help out here...😢

So basically, I don't know if it's working yet but my first test was a failure...before i tried the unthinkable act of rebooting....

Edited by JooJooBee666
Link to post
Share on other sites
20 minutes ago, JooJooBee666 said:

@tdm Do you know what I need to do to allow ADB Shell to work from recovery?

adb should be enabled, you just need to auth. Extract your boot image, add your host adb key to /adb_keys, repack, and flash. Alternatively, instead of adding your key, you can disable adb auth in default.prop.

Link to post
Share on other sites
37 minutes ago, tdm said:

adb should be enabled, you just need to auth. Extract your boot image, add your host adb key to /adb_keys, repack, and flash. Alternatively, instead of adding your key, you can disable adb auth in default.prop.

That's what I did.  I added the following to system_prop.mk:

# ADB Overrides
PRODUCT_SYSTEM_DEFAULT_PROPERTIES += \
    persist.service.adb.enable=1 \
    persist.service.debuggable=1 \
    persist.sys.usb.config=mtp,adb
	

Rebuilding now.  Should that work or do I need to do more?

Update: @tdm  This did NOT work.  I flashed the new build, restarted, hung at boot animation and:

$ adb logcat
- waiting for device -
	

Any other suggestions?

Edited by JooJooBee666
Link to post
Share on other sites
33 minutes ago, JooJooBee666 said:

That's what I did.  I added the following to system_prop.mk:

# ADB Overrides
PRODUCT_SYSTEM_DEFAULT_PROPERTIES += \
    persist.service.adb.enable=1 \
    persist.service.debuggable=1 \
    persist.sys.usb.config=mtp,adb
	

Rebuilding now.  Should that work or do I need to do more?

Let's not spam users with dev stuff. PM me if you need further help.

  • Thanks 1
Link to post
Share on other sites
4 hours ago, JooJooBee666 said:

So I put my sim in an AT&T iPhone 7 and had them activate VoLTE.  Put it back in my pro1, but still no luck.  Rebooted, but now it's hung again on the boot....no adb at this point either....again.  What do I need to do to get that enable on boot again?  I'm just making a new build for now and gonna flash it, hoping it resolves but clearly something else is going on as this is the second time this happened.  Logcat would REALLY help out here...😢

So basically, I don't know if it's working yet but my first test was a failure...before i tried the unthinkable act of rebooting....

Device booted.  It's still NOT working.  Confirmed it's working on the other device but when I put the sim in the pro1, the call just fails immediately if I have LTE only set.

 

Update: It started working after I toggled all the settings under *#*4636#*#.  YAY!

Edited by JooJooBee666
  • Like 1
Link to post
Share on other sites

FWIW, I thought I should note on this thread why my device was not booting anymore, even on a new build: Magisk.  Some of the recent changes must have broken this.  I tried an older version and the latest from the canary channel, same problem.  Back to standard SU for now.

Edited by JooJooBee666
  • Thanks 1
Link to post
Share on other sites
9 minutes ago, JooJooBee666 said:

FWIW, I thought I should note on this thread why my device was no booting anymore, even on a new build: Magisk.  Some of the recent changes must have broken this.  I tried an older version and the latest from the canary channel, same problem.  Back to standard SU for now.

Thanks for noting that.

 

Now it is clear why developers don't like nor support magisk. My fault for not asking if you had it installed.

  • Thanks 1
Link to post
Share on other sites

Just been offered a new official OTA. I will attempt to let it do it OTA on one of them..... (it has gone up a substantial 50MB, so would be interesting to know what has been added)

ADD I: Download and manual flashing worked fine.

ADD II: OTA download&update took an hour, but it got through this time.

  • Thanks 4
Link to post
Share on other sites

F(x)tec Pro1 is in the news!

Quote

Lastly, the LineageOS team has also added support for the F(x)tec Pro1, a productivity-oriented device with a physical slide-out QWERTY keyboard. Although the phone was launched in 2019 with Android 9 Pie, we have no word on when the official Android update arrives. If the physical keyboard form factor in 2020 isn’t brazen enough, users can try out LineageOS 17.1 to enjoy features from Android 10.

XDA did not understand something so don't get too excited. We are on LOS 16.0 so no LOS 17.1 (Android 10) yet. I believe that it is coming in future but we need to hold our horses for some time.

Edited by FlyingAntero
  • Thanks 3
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Terms