Jump to content

LineageOS 17.1 Official Builds: Discussion


Recommended Posts

  • Replies 88
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

I falshed mine, with no issues. Starting from LOS16.0, MindTheGapps and addonsu. Downloaded LOS17.1 https://download.lineageos.org/pro1 OpenGApps nano, ARM64, Android10.0 https://opengapps.o

Updated yesterday via sideload with nano opengapps and Magisk. No problems so far, even banking apps with nfc payments are working! 😀

Android 10 seems to present some additional challenges with the external SD card.  With Open Camera, I had to go to "more camera settings" as usual, but unlike with Android 9, I had to toggle on "Use

Posted Images

Hi!

So firts update the recovery to 17.1. Can i flash the new LOS 17.1 using the SDcard method? And keep my data?

I use openGapps already. But what i understand i have to download and install it again with the new LOS 17.1?

Link to post
Share on other sites
5 minutes ago, Breeze said:

Hi!

So firts update the recovery to 17.1. Can i flash the new LOS 17.1 using the SDcard method? And keep my data?

I use openGapps already. But what i understand i have to download and install it again with the new LOS 17.1?

 

sdcard should work, but I haven't personally tried.

 

Yes you need a gapps that matches your android version.  So, for example, opengapps for Android 10 (and arm64, of course).  Don't forget to switch slots with reboot/recovery before installing gapps.

 

  • Thanks 3
Link to post
Share on other sites
5 minutes ago, Breeze said:

Hi!

So firts update the recovery to 17.1. Can i flash the new LOS 17.1 using the SDcard method? And keep my data?

I use openGapps already. But what i understand i have to download and install it again with the new LOS 17.1?

I would download the opengapps for Android 10, as the one you are using currently are likely to be for 9.
I have not tried from SD, only ADB. But doubt that will make any principal  difference - obviously given it can read the SD.

  • Thanks 1
Link to post
Share on other sites

Here my slightly adjusted helper batch-script. Takes date YYYYMMDD as a parameter and assumes, the img, zip, and the nano is in a LineageOS subdirectory.
(Note that I do not plan to download and change the OpenApps package each time, so the 20201110 is fixed here, And obvious if you want say the pico and not the nano, the name should be adjusted)

An example of a call:

LineageFLASH171.BAT 20201110

@ECHO off
if %1.==. goto :EOF
ECHO * Wait for boot to bootloader to finish (or do manually holding VolDown+Power)
adb reboot bootloader
pause
fastboot flash boot_a LineageOS\lineage-17.1-%1-recovery-pro1.img
fastboot --set-active=a
REM fastboot reboot recovery    does not work, so do manually:
ECHO * Roll down to "Recovery Mode" with VolDown, and press Power to select.
ECHO * Await recovery boot. Select "Apply update", "Apply from ADB" for main flash
pause
adb sideload LineageOS\lineage-17.1-%1-nightly-pro1-signed.zip
TimeOut 5 /nobreak>nul
ECHO * Click Advanced, "Reboot to recovery".
ECHO * Await recovery boot. Select "Apply update", "Apply from ADB" to add Gapps
pause
ECHO * When prompted (shortly after 47%%) click "yes" to "...Install anyway"
adb sideload LineageOS\open_gapps-arm64-10.0-nano-20201110.zip
TimeOut 5 /nobreak>nul
:NORM
ECHO * Click Reboot.
ECHO **DONE** Should now boot into LineageOS

 

  • Thanks 2
Link to post
Share on other sites
34 minutes ago, Breeze said:

https://wiki.lineageos.org/devices/pro1/upgrade

Doesn't say anything about switching slots.....

Step 6 says to reboot to recovery. This is where the slots are switched (active slot is set during LOS sideload but the change takes effect, when the device reboots).

 

And while we're on the subject of not finding settings... on LOS 16 I had deactivated my second SIM card in slot 2. Now I can't find where to activate it and the status bar lists one of the two networks with an X for no connection.

  • Thanks 2
Link to post
Share on other sites
13 hours ago, npjohnson said:

It is required - system mounts are handled differently, ROM will probably flash but GApps won't -- just use 17.1 recovery lol.

I flashed with 16.0 recovery. It worked. I'm not saying anybody else should do it, but in my case what happened is: after flashing, I remembered from when I first installed LOS, that a reboot should be done to switch between slots (A/B). I did that, and booted to recovery -- voila! A new, purple themed recovery UI appeared. From there I flashed OpenGapps and Magisk. All worked perfectly. It really was a total non-drama upgrade. Thanks!

  • Like 1
Link to post
Share on other sites
12 hours ago, Breeze said:

So firts update the recovery to 17.1. Can i flash the new LOS 17.1 using the SDcard method? And keep my data?

I did it from the SDCard, via recovery. It worked flawlessly.

Mind you, I didn't even flash the recovery via ADB first. In my case, I flashed the 17.1 image direclty, rebooted to recovery, automatically the new recovery was there in place of the old one.

Perhaps to be safe, you could flash the recovery via ADB, boot to recovery, and then flash 17.1 from SDcard.

  • Thanks 1
Link to post
Share on other sites
9 hours ago, EvilDragon said:

As I have some apps that need root:

Has anyone tried rooting 17.1? If yes, how did you do that?

I did it with Magisk. on 16.0 I always flashed addonSU first, then Magisk next. Turns out Magisk has all you need for root.

Link to post
Share on other sites

Woohoo! Even I managed to upgrade this time and I'm one of your dimmest members, spoilt by just running BB10 autoloaders and the occasional sideload through a GUI for all these years!

Good riddance to the awful navigation buttons from previous Android and hello being able to go back on the left of the screen whether it is in portrait or landscape mode!

I like Android a tiny bit more now!

  • Like 3
Link to post
Share on other sites
15 hours ago, jamescarruthers said:

I seem to have lost the telephone icon on installation on LOS 17!  Got it back but only after much hassle as I couldn't open the app drawer. With Nova you can only swipe up for the app drawer in portrait.

You can get the app drawer button back in Nova, I certainly have it. You'll need to add the button back as a widget:

  • Long press an empty spot on the home screen
  • Tap on widgets
  • Tap and drag the Nova action shortcut (should be the first one) into the dock or where ever you want it
  • Then tap on App drawer in the Nova Action menu
  • Like 2
Link to post
Share on other sites
1 hour ago, SCΛRECROW said:

You can get the app drawer button back in Nova, I certainly have it. You'll need to add the button back as a widget:

  • Long press an empty spot on the home screen
  • Tap on widgets
  • Tap and drag the Nova action shortcut (should be the first one) into the dock or where ever you want it
  • Then tap on App drawer in the Nova Action menu

Thanks for the tip. This adds a button to show the app drawer which isn't really what I want.  It is the swiping action up from those bottom icons (dock?) that would be nice to have in landscape as well as portrait.

Further evidence that Android is a disjointed mess but I will live with it for now! Thankfully I very rarely use the app drawer, but I needed it when my telephone icon was deleted from the dock during upgrade.

Link to post
Share on other sites
6 hours ago, jamescarruthers said:

Further evidence that Android is a disjointed mess

I believe this sort of is the norm in the tech industry. Started all the way back with the IBM PC - a "disjointed mess" of ready-made components. Oh what a success it was eh? 😁

Most times companies prefer the fast-to-market path, rather than the "perfect product" path. I'm not one to judge which way is the best, we have examples of both approaches that could be deemed to have failed... Windows Me (time-to-market) and GNU HURD (pefect product) come to mind. The HURD could be ressurected at some point and find a successful path, wheeras Windows Me is already buried and forgotten.

Edited by agent008
Grammar corrections
Link to post
Share on other sites

Is it just me, or are anyone else plagued by a series of spontaneous boots with 17.1? Even in complete idle on a desktop.
It is new for 17.1, I did not see this on 16.0. On this unit I did NOT do a wipe during the upgrade.

Screenshot_20201112-192803_3C_All-in-One_Toolbox.thumb.png.ddf3e42bc17130508cf233a543cf0934.png

Note that the AICP-Q, that is supposed to be rather similar, on another unit is NOT plagued by this.

ADD: This seems to be related to apps see later posts.

Link to post
Share on other sites
11 minutes ago, EskeRahn said:

Is it just me, or are anyone else plagued by a series of spontaneous boots with 17.1? Even in complete idle on a desktop.
It is new for 17.1, I did not see this on 16.0. On this unit I did NOT do a wipe during the upgrade.

Screenshot_20201112-192803_3C_All-in-One_Toolbox.thumb.png.ddf3e42bc17130508cf233a543cf0934.png

Note that the AICP-Q, that is supposed to be rather similar, on another unit is NOT plagued by this.

Being a former Priv user, I had gotten used to spontaneous reboots.

Fortunately 17.1 has been rock stable these couple days. Even better than 16.0 (wifi connections are way more stable). Only problem I had is I ran out of battery completely yesterday, and when I plugged it in it started but the screen digitiser was not working i.e. the phone wouldn't register my tapping, swiping etc.

I manages to use the keyboard to restart the phone, it started to work again. If anybody need to do this: open the keyboard, push the power button for a couple seconds to bring up the poweroff / restart menu. Then cycle between options with the TAB key, use Enter to confirm the highlighted entry.

  • Thanks 2
Link to post
Share on other sites
17 hours ago, jamescarruthers said:

Thanks for the tip. This adds a button to show the app drawer which isn't really what I want.  It is the swiping action up from those bottom icons (dock?) that would be nice to have in landscape as well as portrait.

Further evidence that Android is a disjointed mess but I will live with it for now! Thankfully I very rarely use the app drawer, but I needed it when my telephone icon was deleted from the dock during upgrade.

My apologies, I think that functionality existed in Nova running on Android 9 (LOS 16) but something messed it up in Android 10 (LOS 17).

 

3 hours ago, EskeRahn said:

Is it just me, or are anyone else plagued by a series of spontaneous boots with 17.1? Even in complete idle on a desktop.
It is new for 17.1, I did not see this on 16.0. On this unit I did NOT do a wipe during the upgrade.

Screenshot_20201112-192803_3C_All-in-One_Toolbox.thumb.png.ddf3e42bc17130508cf233a543cf0934.png

Note that the AICP-Q, that is supposed to be rather similar, on another unit is NOT plagued by this.

No spontaneous reboots here and I did not wipe my phone either. It's been up for over 42 hours since the last (user initiated) reboot.

  • Thanks 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Terms