Jump to content

LineageOS 17.1 Official Builds: Discussion


Recommended Posts

  • Replies 226
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Ah that sound the problem several have encountered with the earpiece. It seems to be a mechanical issue, try to check if the display part is tight together at the earpiece end. Some have reported that

I falshed mine, with no issues. Starting from LOS16.0, MindTheGapps and addonsu. Downloaded LOS17.1 https://download.lineageos.org/pro1 OpenGApps nano, ARM64, Android10.0 https://opengapps.o

Updated yesterday via sideload with nano opengapps and Magisk. No problems so far, even banking apps with nfc payments are working! 😀

Posted Images

1 hour ago, EskeRahn said:

(lineage-17.1-20210322-nightly-pro1-signed.zip on March 5 security patch installed smoothly using adb sideload)

Same here with OTA.

(On a side note, I sometimes see your sideload success report before my phone would report availability of an OTA update; in that case the update will always appear immediately after a manual re-check, though.)

  • Like 1
Link to post
Share on other sites
2 hours ago, Rob. S. said:

Same here with OTA.

(On a side note, I sometimes see your sideload success report before my phone would report availability of an OTA update; in that case the update will always appear immediately after a manual re-check, though.)

It is quite random when I actually check. Today I checked early morning (around 0700, CET), often it is not available much before noon. And sometimes I forget to check until the evening or even the next day.

To check I just finds and refreshes an open tab for https://download.lineageos.org/pro1

Link to post
Share on other sites
On 3/29/2021 at 3:48 PM, EskeRahn said:

(lineage-17.1-20210329-nightly-pro1-signed.zip on March 5 security patch installed smoothly using adb sideload and opengapps pico 20210327)

Same here by OTA...

  • Like 1
Link to post
Share on other sites
On 3/27/2021 at 12:23 PM, daniel.schaaaf said:

Anyone else with bluetooth trouble on 20210322? My headphones connect alright, but the audio is routed to the phone speaker.

Regular audio or call audio?

Link to post
Share on other sites
13 hours ago, Wheeljack said:

Regular audio or call audio?

 Regular audio for sure. I haven't had the chance to try call audio yet. It's still broken in 20210329, only for me apparently, which makes me think that my phone is borked.

The only big thing I did the last few days was disassembling and reassembling the phone. Is there an "external" antenna in the case, to which the Bluetooth chip connects? Or is said antenna on the mainboard? The headphones connect to the phone, and I was able to re-pair them. They are actually shown as "active" when I chose the audio stream.

One other thing I notices is that I also cannot control the volume of internal speaker directly with the volume buttons. The buttons work fine, but they control the caller volume instead of the media volume.

Well well, I bought myself another SD-card and reactivated my Moto Z Play as a media player. I guess I will fade out my Pro1 slowly ...

Link to post
Share on other sites

Is there any way to improve the speed of getting a GPS fix? Today I was walking in the city 3 hours ago and it took the phone about 10 minutes to get a fix. The previous fix was 3 or 4 days ago in the same city.

The device quickly discovered some GLONASS satellites. After 3-4 minutes it discovered a couple of GPS satellites, but was still not enough to get a fix.

I'm located in Poland. It looks like it's an issue with cold fixes, because right now I'm getting an immediate GPS fix. (the previous fix 3 hours ago)

Edited by marmistrz
Link to post
Share on other sites

In LineageOS 16 I could vastly improve the locking speed by the following edits in /system/vendor/etc/gps.conf:

[...]
XTRA_SERVER_1=http://xtra1.gpsonextra.net/xtra.bin
XTRA_SERVER_2=http://xtra2.gpsonextra.net/xtra.bin
XTRA_SERVER_3=http://xtra3.gpsonextra.net/xtra.bin
[...]
XTRA_VERSION_CHECK=1
[...]
NTP_SERVER=europe.pool.ntp.org
[...]
INTERMEDIATE_POS=1
[..]
SUPL_HOST=supl.vodafone.com
SUPL_PORT=7275
[...]

I am also in Europe (Germany) and at times could not get a fix at all (even after waiting for hours) with the default settings of LineageOS 16. Since I made that edit, GPS fixes are very fast.

Note that the "INTERMEDIATE_POS" bit is optional: It causes the location service to report even very early position estimates based on mobile network towers only. That estimate can however be wrong by many kilometers, so not all people like it. I find the option helpful if you travel a lot and often switch on the GPS very far from the last fix.

As you may have guessed, you need root access for this hack. Also, remember that you need to remount / read-writable temporarily. The config will probably not survive OTA updates, so better make a backup once you have found a setting that works for you. 

Edited by claude0001
  • Like 2
Link to post
Share on other sites
21 minutes ago, marmistrz said:

I'll check if it helps, thanks! Is there any reason why some of these changes are not in the official LineageOS? The relevant file is https://github.com/LineageOS/android_device_fxtec_pro1/blob/lineage-18.1/configs/gps/gps.conf

I think some things regarding AGPS are left blank on purpose in LineageOS, as using such services potentially reveals your location to the server operators, which may be seen as a privacy issue.

Even disregarding this, from what I read on the internet, the optimum settings depend on what region of the world you are in. So maybe there is no one-size-fits-all config anyway.

I found this config on some German Android user-forum and did not really check if it is truly optimal. The new settings certainly helped (a lot) in my case, but you may find even better ones for Poland by experimenting a little ...

Hope it will help.

Edited by claude0001
  • Like 1
Link to post
Share on other sites

So I get the setting improved things on your phone too?

I now somehow regret not to have stressed the follwing from the beginning:

Fully enabling AGPS (which I believe these settings do) enhances the functionality of GPS at the cost of privacy! There are valid arguments for having AGPS disabled by default in LineageOS and leaving it to the individual user to opt-in. See e.g. https://forum.xda-developers.com/t/keep-a-gps-supl-disabled-upon-rom-install.3612024/

However, I am not in charge. Go ahead with submitting a patch if you feel you must. 🙂

Edited by claude0001
  • Like 2
Link to post
Share on other sites
9 hours ago, claude0001 said:

There are valid arguments for having AGPS disabled by default in LineageOS and leaving it to the individual user to opt-in.

I would prefer if it was settings the user could select/deselect (without the need of rooting and messing with system files)

  • Like 2
Link to post
Share on other sites
1 hour ago, EskeRahn said:

I would prefer if it was settings the user could select/deselect (without the need of rooting and messing with system files)

Agreed. Unfortunately, it's not that straightforward to implement.

Edited by marmistrz
  • Like 1
Link to post
Share on other sites
14 minutes ago, marmistrz said:

Agreed. Unfortunately, it's not that straightforward to implement.

You could say that it is due to the fundamental lack of interest in users privacy at Google that it isn't....

Link to post
Share on other sites
Just now, EskeRahn said:

You could say that it is due to the fundamental lack of interest in users privacy at Google that it isn't....

Or perhaps "lack of interest" is too kind. "dis-interest" i guess would be more appropriate!

Link to post
Share on other sites
Just now, EskeRahn said:

Or perhaps "lack of interest" is too kind. "dis-interest" i guess would be more appropriate!

LineageOS devs seem to be disinterested too, they treat gapps-free users as weirdos.

  • Haha 1
Link to post
Share on other sites
On 4/9/2021 at 11:27 PM, claude0001 said:

So I get the setting improved things on your phone too?

I now somehow regret not to have stressed the follwing from the beginning:

Fully enabling AGPS (which I believe these settings do) enhances the functionality of GPS at the cost of privacy! There are valid arguments for having AGPS disabled by default in LineageOS and leaving it to the individual user to opt-in. See e.g. https://forum.xda-developers.com/t/keep-a-gps-supl-disabled-upon-rom-install.3612024/

However, I am not in charge. Go ahead with submitting a patch if you feel you must. 🙂

Can you report an issue to LineageOS that it should provide a setting to enable/disable AGPS, so that gps.conf doesn't have to be modified?

Link to post
Share on other sites
47 minutes ago, marmistrz said:

Can you report an issue to LineageOS that it should provide a setting to enable/disable AGPS, so that gps.conf doesn't have to be modified?

As they sadly consider the previous version as unsupported as soon as the new is released, we should not expect anything regarding 17.1 😥

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Terms