Jump to content

IGG does not want my money


Recommended Posts

4 minutes ago, EskeRahn said:

Visa worked fine for me (DK)

Worked fine for me too (USA), but had to answer a text from my Bank assuring them I made that transaction (at which point they slapped an additional foreign transaction fee on me 😄 ).

  • Haha 1
  • Sad 1
Link to post
Share on other sites

VISA worked for me, too (DE). That said, a few days ago my subcription renewal at LWN.net by VISA failed with a simple "charge was declined" note. My bank offered no explanation upon my support request except "we checked the card, it's ok and should work" and "please try again", which I did, and then it worked. Never had any problems with it before...  

  • Like 1
Link to post
Share on other sites

A few tips for IGG contributions in case you haven't done so already. Please disable any proxies, or VPNs that you may have running. We see people using those a lot more often now, but for any fraud protection such as what Stripe has (what IGG uses for payments), that's a no no. It's also important that your billing and shipping address match the address where your card is registered. You should also call your bank immediately after the failed payment attempt and they should typically be able to tell you why.

Or you can email us at [email protected] and we'll generate an internal order matching the IGG rates.

  • Like 4
  • Thanks 1
Link to post
Share on other sites
18 minutes ago, Erik said:

Or you can email us at [email protected] and we'll generate an internal order matching the IGG rates.

So this is an option, that's awesome. I already sent such a request. I'll wait patiently for support to come back to me.

I'll also get in touch with my bank too see if I can get things sorted.

Edited by Slion
Link to post
Share on other sites

My payments worked fine for me. My (first) Pro 1 was via the website way back when they first became available. Used a Visa debit card, worked perfectly. This new Pro1-X was via a different Visa debit card from a different bank, but also worked perfectly. (AUS)

Maybe getting a bank account with a linked debit card is the way to go?

  • Like 2
Link to post
Share on other sites

I asked my bank to sort it out but that didn't work and now I'm running out of time. I asked FxTec support if they could bill me directly and @Erik mentioned they could do that so I'll wait patiently until they get a chance to process my support request.

  • Like 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

Terms