Jump to content

Pro1X day 1: unable to log into Google account [solved]


Recommended Posts

Hi all, my spouse received their Pro1X today (stock ROM). The build quality seems excellent, and they're super pumped about the keyboard and excited to make it their primary device. However, they immediately ran into an issue: they can't log into their Google account, either during first-boot or afterwards. Wi-Fi connects and we can load web sites in Chrome, but the Google login flow gives them the old "there was a problem communicating with google's servers" error.

We tried a few different ways of adding the account, did a factory reset, and even Google's "DisplayUnlockCaptcha" tool. Any thoughts on what might be going on? We can log into the account in a browser tab, but any attempt to add the account to the phone fails. We tried checking for Android system updates and got "updates are temporarily unavailable please try again later".

Anyone have any suggestions? Thanks in advance.

Edited by smammy
  • Sad 1
Link to post
Share on other sites

So, when you factory reset, you do or don't get the initial setup wizard (starts with hello) that includes logging into the Google account.  Do you get the wizard, but it never asks for your google account, or you get the wizard, it asks for your Google account but you encounter the error, or you don't get the wizard at all?

I'm asking just to clarify because you mention using chrome which you would only have access to after the start-up wizard (although, in fact, I would guess the start-up wizard is a chrome kiosk).

  • Like 1
  • Thanks 1
Link to post
Share on other sites
Posted (edited)

@Hook We do get the wizard on first boot. First it prompts to connect to WiFi, which we do. Then it says something like "collecting info" with a big spinner, and eventually instead of the google login prompt ("enter your email") it says something like "there was a problem communicating with google's servers" with an option to "try a different network" or "skip for now".

If we choose "skip for now" we get to the home screen and can mess around with chrome. After that, trying to add a google account through settings > accounts, log into play store, log into gmail, etc. all show the same thing - "collecting info" with a spinner and then "there was a problem communicating with google's servers".

For what it's worth, we can log into google accounts just fine on a different phone (Asus Zenfone 8 ) when connected to the same wifi network.

Edited by smammy
  • Like 1
  • Thanks 1
Link to post
Share on other sites
11 hours ago, adam2 said:

I had this problem.  I found I was able to set everything up by doing it with no SD Card and no SIM Card installed.

I set it up over wifi, then I installed my SIM Card and SD Card.  Everything seemed to work fine after that.


I've been using it fine for a few days, now.

Oh wow! I've just done the same and it worked! Thanks adam2!

  • Thanks 4
Link to post
Share on other sites
  • smammy pinned this topic
13 hours ago, adam2 said:

I had this problem.  I found I was able to set everything up by doing it with no SD Card and no SIM Card installed.

I set it up over wifi, then I installed my SIM Card and SD Card.  Everything seemed to work fine after that.

Thank you! This worked for my spouse just now.

  • Like 2
Link to post
Share on other sites
  • smammy changed the title to Pro1X day 1: unable to log into Google account [solved]

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

Terms