Jump to content

How to start a new Pro1 X without Google ?

Recommended Posts

  • Replies 60
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Just my personal opinion: I wouldn't bother with any derivative distributions and just use upstream official LineageOS. If you use that without GApps, it's pretty close to /e/-OS. The main thing they

It's a long story, if you care to read through the updates on IGG.  The 25 cent recap is: 1. The Pro1x was intended to be simply a Pro1 with a different color and more memory with your choice of

Thanks guys for your support. Those last days were exhausting. Wouldn't make it without you.

Posted Images

Used a Win 10 tablet now. Pluging in the device shows the Qx1050 in device manager instantly, no need for driver updates.

Copied files and linked path, run "adb devices" command and everything seem working.

Sideload passed on the second attempt as on the first one it told me the recovery file is corrupted and system cannot reboot anymore. But I just redid the wipe and install.

Gonna test now.

  • Like 2
Link to post
Share on other sites
7 hours ago, EskeRahn said:

Also remember that both ports and cables can be problematic with fastboot on newer PC's

Meanwhile, I never ran into these kinds of problems on my Linux machine (Debian 11 or 12).

Always just plugged in a USB-C to USB-C cable (or Micro-USb gor older devices), so this problem might be Windows-specific (unless I just got really really lucky, for once 🙃).

Link to post
Share on other sites
38 minutes ago, chrissv said:

...so this problem might be Windows-specific´...

Quite possible, it could be some ever so slightly different handling of some handshaking (or lack of handshaking?)
At first I thought it was USB3.0 that was the problem, as USB2.0 seem to 'always' work. But it is more complex than that, as it works just fine with USB3.0 from the Thunderbolt4.0 hub.
My guess is that the presence of a hub adds ever so slightly to the latency, and it just MIGHT be that the Linux driver has ever so slightly longer latency build in.

Link to post
Share on other sites

For my case it looked like a drivers issue, as those manual additions did not seem to work well.

If the devices register and install themselves, things seem a bit more smooth.

  • Like 1
Link to post
Share on other sites

What worked for me now:

- Installing adb and fastboot (partially as no FxTec USB Drivers available)
- ADB driver install (probably no effect)
- Reboot into bootloader mode
  With the device powered off, hold Volume Down + Power
  Enter recovera with Volume Up + Power
- Enable offline charging
  fastboot oem enable-charger-screen
  fastboot oem off-mode-charge 1
  fastboot reboot
- Unlocking the bootloader (skipped as already by default)
  fastboot flashing unlock
- Flashing additional partitions
  additional partitions to be flashed for recovery to work properly
  fastboot flash dtbo dtbo.img
- Installing Lineage Recovery using fastboot
  Other recoveries may not work for installation or updates.
  fastboot flash recovery recovery.img
- Installing LineageOS from recovery
  Factory Reset, then Format data / factory reset and continue with the formatting process
  adb -d sideload filename.zip
- Installing Add-Ons (skipped as no GApps added)
  Apply Update
  Apply from ADB
  adb -d sideload filename.zip (for all packages)
- Reboot system now

Using Pro1X shipped with Stock Android connected to Win7 and Win10.

  • Like 1
  • Thanks 2
Link to post
Share on other sites
Posted (edited)
3 hours ago, JJB said:

Next up I will check that F-Droid stuff and app stores

Depending on your needs, you might want to add the Izzy repository to F-Droid. It has a lot of interesting open-source stuff that does not (yet) meet the acceptance criteria for the official F-Droid repo.

Aurora Store is what you want to be able to install (free) software from the Google Appstore. Some apps (e.g. official Firefox) are not on F-Droid, despite being open source ...

Congrats on getting things going at last!

Edited by claude0001
Link to post
Share on other sites
4 hours ago, JJB said:

Thanks guys for your support.
Those last days were exhausting. Wouldn't make it without you.


So glad it worked out finally. 

I will say, this stuff is tricky on Windows (and I am mostly a Windows user),  However, I have an old Thinkpad  that I installed Manjaro on.  All the fastboot and adb tools were already installed and doing all this stuff just works smoothly. I now exclusively use that Linux laptop for doing this even though I am not all that skilled with Linux (luckily have a couple of knowledgeable friends that give me support).

I don't know why it's such a hassle with Windows, but it always is and I can no longer imagine doing fastboot and adb without Linux. The ironic thing is I don't use my Linux laptop for much else except to ssh into my friend's Linux server and irc.  Lol.

  • Like 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information