Jump to content

Need help with softbrick!

Recommended Posts

Hello, guys.

Recently, I've tried to root a Cubot Power 4G following a guide I found online. I probably should have been more catious about it, cause now the phone is stuck on a bootloop. I tried to install a custom recovery to try and fix this, but as there was no official twrp for Cubot, I once again downloaded something that was probably shady. Thus, now the phone is stuck on bootloop, won't access recovery mode, is now turned off because battery gave out, but if I try to connect it to the pc, it will start to bootloop again. I cannot access adb, or at the least I don't know a way to, since it keeps bootlooping and I have no way to access a recovery mode(since there's no one, or at the least, if there is, it's faulty). What can I do here?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information