Jump to content

Can't update, can't unlock OEM

Recommended Posts

Hey, so my phone arrived. But I can't seem to run the update.

My last version is QX1000_EEA_20200306124530_20200306-1247, security level patch 5. Sep. 2019.

Checking on updates just throws me an error that it can't reach fota server::443. I do have a functional WiFi connection.

How do I update my phone now?

After retrying 10 times, it works now.. 😄

The other issue still remains.


Also I have enabled development mode, but I can't enable OEM-Unlock. It's greyed out, already "activated" and is saying that the bootloader is already unlocked.

Running fastboot oem unlock after booting into the bootloader just returns me "FAILED (remote: 'unknown command')" is this normal?


I have completely reseted the phone already.




Edited by __fastcall
  • Like 1
Link to post
Share on other sites

thanks for your answer!

I don't understand what the ADB driver has to do with it, as the button is greyed out on the phone itself. I could not even lock the oem functionality again if I wanted to. And if I read correctly, it's how it is when you get the phone.

I have switched ports and cables. And I have unlocked the OEM bootloader of a OnePlus three weeks ago successfully.

Link to post
Share on other sites

As I stated in the other topic. When you used the instructions on Lineage, the unlock command should be fastboot flashing unlock. 
I just received a Pro1, booted it and it was already unlocked. So there was no need for that.

To help you figure 💩 out, I used a different clean laptop. I installed everything as described on https://wiki.lineageos.org/devices/pro1/install. After installation and connection via ADB, I changed the driver manually to "Google Nexus ADB interface". I don't remember which one was selected, but it sure as Hell wasn't Google Nexus ADB interface. So as _DW_ stated, check whether you are using the correct one. When changing the driver, don't forget to deselect compatible hardware, otherwise it won't show. At least, not on my Windows 10 laptop. I got it working on both 2004 and 190x Windows 10 by the way...

After that I issued:

  • adb reboot bootloader
  • fastboot devices (to check whether it was connected)
  • fastboot flashing unlock (error already unlocked)
  • fastboot flash boot lineage-16.0-20200803-recovery-pro1.img
  • Volume Up + Power
  • Performed a factory reset in Recovery
  • Apply update via ADB sideload
  • adb sideload lineage-16.0-20200803-nightly-pro1-signed.zip
  • Reboot to Recovery
  • adb sideload MindTheGapps-9.0.0-arm64-20190615_031441.zip

And now it's running LOS 0803.

Edited by DieBruine
  • Like 3
  • Thanks 1
Link to post
Share on other sites

Thanks for your answers!

Yeah, what confused me was that it was already unlocked. As most tutorials seemed to require you to unlock it first.

Ive tried to flash LineageOS anyway and it worked well. Have the newest testing version running. 🙂

Edited by __fastcall
  • Like 1
  • Thanks 1
Link to post
Share on other sites
3 hours ago, __fastcall said:

I had a smaller "problem" with Gapps Nano signature not getting validated. But I could install it anyway, Magisk followed afterwords.


Yeah that's expected @tdm says why in another post somewhere.

Glad you got it sorted lineage is way better than stock 😉

  • Like 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information