Jump to content

PRO1, AICP 17.1, failed early install attempts, wrong bootimage


Recommended Posts

See this thread for working install:

----------------------------------------------------------------------------------------


Below is initial attempts where I used a wrong boot image

 

Using this AICP.S mage

aicp_pro1_s-17.1-WEEKLY-20220713.zip

I was super optimistic and went from 16.1 with OpenGapps to 17.1 and MindTheGapps 12 in one go, without a factory reset (=wipe).
...and that did not go well,,,, I got a boot-loop
(I used the recovery-image from Lineage lineage-19.1-20220711-recovery-pro1.img)

Then did a factory reset, and it booted - obviously with everything gone... But not happy
1479233608_IMG_20220714_01352801.jpg.326eba208f8ee08ae3e138077bab64f4.jpg

Tried to reflash including factory reset - went into boot-loop again....

Then tried to flash WITHOUT GAPPS (with yet another reset...,)

New boot-loop...
After some (10?) iterations it asks me to wipe (again),

150062200_IMG_20220714_09114301.jpg.673828b65a1d137c5133d854541a2e07.jpg

and doing so allows it to boot with above message again....

So currently severely broken.....
Though not totally useless... (e.g. both camera and fingerprint reader works)
So WAIT for new version!!!!

ADD:
Tried a clean gapps-free and wiped AICP-R, booted and skipped all wizards.
And  then did a AICP-S flash without wiping.
...and got exactly the same behaviour as above. :classic_sad:

ADD:
Also tried the flash&wipe with SIM and SD-card removed - same result.
 

  • Thanks 1
Link to post
Share on other sites
  • EskeRahn changed the title to **** NOT WORKING PT **** AICP 17.1 (Android S) Official Build.
  • EskeRahn changed the title to AICP 17.1 (Android S) Official Build. **** NOT WORKING PT ****
5 hours ago, Hook said:

Any chance they got their hands on a pre-production Pro1x and forgot to label the ROM properly.  Lol

He he. If so I doubt things would work as relative well as they did... Especially the camera

But is a bit odd that it is 'released' in a state where I can not even do a clean wiped GAPPS-free flash and boot it.... So I assume that in special conditions an upgrade might work.

An obviously thing to try would be a clean gapps-free wiped AICP-R and  then do a AICP-S flash without wiping. I have not tried that (yet?) Tried, no cigar...

Link to post
Share on other sites

(I noticed on the AICP download site that at the least some devices are on their third iteration of 'S', e.g. Pixel 5a, so hope we will get a less buggy version soon)

Link to post
Share on other sites

Flashed todays release aicp_pro1_s-17.1-WEEKLY-20220727.zip, with factory reset

And it is the same as above. with and without MindTheGapps-12.1.0-arm64-20220605_112439.zip

Goes directly into bootloop, and after about 10 failed attempts asks for a new factory reset, and after that continues with the above splash on top of the setup wizard.

(Did not bother to flash back to AICP-R, just turned it off, awaiting a usable version, hopefully next week...)

Link to post
Share on other sites
9 minutes ago, DieBruine said:

I am backing up my phone as I type. Afterwards I will try to flash 17.1 after a reset and let you know the results. 

99.99% sure it will not work for you either, but thanks for trying.

Link to post
Share on other sites

Yup, constant boot loop. Wiped it first, sideloaded the rom, signature error, flashed anyway. keeps it in the loop.

 I had decided yesterday that I will be selling this Pro1 (because Pro1x). So I don't mind a little experimentation. 
Any others you recommend 😅

Flashing Stock 20200825 😁
Finished flashing stock, relocked bootloader and GPS working again...

Edited by DieBruine
Finished
  • Thanks 1
Link to post
Share on other sites
  • EskeRahn changed the title to PRO1, AICP 17.1 (Android S) Official Build. **** NOT WORKING PT ****

Flashed today's release aicp_pro1_s-17.1-WEEKLY-20220803.zip, with factory reset and no Gapps

And it is the same error as above. Boot-loop some ten 10 times, asks for Reset, Boots with error screen, and all seems to work, except this splash screen on each boot.
(But to make things clear, it is 'only' on the first try after flash that it requires a reset)

Link to post
Share on other sites
  • EskeRahn changed the title to PRO1, AICP 17.1 (Android S) Official Build. ****BUGGED ****

I Just tried to reflash AICP-S on top of AICP-S, with NO factory reset, and this goes much better, though not 100% smooth.

  • It still enters a boot-loop attempting to boot after the flash is done...
    BUT it eventually DO boot into AICP-S with things preserved from last time. 😁
  • It still present the splash screen that something is terribly wrong on boot...
    BUT after that, things seem to work fine (until you do the next boot).  😁

So though severe bugs they are NOT show-stoppers any more.
You will still need a factory reset going from AICP-R to AICP-S, But though sad, that is tolerable.

 

Link to post
Share on other sites

Minor issue: Screenshot works a bit oddly, as it seems you need to mark the portion of the screen you want to copy every time.
It could be me that just have not guessed how to easily get the entire screen,... (double tap does not work, gives a miniature cut of the rectangle between my two taps...)

Link to post
Share on other sites
7 hours ago, EskeRahn said:

Minor issue: Screenshot works a bit oddly, as it seems you need to mark the portion of the screen you want to copy every time.
It could be me that just have not guessed how to easily get the entire screen,... (double tap does not work, gives a miniature cut of the rectangle between my two taps...)

Did you check if screenshot is available from the square button multi-taking screen?

Link to post
Share on other sites
51 minutes ago, Hook said:

Did you check if screenshot is available from the square button multi-taking screen?

Screenshot is indeed available, but it enters a mode where you can select what to save, clicking and dragging, and the default is NOT the entire screen.
Until selected only a cancel 'button' is available. Once dragged both an accept and the cancel buttons are available.

Link to post
Share on other sites
2 hours ago, EskeRahn said:

Screenshot is indeed available, but it enters a mode where you can select what to save, clicking and dragging, and the default is NOT the entire screen.
Until selected only a cancel 'button' is available. Once dragged both an accept and the cancel buttons are available.

Okay, I guess AICP did it differently.  In Lineage 19, I get a screenshot button that takes the full screen by default, but also offers an edit and share button.  Then again, maybe this is a Nova launcher.  What about the power button (you may have to add the screenshot button in power button settings)?

I'm so far staying on Lineage 19, and don't remember the differences with AICP-R, so my advice may not be useful.  I wish they would get AICP-S fixed.

Edited by Hook
  • Like 1
Link to post
Share on other sites
2 minutes ago, EskeRahn said:

Actually I just today found out that it is not as bad as the initially transition led me to assume.

I saw that, but at least until I have my Pro1x, I'm not going to trust it as a daily driver.  Once I have my Pro1x, I'm planning a lot of experiments with my Pro1.  😉

  • Like 1
Link to post
Share on other sites

Flashed today's release aicp_pro1_s-17.1-WEEKLY-20220810.zip, Security patch March 5  and MindTheGapps-12.1.0-arm64-20220605_112439.zip (without factory reset)

And it is the same error as above. Boot-loop some ten 10 times, , Boots with error screen, and all seems to work, except this splash screen on each boot.
(But to make things clear, it is 'only' on the first try after flash that it requires a reset)

Link to post
Share on other sites

It is a bit odd that there are no more security updates on AICP-R, since June. And on the other hand the security patch level for AICP-S is March, so I guess they see S as still in development?

I would also like to know if it is me that are doing something wrong or they see the same splash screen?
Should I e.g. use a different boot-image than I do? I copied the most recent boot-image available at the time of the first AICP-S: lineage-19.1-20220711-recovery-pro1.img should I use an earlier or a newer? (I have saved a few older 0426, 0502, 0530, 0627)

Link to post
Share on other sites

Tried with the old boot-image from lineage 18.1 20210913 (That is the one I used for AICP-R!), with a reset, got he bootloop and request for another reset BUT the splash screen is gone!!
So DO NOT use one for 19.1 though it matches Android 12, Use the same as for AICP-R (matching Andoid 11) !!

I will update this thread accordingly...  (Or parhaps make a new one, closing this done...)

Link to post
Share on other sites
  • EskeRahn changed the title to PRO1, AICP 17.1, failed early install attempts, wrong bootimage

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

Terms