Jump to content

Pro 1x sends constant "Suspend" commands to Bluetooth headphones

Recommended Posts

Just wondering if anyone has this issue, or could advise.

I have a set of HyperX bluetooth headphones,and they pair easily to the phone, but there is no audio. The phone keeps "suspending" them and defaulting to its own internal speakers.

I enabled a Bluetooth snoop log in the phone, and looked at the .cfa file with Wireshark, and I see that the phone keeps sending "Suspend" commands to the headphones as soon as I start to play audio.

So in the log I see the phone as source  issues "Sent Vendor dependent: Interim - RegisterNotification - PlaybackStatusChanged - PlayStatus: Playing", to the HyperX as destination.

Then the phone as source issues "Sent Command - Suspend - ACP SEID [5 - Audio Sink]", to the HyperX as destination.

This happens repeatedly as I try to force the phone to play through the headset, and it keeps powering down the headset (or I guess more accurately "suspending" it, but the effect is the same in that I have to hit the power button and it reconnects to the phone).

Problem exists on both GMS-less version 2.1.5 and LineageOS.

Any ideas?

Link to post
Share on other sites
  • 5 months later...

Playing with this a bit more, I see when I switch to HD Audio, two codecs are permitted with this combination of HyperX headphones and Pro 1x.

They are SBC and Qualcomm aptX.

By default, enabling HD Audio triggers the Qualcomm aptX codec, and that kills the headphone sound and starts the "suspend" problem. But it is possible to select the SBC codec instead of Qualcomm aptX when HD Audio is enabled, and that reconnects the sound.

Interesting. Some kind of failure related specifically to the Qualcomm aptX codec.

Anyone else have a Bluetooth device working properly, using that codec?

Be interesting to know if the flaw was in the phone, or the headphone.

  • Thanks 1
Link to post
Share on other sites

And my final comment on documenting this issue.

It is completely solved in the current version of LineageOS, 20-20230803-NIGHTLY.

Issues discussed above were in respect of a much earlier unofficial version of LOS, and version 2.1.5 GMS-less Android from Fx Tec.

The current official LOS permits three codecs with these headphones, SBC, AAC and Qualcomm aptX, and they all work just fine, no sudden "suspend" disconnects.

So thank you very much LOS devs, and mystery solved!

  • Thanks 1
Link to post
Share on other sites

For what it's worth, in my car I regularly use bluetooth to connect to a little bluetooth to FM convertor:  
Never had your issue, just checked in Developer Options, HD audio is disabled, but I'm not connected right now.  
I'll have a play with the settings next time I'm out and about and connected and report back any issues.  
I'm on LineageOS 20-20230803-NIGHTLY, but haven't seen an issue on this or previous versions. 


Just seen your last post which you must have put up while I was typing, all better, and a solution for those running older versions. 

Edited by MonCon
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information