Jump to content

(solved) locked/broken bootloader "press volume key to select"

Recommended Posts

TL;DR: contact support, they can help.


Last week my phone bricked itself in this black-green-white-red state (full text so it's easier to find):

Press volume key to select, and press power key to select
FastBoot mode
PRODUCT_NAME - msm8998
SERIAL NUMBER - f77848ef

fastboot flashing did not work, choosing any menu would just show this page again, occasionally I would see "Press any key to reboot" screen (usually when phone was plugged into a sleeping PC, and the PC woke up.


F(x)Tec support was able to help me, my advise is not to waste your time trying to recover yourself with these symptoms (I spent a few days trying to do so) and, maybe, potentially you could break something. Your request will take some time to go through the pipeline, so prepare for a few days without a phone or find an alternative, but don't bother setting it up completely like I did, if you can afford it.


PS: to mods, I was not sure whether to create a new thread or to answer here, or somewhere else, please merge if it's appropriate.



Link to post
Share on other sites

Yes, and there was no way for me to know what had to be done.

Like someone stated on a link I mentioned in the post, I cannot disclose any more info at this point, so my advise is simple: don't waste your time, don't wait and contact support if you have this issue, wish I did that sooner.

  • Like 3
Link to post
Share on other sites

It's not secret.  My factory restore tool should do the trick.  But, as I recall, the problem @D1ggs had was that he locked his bootloader while on non-stock and the bootloader unlock flag was not set.  This is a one-way trip and needs EDL to fix.


My initial attempt at fixing this involved a custom executable, and we couldn't get that working easily.  I've since helped another user successfully.  I ended up making a very small package that can be flashed with the factory restore tool that manually sets the bootloader unlock flag.


  • Like 2
  • Thanks 1
Link to post
Share on other sites
7 hours ago, Craig said:

Hmmmm, quite the mystery.  Secret procedure only OEM can tell you about.... got me curious.  Maybe I'll fake a broken phone just to find out...

FxTec was really accommodating for my screw up. It's really nothing fancy at all and uses the same EDL paths that @tdm's restore tool does. 

Really, FxTec didn't have to help me at all and this was my screw up alone. They went above and beyond, more so than any other OEM and for that I am greatly appreciative. 

I guess the moral of this story is, if you do something stupid, Papa Chen cares about you and will do what it takes to fix it (within reason). 

  • Like 3
  • Thanks 2
Link to post
Share on other sites

My case was a bit different though, I did not get to flashing my phone yet, it happened spontaneously, wanted to stress this, otherwise I would not have stared a new thread 🙂

My problem seems very-very similar to yours, though, just looks like the way we got there was different.

Link to post
Share on other sites
  • 1 month later...

@is: do you happen to have more details? I ended up being stuck in bootloader screen and I cannot flash anything, because the bootloader is locked. I did not try to flash anything - when I picked up my phone in the evening, it was stuck in this screen. I wish I wouldn't have to wipe my data partition, but I have tried a lot, but because the bootloader is locked (and I also get no option to e.g. draw the pattern - which I do know), I am stuck.. nothing is booting.

Do you happen to know what can be done to fix this? Preferably without losing data (but if it's only possible with the data being lost, then I guess so be it)...

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information