Jump to content

Recommended Posts

A couple of days ago my Pro1 started seriously overheating and draining its battery. Rebooting didn't help. After investigation I noticed it was constantly using network bandwidth both upload and download. Settings battery usage was reporting Gmail as being most greedy. Network monitoring tools were in fact showing some Google Service was responsible for that traffic.

Turning off auto-sync in Gmail fixed the issue. Battery life is now awesome with the downside that emails and personal info don't sync automatically, obviously.

I only have two accounts in Gmail, namely Google Gmail and an Active Sync account. Only the later is setup to synchronise.

This is a problem I've seen before on my venerable Samsung S7 Edge.

  • Thanks 2

Share this post


Link to post
Share on other sites

For what it's worth, I haven't noticed any similar issue, but only use one gmail account.

I think if this was a common issue, google would be on top of it.  So it's probably a you issue.

But on previous device I used to use K-9 for years and was always happy with it....

  • Like 1

Share this post


Link to post
Share on other sites
26 minutes ago, EskeRahn said:

Sounds like yet another Google app that should be avoided... 🙄

Easier said than done since I'm using ActiveSync Provisioning. My understanding is that Gmail is just the frontend using a bunch of Android backend services doing Personal Information Management at the platform level. Things like Contact and Calendar synchronisation.

From there flows a few questions:

  • Is ActiveSync Provisioning implemented by those Android services or by Gmail?
  • Are those apps you mentioned just using those Android services or implementing their own stacks of protocol?
  • Was that bug I'm facing really caused by Gmail app layers or is it in fact caused by those Android PIM services?

Share this post


Link to post
Share on other sites
4 minutes ago, Craig said:

So it's probably a you issue.

Am I holding it wrong? 😁

  • Haha 5

Share this post


Link to post
Share on other sites

I am not sure if that information is useful at all, but I recently had the Google Photo app causing overheating and battery drain on my Priv. So maybe there currently is some problem with synchronisation of Google Apps in general?

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites
52 minutes ago, Craig said:

For what it's worth, I haven't noticed any similar issue, but only use one gmail account.

I have 2 Gmail accounts currently configured on my Pro1 and don't see the issue.

  • Like 2

Share this post


Link to post
Share on other sites
2 hours ago, david said:

I have 2 Gmail accounts currently configured on my Pro1 and don't see the issue.

I've been using Pro1 for almost 2 months without getting that issue either. I think until then it had been possibly overheating a couple of times but a reboot always fixed it. This time it was really stuck trying to do something dumb or just slurping my data 🤔

To be fair and as mentioned in the first post it's an issue I observed on well-known brands flagships over the years. Though in the few months I used a Huawei P30 Pro it never exhibited such an issue.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Terms