Jump to content
D1ggs

Has the SafetyNet Issue been fixed in Stock?

Recommended Posts

Posted (edited)

Waiting patiently for when stock has passed validation....

It's ridiculous that a phone like this hasn't been validated yet. 

 

Edit: Dumby me forgot to lock the bootloader /facepalm

Edited by D1ggs

Share this post


Link to post
Share on other sites
Posted (edited)

They have withdrawn the broken OTA, so yes. Unfortunately if you got that broken OTA then you are still stuck with it for now.

Edited by Slion

Share this post


Link to post
Share on other sites

Yeah that was fixed in 20191203 but you also have to lock bootloader.

 

(Also note if you installed 20200304 a mistake was made, and the only way to fix is to restore and start over).

Share this post


Link to post
Share on other sites
3 minutes ago, Craig said:

Yeah that was fixed in 20191203 but you also have to lock bootloader.

 

(Also note if you installed 20200304 a mistake was made, and the only way to fix is to restore and start over).

Ahhh! This is what I wasn't doing correctly.

Have we figured out how to root the latest version of stock yet? 

Share this post


Link to post
Share on other sites
Posted (edited)

To the best of my knowledge w/o checking the magisk thread, I think no (not that we dont know how, but nobody had yet captured the latest boot.img). I think you have to root at earlier version, then take OTA, following correct procedure to keep rooted.

Edited by Craig

Share this post


Link to post
Share on other sites
3 minutes ago, Craig said:

To the best of my knowledge w/o checking the magisk thread, I think no (not that we dont know how, but nobody had yet captured the latest boot.img). I think you have to root at earlier version, then take OTA, following correct procedure to keep rooted.

Yeah I tried that and kept getting error 22 so I gave up and went back to Lineage.

Share this post


Link to post
Share on other sites
1 hour ago, Craig said:

if you installed 20200304 a mistake was made, and the only way to fix is to restore and start over).

I thought they were supposed to provide another OTA that's fixing it. I can't be bothered doing a reset.

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, Slion said:

I thought they were supposed to provide another OTA that's fixing it. I can't be bothered doing a reset.

They are, I believe.  I think Craig simply meant the only way to get safety net now...

  • Like 1

Share this post


Link to post
Share on other sites

Yes, correct, only way to fix it now.  An update is coming shortly (or was it next week?)...

  • Haha 4

Share this post


Link to post
Share on other sites

I honestly think it would be a good idea to certify lineage, as that is getting way faster updates.

  • Like 1

Share this post


Link to post
Share on other sites
22 minutes ago, kontakt said:

I honestly think it would be a good idea to certify lineage, as that is getting way faster updates.

Is that an option?

Share this post


Link to post
Share on other sites
Posted (edited)

No.  But stock could at least pull in all the lineage fixes/etc fairly easily.

Edited by Craig
  • Like 3

Share this post


Link to post
Share on other sites
4 hours ago, Craig said:

No.

Then I'm afraid I should remain on stock only until I get myself a second Pro1.
Except that I got that botched OTA... does not compute.. ho crap.

4 hours ago, Craig said:

But stock could at least pull in all the lineage fixes/etc fairly easily

I'm guessing that for financial reasons OTAs are on pause until they get hardware manufacturing sorted out and significant volume in the hands of their customers.  

Share this post


Link to post
Share on other sites
Posted (edited)

If safetynet is required, the ONLY solution is unrooted stock.  This is the new normal.

For the past few years this could be worked around with magisk, for both root and custom rom, but no longer with latest google updates. https://twitter.com/topjohnwu/status/1251712525843918853

So this is even more reason for us to want stock to fix problems/issues.

I mean the community buglist of issues https://docs.google.com/spreadsheets/d/15uE12Yv5nMvIF42U33cY5FQoF6M66QIn00cC876uf7Y  hasn't changed since last year, other than the March multiple-keypress fix which was a very important and welcome update, but done by a community member in December.

 

Edited by Craig
  • Like 1

Share this post


Link to post
Share on other sites
2 hours ago, Craig said:

If safetynet is required, the ONLY solution is unrooted stock.  This is the new normal.

For the past few years this could be worked around with magisk, for both root and custom rom, but no longer with latest google updates. https://twitter.com/topjohnwu/status/1251712525843918853

So this is even more reason for us to want stock to fix problems/issues.

I mean the community buglist of issues https://docs.google.com/spreadsheets/d/15uE12Yv5nMvIF42U33cY5FQoF6M66QIn00cC876uf7Y  hasn't changed since last year, other than the March multiple-keypress fix which was a very important and welcome update, but done by a community member in December.

 

I still get the occasional lose of touch input that gets fixed by a reboot (I'm on the botched stock update).

Share this post


Link to post
Share on other sites
12 hours ago, kontakt said:

I still get the occasional lose of touch input that gets fixed by a reboot (I'm on the botched stock update).

That is odd, I have not seen that on stock for long, but I do get it for the newer iterations of LineageOS unfortunately

Share this post


Link to post
Share on other sites

My main gripes are:

- Volume in calls being way way way WAY too loud

- Proximity sensor or something related in the screen touch software causing the screen to register touches when the phone is against your face.  And that causes me to either mute the phone (most often), so others can't hear me, or hold, so I can't hear them.  This causes real problems and is very unprofessional on business calls.

- The cell reception is horrible when you aren't in a strong signal area, compared to other phones.

- Auto rotate gets confused and I have to turn it off to get things to rotate and back on again later.

- The keyboard backlight turning off and not coming back on again unless you close and open the screen would be a problem, but a Tasker setup is a workaroud that works fine.

That's all I can think of off the top of my head.  Everything works very well on this phone.....except using it as a phone!! LOL

Share this post


Link to post
Share on other sites
Posted (edited)

For those that are curious, running the latest version of stock 202003. Safety net issue is fixed and in fact passes even if the boot loader is unlocked. Google pay works. 

Since I've been on Verizon via red pocket , my signal has been rock solid. Glad I made the switch. ATT stank to high heaven. 

 

@slion, can't you use the fastboot restore files to roll back to the October release and re-up date forward to fix your phone? Even the factory restore tool should work in that regard. 

 

Edited by D1ggs
  • Like 1

Share this post


Link to post
Share on other sites
42 minutes ago, D1ggs said:

@slion, can't you use the fastboot restore files to roll back to the October release and re-up date forward to fix your phone? Even the factory restore tool should work in that regard. 

No idea, I did not fiddle with those tools. It would be nice to get some official support on that issue.

Share this post


Link to post
Share on other sites
7 hours ago, Slion said:

No idea, I did not fiddle with those tools. It would be nice to get some official support on that issue.

Dude, seriously get on this. It will literally take you 15 minutes to get this fixed with the fastboot files. 

Yeah sure it isn't official but I'd go nuts sitting on a bug like that. 

You'd be back up and running in no time.

  • Like 1

Share this post


Link to post
Share on other sites
11 hours ago, D1ggs said:

Since I've been on Verizon via red pocket , my signal has been rock solid. Glad I made the switch. ATT stank to high heaven. 

These things are always dependent on where you are.  I went through the SMS failure twice with Verizon.   Worked great when it worked and I might have gotten it working again, but AT&T is so good where I am and most places I go, I lost my motivation for fiddling with Verizon. 

I do very much hope you do somehow not have any problems with Verizon in the future. 

Share this post


Link to post
Share on other sites
3 minutes ago, Hook said:

These things are always dependent on where you are.  I went through the SMS failure twice with Verizon.   Worked great when it worked and I might have gotten it working again, but AT&T is so good where I am and most places I go, I lost my motivation for fiddling with Verizon. 

I do very much hope you do somehow not have any problems with Verizon in the future. 

I'll let you know how long it lasts. So far so good. 

Share this post


Link to post
Share on other sites
Posted (edited)
7 hours ago, D1ggs said:

Yeah sure it isn't official but I'd go nuts sitting on a bug like that. 

Well everything is working fine. The only problem I've had with it was not being able to install Disney+ which I don't really need on my phone anyway.

Edited by Slion

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Terms