Jump to content

Can't use new phone because of google FRP

Recommended Posts

Hi all!

Just received a replacement unit from the kind people at F(x)Tec, just want to say that's GREAT customer service. Yes, it took some time but hey!

On the other hand, I just can't log into the phone (for the first time). It asks for either some password (which I don't know and couldn't find it anywhere in the box) or google account. When I try to put my GA there, it asks for second step auth, which I pass (tried all the possibilities like SMS, clicking on a different device, putting in a security code from GA..) but it always ends up the same: a shadowy box pops up saying ,,please sign in using one of the owner's account for this device'' and then it goes back to ,,Verify your account'' with a message ,,This device was reset. To continue, sign in with a Google Account that was previously synced on this device''.

Ive opened a service ticket but they haven't responded yet, so trying different approaches..

Steps I'd tried:
- reset user data in recovery

- flashing original 07/07/2020 ROM

- flashing lineageOS (although I am not sure this one got done properly -- the greeter looks exactly the same.. I am sure the flashing was successful and I got through the standard ,rolling balls' intro of Lineage ..) .. maybe my error was I'd installed GApps too, that's one last thing I might try installing the ROM without GApps..


THanks for any clues..

Edited by itchy355
  • Like 1
  • Sad 1
Link to post
Share on other sites

It seems that they have sent a refurbished device to you but they didn't reflash the firmware with factory tools. Your situation is like owning a stolen device so there is very little you can do. The whole point of FRP is to block the use of the device and data. I think that EDL flashing tool can help but I am not sure.


  • Thanks 2
Link to post
Share on other sites

Please don't mistake me for someone who knows what he's talking about, but I would try flashing the original factory image from October 2019.  First, I think it is the only complete ROM.  You can then take all the updates.  I think it is worth a try.  Make sure you once again wipe userdata as the flashall included does not do that and will reboot you without giving you a chance to do it.



  • Thanks 1
Link to post
Share on other sites

you can remove frp for approx 95% of phones without any firmware flashing...is just needed to find sw hole...i am able to remove frp on approx all phones. is just needed to know where to find it. Maybe you can start with samsung frp method...test what happens with pin locked sim card. Bootup phone , put inside locked sim, wait for enter pin but dont enter it, quickly press onoff in same time remove sim and press again onoff...now you will see lockscreen? if yess...test to pulldown top bar (dont unlock it!)...let me know what happens.

Another way...test to go through setup up to select wifi...connect to wifi...then go to add wifi network...and write something and long press on text...are you able to share text maybe via gmail ? ...or websearch?

It is very hard to explain it...but fx is for 100% unlockable

All what is needed is find way how to open browser...then download quickshortcutmaker apk, install it, then in this app open settings, disable device admin app, then disable google services, install remotearizalsolution, again go to settngs-add account, add your google account, then go to apps, reenable google services, then to accounts, enable account synch....and finally reboot...after reboot...nextnextnext account added nextnextnext...done.

Very simple or not ? 😄

FX have unlocked bootloader...soo you can test to flash recovery, wipe and flash custom rom....or image of original rom


Again fx is for 100% unlockable for free.

I am service technician and i can unlock all samsung etc devices...only is problem with latest fw on huawei...on it is needed downgrade.


Let me know...you can contact me on PM

  • Thanks 4
Link to post
Share on other sites
  • 3 weeks later...

Hey there, thanks for a very detailed answer! I think you're the Cornholio who used to solder the sim card slots on Motorola photon Qs, right? 🙂 My problem was luckily solved another way, I think it is official now so anybody else can contact tech support and they'll help him.

  • Like 1
Link to post
Share on other sites
  • 3 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information