Jump to content

Android 11&12 Charging issue. Reproducible trigger method.


Recommended Posts

We have in the lineage threads for 18 and 19, as well as AICP-R had a number of posts on a strange charging issue, where it keeps the battery at a stable level, neither charging nor discharging while connected.

This seems not to be limited to the Pro1, but is an issue that also affects the Pro1.

See the post I made here in the Lineage 19 thread.

Unfortunately this common problem is rather illusive, as it is not easy to say how to trigger or avoid it. All we know for sure is that it is temporarily gone after a reboot.

I have tried multiple times to find a 100% reproducible method, but today I might have some sort of a breakthrough:

I had the issue (at 29%) earlier today and then did this

  • Rebooted while connected
  • Did NOT enter the password but waited at few minutes
  • Picked it up while disconnecting, entered the password, and put it back on the table while connecting.

And it did NOT charge! I let it be on the table -starting typing info on this- and it did a spontaneous reboot(!!).
(Note that it did charge to 35% in the period before I entered the password)
Repeated the last two dots, and it still did not charge (but this time no spontaneous reboot).

I repeated it a third time, and this time it DID charge.

I then tried to repeat it some five more times afterwards, NOT being able to trigger it again. So could be some timing that has to be in a particular window to trigger (or not trigger) it...

I did it again waiting long before entering the password (now at 50%). And this DID trigger it!
So though not a 100% easy to use method there clearly is a pattern, that might be investigated further, for a 100% reproducible way!

I can not say for sure whether or not I by reflex have touched the fingerprint sensor during each pick up, but I think I did on most.

So if anyone want to spent some time digging further into this, it would be great, as a reproducible method is the first step in making an error report so someone can do what ever it takes in the Lineage&AICP distributions to circumvent the bug.

  • Thanks 3
Link to post
Share on other sites

Interesting.
I had the problem very very often with LOS18.1 (I had always to reboot once the phone has been charging one time) , then I flashed LOS19.1 (wiping data), and I had (quickly) the same behaviour (but my fingerprint sensor worked, wtf ?).
Then I reflashed LOS18.1 (also wiping data), and I had only the problem two or three time in three weeks of use (and fingerprint sensor works quite all the time, wich wasn't the case in LOS17.1 and first installation from LOS18.1).
Very strange.

Link to post
Share on other sites

With the latest build, I'm having this issue no matter what. The previous build did a better job in that respect. No matter what I try or which charger I use, I just used my original charger for the very first time in 2 years, it won't start charging since I installed this build a couple of days ago. 

Back to rebooting every charge. And still no GPS fix by the way. Almost immediately 20 sats, but never a fix.

And, mine starts charging as soon as the boot logo is gone!

Edited by DieBruine
  • Sad 2
Link to post
Share on other sites
  • 2 weeks later...

 

On 7/22/2022 at 7:27 AM, DieBruine said:

With the latest build, I'm having this issue no matter what.

Maybe they changed something for the worse? That could be why it was so relatively easy to trigger it here too?
(reposting this as i had to steal an old post....)

  • Like 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

Terms