Jump to content
cheetah

AT&T Wi-Fi Calling?

Recommended Posts

So I was a Verizon user, but at the time I got the phone, I thought Verizon was not going to work so I switched to AT&T.  While now I know there's a work-around to make the phone work on Verizon, AT&T is like $20 / mo cheaper for me so I'm encouraged to give it a shot.

Problem is, I get flat 0 signal at my house.  Once in a great while, I'll get like a couple minutes of signal, but it's not reliable enough to use.  I looked into getting a signal boost device, but they don't do that anymore; it's all about the wi-fi calling.  I've never set that up on any phone, so I'm a total newb here.

When I go to the settings, I type in 'wi-fi' and Wi-Fi calling is an option.  Clicking it, I'm taken to the SIM card screen, and I don't see any relevant Wi-Fi related stuff there.  Does it just not work?  Anyone know anything about this?  Sorry if it's already answered, I've searched a few times over the past couple of days to try and find it.

 

Thanks guys!

Share this post


Link to post
Share on other sites
5 hours ago, Polaris said:

First off, have you enabled it in the INFO menu (*#*#4636#*#*)?

Yes, it looks like it is on.

Share this post


Link to post
Share on other sites
38 minutes ago, cheetah said:

Yes, it looks like it is on.

Ok, my full disclosure statement is that I haven't, and don't plan on, using WiFi calling.  However, as I understand it from friends who do use it, you'll need to call AT&T and have them provision your account for WiFi calling (I believe only post paid accounts (not prepay) are eligible).  Once they configure your account to use WiFi calling, then all you need to do is make sure that the switch is active (which you have already done); then, when you are connected to an access point with a good WiFi signal, your calls will automatically be routed via WiFi.

Share this post


Link to post
Share on other sites
11 hours ago, cheetah said:

AT&T is like $20 / mo cheaper for me so I'm encouraged to give it a shot.

 

11 hours ago, cheetah said:

Problem is, I get flat 0 signal at my house. 

Sorry, this juxtaposition gave me a chuckle.  😉  Still, if you get the WiFi Calling solved... hopefully, you will.

  • Haha 1

Share this post


Link to post
Share on other sites
36 minutes ago, Polaris said:

Ok, my full disclosure statement is that I haven't, and don't plan on, using WiFi calling.  However, as I understand it from friends who do use it, you'll need to call AT&T and have them provision your account for WiFi calling (I believe only post paid accounts (not prepay) are eligible).  Once they configure your account to use WiFi calling, then all you need to do is make sure that the switch is active (which you have already done); then, when you are connected to an access point with a good WiFi signal, your calls will automatically be routed via WiFi.

Okay, thanks for the tip -- I will call them and report back as to what happens.

Share this post


Link to post
Share on other sites
17 minutes ago, Hook said:

 

Sorry, this juxtaposition gave me a chuckle.  😉  Still, if you get the WiFi Calling solved... hopefully, you will.

No problem 🙂 To be fair to AT&T ... Verizon had full glorious bars at my house, but not a half mile down the road, flat nothing, so I'm not sure what physics glitch enabled it to be so good at my house.  I live in a really mountainy area and there's dead zones where even regular FM car stereo waves don't dare venture.  I guess Verizon's tower is positioned just right that it's line of sight with my house somewhere, and AT&T's isn't.  But I have to agree it sounds pretty funny.

  • Like 1

Share this post


Link to post
Share on other sites

AT&T got back to me and said Wi-Fi Calling is for AT&T Enabled devices only and is not available for unlocked devices.  So ... no love for the Pro1 here 😞

I will probably wind up running some VoIP app and setting up Google Voice to ring it -- I don't give out my "bare" cell number to anyone so for my situation that would be acceptable.  So long as I can figure it out for less than the $20 / mo I'm saving anyway 😉

Share this post


Link to post
Share on other sites

I have (theoretically) set up the Google Voice app to do incoming calls over Wi Fi.  Much as I hate to rely on a Google app (I'm trying to start de-googling my life ... gonna do the Lineage thing as soon as we've got an official release!) its what I have to do right now.

Share this post


Link to post
Share on other sites

Thanks for replying and letting us know about the AT&T branded devices v.s. the unlocked devices!

Ouch!  So sorry you have to be linked at the hip with Google. Ugh.

Share this post


Link to post
Share on other sites

I wonder if the mule trick would work here like it does for Verizon.  Of course, you'd have to have an AT&T enabled phone that you didn't need anymore, which is unlikely as you were Verizon.  Just curious.

  • Like 1

Share this post


Link to post
Share on other sites

I'm on T-Mobile, but if you do try the bait and switch with an activated phone, it could be of use.

The wifi-calling option actually seems to be in the phone app itself. If you tap the dots and go settings > calling accounts > [your sim card name] > wifi calling, you should get options there.

Of course, your experience may differ because different network and all that. That's just where I found the setting on my phone.

And I did confirm it worked, complete with the person I called saying I cut off a bit at the beginning (a hallmark of wifi calling it seems :D).

  • Like 2

Share this post


Link to post
Share on other sites
45 minutes ago, Hook said:

I wonder if the mule trick would work here like it does for Verizon.  Of course, you'd have to have an AT&T enabled phone that you didn't need anymore, which is unlikely as you were Verizon.  Just curious.

...but such a phone could be bought of of Ebay for less than $20.

  • Like 1

Share this post


Link to post
Share on other sites

Thank you @SirBaconIII, I'm also on T-Mobile, and the setting in the phone app was the missing piece I needed to get WiFi calling back. It was working on my two previous devices (Pixel 1 & Essential) and given that my office is practically a Faraday cage, I was sorely missing it.

Share this post


Link to post
Share on other sites
Just now, wilhelmfitzpatrick said:

Thank you @SirBaconIII, I'm also on T-Mobile, and the setting in the phone app was the missing piece I needed to get WiFi calling back. It was working on my two previous devices (Pixel 1 & Essential) and given that my office is practically a Faraday cage, I was sorely missing it.

Glad I could help. Now I need to find a time to call them and ask them to set up a profile for native voicemail, but I'll probably talk about that in a new topic if need be.

Share this post


Link to post
Share on other sites
3 hours ago, SirBaconIII said:

I'm on T-Mobile, but if you do try the bait and switch with an activated phone, it could be of use.

The wifi-calling option actually seems to be in the phone app itself. If you tap the dots and go settings > calling accounts > [your sim card name] > wifi calling, you should get options there.

Of course, your experience may differ because different network and all that. That's just where I found the setting on my phone.

And I did confirm it worked, complete with the person I called saying I cut off a bit at the beginning (a hallmark of wifi calling it seems :D).

Unfortunately, I don't have the option there, the line simply isn't there.

I'd be curious if someone else who has AT&T could try the mule phone trick -- it might work for wifi calling.  I'm also going to look into services other than Google Voice.  So long as I pay less than $20 / mo, I'm doing better than I was 🙂  Though, for the immediate moment, I have a working solution.

Share this post


Link to post
Share on other sites
On 2/4/2020 at 3:53 PM, SirBaconIII said:

I'm on T-Mobile, but if you do try the bait and switch with an activated phone, it could be of use.

The wifi-calling option actually seems to be in the phone app itself. If you tap the dots and go settings > calling accounts > [your sim card name] > wifi calling, you should get options there.

Of course, your experience may differ because different network and all that. That's just where I found the setting on my phone.

And I did confirm it worked, complete with the person I called saying I cut off a bit at the beginning (a hallmark of wifi calling it seems :D).

I looked at this on my Pro1, on t-mobile today.  If I turn on the option there and then go into airplane mode, but re-enable wifi, it wouldn't let me place a call.  That doesn't mean that it isn't just shortsightedness by the phone app programmers.  It could still be making a wifi call, but I don't really have an easy way too prove it.  I can possibly look at my lan network traffic sometime while testing it.  There is a chance it isn't really doing wifi calling, however.

Share this post


Link to post
Share on other sites
On 2/4/2020 at 11:37 AM, cheetah said:

I have (theoretically) set up the Google Voice app to do incoming calls over Wi Fi.  Much as I hate to rely on a Google app (I'm trying to start de-googling my life ... gonna do the Lineage thing as soon as we've got an official release!) its what I have to do right now.

Port the number to MightyCall. It's 19.99 a month for 1000 minutes, lots of enterprise-grade features, and no more sGroogle! I've been using it for a little over a month now, and it is SUPER SLICK. It is designed for business.

Share this post


Link to post
Share on other sites
5 hours ago, david said:

I looked at this on my Pro1, on t-mobile today.  If I turn on the option there and then go into airplane mode, but re-enable wifi, it wouldn't let me place a call.  That doesn't mean that it isn't just shortsightedness by the phone app programmers.  It could still be making a wifi call, but I don't really have an easy way too prove it.  I can possibly look at my lan network traffic sometime while testing it.  There is a chance it isn't really doing wifi calling, however.

If wi-fi calling works, then you can place a call in airplane mode, with wifi enabled. Tried and verified with the Pro1 by myself (Telia Sweden). Keep in mind that most operators still require specific phone models in order to provision wifi calling. It's likely that AT&T doesn't allow the Pro1. Most operators have become more lax the last year. The reason why they have been so restrictive is because the lack of standardization and stability of this feature, according to the rumor mill. Telia has however switched to a more lax model recently, as I didn't expect this to work.

 

Anyway, Telia Sweden doesn't help with AT&T. My point is that it's pointless to try and get wifi calling to work unless it's provisioned by the network. You can't force it from the terminal/phone.

  • Thanks 1

Share this post


Link to post
Share on other sites

I know this is an AT&T topic, but I contacted t-mobile on facebook (t-force) and will report back with my findings, as it pertains to getting it provisioned for wi-fi calling.

UPDATE:  I now have wifi calling working on T-mobile with the Pro1.  As I said I would do above, I contacted them on facebook (that is supposed to be the place to get the best results).  They call that group T-Force on there.  I sent them a message stating that I'd like to get my new phone provisioned for wifi calling.  They said I needed to have an E911 address set up in my account online, for this line.  I went online and it showed my line was already set up with my address.  It had a "usage address" for where the phone would be used the most (for tax purposes) and an address for the E911.  The first one was still set to an old address I lived at years ago.  I updated that one, so then both were set to the same address.  I didn't have to update the E911 address.  I don't think I hit save on its page, but it is possible.

They had also given me a link to see all the phones t-mobile supports for wifi calling.  I told them this phone wouldn't be on there, as it was from a new manufacturer.  They asked me to authenticate my account so they could look at it.  (that's normal on facebook.  You just have to log-in through a link they send you on there in a pop-up window) 

They came back and said that I was set up properly for wifi calling and it should work if the phone supports wifi calling on t-mobile.

They asked me for the name of the phone and I sent them a link to the fxtec website. 

They said it was a cool looking phone.  :-)  They said that if my account is set up properly for wifi calling (they said mine is), then it will work on any compatible device.  They said they couldn't guarantee it would work for me.  They said they looked on the forums (these forums) and saw that some people said it was working by going into the phone app settings, etc.  :-)  I told them I'm in this chat too, and it didn't work for me when I was in airplane mode with wifi turned on, but that I'd try again.

I went back into the phone app, I enabled wifi calling, I enabled airplane mode, I re-enabled wifi, I placed a call to myself, and got through to my voicemail!  The call icon shows a mini-wifi signal icon next to it too.

They said they didn't do a thing on their end.  So either:

- They did something and didn't tell me

- They inadvertently triggered something looking  at the my account

- Me merely going into the E911 screen now that I have the new phone/sim on the account, triggered something

- Me setting the usage address to the E911 address did it

- I accidentally hit save in the E911 screen

- It didn't want to work the first time on my phone, but worked the second time, for whatever reason.  If this is the case, the steps I took were to go into the phone settings, flip the switch for wifi calling, try to place a call when in airplane mode, with wifi on, fail, go back into the phone settings and disable wifi calling.  Tried to place a wifi call again, in airplane mode.  (used the phone for a while, doing other things) Went back into the phone app settings and enabled wifi calling.  Tried to place a call when in airplane mode, with wifi on, and succeeded.

 

254744046_Screenshot(Feb17202011_34_52PM).thumb.jpg.528a0718f939484e163645db8b0bfef0.jpg

 

For anyone else on T-Mobile (possibly other carriers, in the USA and Canada), I would recommend going into your online account settings for your Pro1 line and going into the E911 screen.  If it isn't set, set it.  If you have a Usage Address in another screen, set it to the same as the E911 address.  I'd recommend hitting save on the E911 screen, even if you haven't changed the E911 address.

And if it doesn't work the first time you test it (with wifi calling enabled in the phone app settings), disable the setting and try again.  To be a valid test, you should be in airplane mode.

 

Edited by david
  • Like 1

Share this post


Link to post
Share on other sites

I am on Telstra Australia trying to get WIFI calling going. Have confirmed with Telstra that it is activated. I can't seem to get the VoLTE buttons to turn on, they are greyed out when accessing via *#*#4636#*#*Screenshot_20200218-202638.thumb.png.f510878c301cc9684268c9324dbc5380.png 

Screenshot_20200218-203155.png

Screenshot_20200218-203043.png

Share this post


Link to post
Share on other sites
10 hours ago, ahunter said:

Anyone know how to force provisioning?

I have no idea what's taking place with your carrier, but with AT&T in the US all the switches are grayed out for me too; however, but both VoLTE and VoWiFi work.  The only way to turn VoLTE off is to use the switch enable/disable 4G/LTE switch in the mobile network configuration.  If it is on it will place VoLTE calls by default (when service allows), if it is off then it won't.  The fact that they are grayed out in the off position is a known Android issue.

  • Thanks 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Terms