Jump to content
Wasmachineman_NL

Sane camera app: does it exist?

Recommended Posts

9 minutes ago, netman said:

I like opencamera, the shutter button doesn't yet work in it though (but should be a relatively easy fix in future OTA).

Wow, this already is miles better than the awful Snapdragon Camera. Thanks @netman!

Edited by Wasmachineman_NL
  • Like 2

Share this post


Link to post
Share on other sites
19 minutes ago, Wasmachineman_NL said:

I was filming my new washing machine today but the Pro1 camera app decided to do all sorts of random shit while recording, which pissed me off greatly.

With that comes my question: is there a sane camera app for the Pro1?

What did the default app do? 

Share this post


Link to post
Share on other sites
3 minutes ago, david said:

What did the default app do? 

No autofocus, no shutter sound, and whoever came up with the idea of swiping to open the camaera settings should be thrown into that W918 while it's spinning at max RPM lynched.

At least Open Camera seems to be sane compared to Snapdragon Camera, i'll try to catch the rinses of that W918 later tonight.

Also, side note: the Pro1's camera is really, really sensitive to PWM dimming of LED lighting, as you can see.

Edited by Wasmachineman_NL
  • Like 1

Share this post


Link to post
Share on other sites
26 minutes ago, Wasmachineman_NL said:

Filmed with Open Camera, and I found a quirk: opening/closing the keyboard stops recording.

I did a quick check.

It also stops recording if I press F5 or F6 on Pro1's keyboard (own layout) and unfortunately Pro1 sends these keypresses on opening/closing event.
I have also checked on my Motorola G6 using a bluetooth keyboard and it also stopped when I pressed F6 or F7 keys (yes, it seems to be shifted).

So it seems OpenCamera has a function mapped to these keys and that is why it stops when you open or close Pro1's slider.
It also reacts when I press yellow arrow anyway.

So this behaviour will change if F(x)tec assigns a better keypress event for slider open/close functions.
(If you try Total Commander, you will also find stange behaviour as it handles F5/F6 as copy/move function, so a dialogue will appear when you open/close slider.)

Anyway, GCam Port continues recording even if keyboard opened/closed event appears...

  • Like 1

Share this post


Link to post
Share on other sites

Oh wow yeah OpenCamera is way better for starters. Had a freeze after taking a picture that didn't get saved but still less frustrating experience than whatever was going on with the stock. 

Don't forget to set it to max quality video and image though as by default it is 1080p and 90%. Usually take portrait pics so the shutter button isn't very useful. 

Share this post


Link to post
Share on other sites
2 hours ago, Wasmachineman_NL said:

I was filming my new washing machine today but the Pro1 camera app decided to do all sorts of random shit while recording, which pissed me off greatly.

Are you sure you weren't recording a video monitor playing back a recording of a video monitor playing back a recording of a washing machine?

  • Like 1

Share this post


Link to post
Share on other sites

Google around for the pixel camera apk. The camera apk adds all of the goodies the pixel has.

Share this post


Link to post
Share on other sites

I have been using Open Camera for years, and can highly recommend it.

There is one issue with the Pro1: HDR does not work well. There seems to be a bug in the API delivering images at the requested ISO, so when Open Camera then tries to stitch things together we get some weird halos. I saw it a lot on the tough motif of my white dog. Open Camera has no problems with this on other phones i tried. And the Pro1 can do HDR just fine in their build in app. So must be a parameter translation issue in the API. My GUESS some confussion between linear and logarithmic scales in their implementation of the Camera2 API.

Share this post


Link to post
Share on other sites

"A Better Camera" and "Camera FV-5" seem to work well.

Using Googe Photo's for colour/image corrections and I have had some very stunning results.

  • Like 1

Share this post


Link to post
Share on other sites

I take back what I said about Open Camera and found it to not be suitable or smoothly functioning at all on my otherwise lean Pro 1.

Went back to using Snapdragon until I find and install the right Google APK. The main thing in both was how slow it was to take a picture.

Especially in low light, it would take as much as 4-5 seconds to shine for focus and then flash again for the actual photo. Daylight is OK but not very detailed or crisp.

 

edit: Thank you AHunter I will try those as they will be quicker and easier to install than the Gcam APK.

Edited by Adrienspawn
  • Like 1

Share this post


Link to post
Share on other sites
20 minutes ago, Adrienspawn said:

I take back what I said about Open Camera and found it to not be suitable or smoothly functioning at all on my otherwise lean Pro 1.

Went back to using Snapdragon until I find and install the right Google APK. The main thing in both was how slow it was to take a picture.

Especially in low light, it would take as much as 4-5 seconds to shine for focus and then flash again for the actual photo. Daylight is OK but not very detailed or crisp.

 

edit: Thank you AHunter I will try those as they will be quicker and easier to install than the Gcam APK.

Did you mean that Night Sight is slow? The whole idea behind it is to take sevaral shots and combine them to one picture. There are some algorithms that can produce geat pictures in low light. It is the "magic" behind Gcam.

  • Like 2

Share this post


Link to post
Share on other sites
46 minutes ago, Craig said:

Does night sight use flash?

It didn't in my experiences.  But, in general, the magic in GCam does seem to revolve around taking many pictures in the background and doing some magical processing on them to come up with a good looking composite picture, so it can be slower, depending on the mode used.  If you use regular HDR+, that's faster than HDR+ Enhanced, for instance, but the output isn't as good in difficult situations.

Of course, I'm speaking in nitpicky terms.  All of this is much better than the camera sensors and software of several years ago, which is what I am transitioning from. 🙂

This is the GCam port I'm currently using.  I do have another one installed as well, but this one has the night sight viewfinder right side up and the other one is upside down.

https://forum.xda-developers.com/poco-f1/themes/b-s-g-google-camera-port-developed-mi-8-t3843130

Direct link to the version I'm using:  https://androidfilehost.com/?fid=4349826312261725819

UPDATE:   I should also mention that this version has the astrophotography option.  It only goes for 13 seconds, vs 4 minutes on a Pixel 4, but it is better than nothing.

Edited by david
  • Like 2

Share this post


Link to post
Share on other sites
2 hours ago, FlyingAntero said:

Did you mean that Night Sight is slow? The whole idea behind it is to take sevaral shots and combine them to one picture. There are some algorithms that can produce geat pictures in low light. It is the "magic" behind Gcam.

No.

All photos are slow to be taken especially dim light ones. I have no idea what that option is and have not used Gcam yet, only Snapdragon and OpenCamera.

David thanks for the link I will try it out.

Edit: Bless the heavenly fathers. Now I have an actual useable camera. A million thanks.

Edited by Adrienspawn
  • Haha 1

Share this post


Link to post
Share on other sites

"Camera FV-5" definitely taking a better picture in auto mode compared to better camera. Even though it is built to have similar function to a digital SLR

Share this post


Link to post
Share on other sites

@Adrienspawn, or anyone else who is using the BSG GCam port, can you take and save videos?  Mine records, but then doesn't save it anywhere. 😞

Share this post


Link to post
Share on other sites

I don't know if it is only happening on my phone, but when I take a video with the BSG GCam port, after I hit stop and it acts like it is writing it, I can't get to it through the thumbnail.  When I tap on that, I get a blank view with a camera icon over it.  When I go into the gallery or google photos, it isn't there.  However, if I take a still picture and then go into one of the grid views, it is somehow found by the system and it shows up in the grid. 

If I go into a file explorer program after taking a video, the file is there.  Once opening it that way, it again will show up in the gallery/google photos apps.  Something is keeping it hidden in some way.  Very odd.  It doesn't happen with the other GCam port I have.

One other thing I've found is if I take a video with the other GCam port I have (from san1ty...https://www.celsoazevedo.com/files/android/google-camera/dev-san1ty/  the 20200216 .apk), in 4K mode, and send that to people with Pixel 1 and Pixel 4 phones, through Viber, they get a message that the format can't be played.  If I dial it back to 1080p and take a video and send it to them, then it plays fine.  If I use another app to convert the 4K version to a 1080p version, and send that, they can view that just fine too.

Share this post


Link to post
Share on other sites
On 2/29/2020 at 1:19 AM, Adrienspawn said:

You're right it doesn't pull up the video from within the app from the thumbnail but I do see it in my google photos gallery 

This is on the BSG GCam?  So if you take a new video and don't take any photos, once you tap the thumbnail, it brings you to the Google photos gallery and you see it there?

Share this post


Link to post
Share on other sites

Okay, I just tried it again and it is behaving differently than before.  I have no idea why.  It shows blank in the thumbnail.  Tapping that gets a black view with a camera icon.  Tapping the thumbnail again (which shows the last photo, not the last video, even if the video was more recent), brings it to single photo view of that photo.  UPDATE:  After some period of time, it does show the last video in the thumbnail.

Tapping the gallery view icon brings me to Google photos gallery view, with the video not displayed immediately, but after a few seconds, it shows up.

  • Like 1

Share this post


Link to post
Share on other sites
3 hours ago, david said:

Okay, I just tried it again and it is behaving differently than before.  I have no idea why.  It shows blank in the thumbnail.  Tapping that gets a black view with a camera icon.  Tapping the thumbnail again (which shows the last photo, not the last video, even if the video was more recent), brings it to single photo view of that photo.  UPDATE:  After some period of time, it does show the last video in the thumbnail.

Tapping the gallery view icon brings me to Google photos gallery view, with the video not displayed immediately, but after a few seconds, it shows up.

I have noticed this behaviour depend on if you open with hardware button of from app shortcut. App shortcut works better.

Share this post


Link to post
Share on other sites
5 hours ago, ahunter said:

I have noticed this behaviour depend on if you open with hardware button of from app shortcut. App shortcut works better.

All my tests are from app shortcuts. 

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Terms