Jump to content
dt.white

Digitizer Input Without Touch

Recommended Posts

OK, so not sure if this is actually a bug or not, but need to see if anybody else is experiencing this issue.

Note: my device has never been dropped, and this behaviour started yesterday evening. Multiple reboots have not resolved the issue.

Essentially, whenever I'm using my device, it intermittently registers multiple touches along a single line of the digitizer, causing completely unanticipated behaviour which as you can imagine, is very frustrating and makes the device very difficult to use - I even had difficulty recording it! (but I managed). Please see the linked video file, which I recorded. Note I've turned on both the options for seeing touch input (user and developer) to give as much detail as possible.

If anybody else is experiencing this or has any ideas as to what is happening, please let me know.

Thanks

  • Like 2

Share this post


Link to post
Share on other sites

This sounds like a physical glitch in the digitizer. I get this from time to time with my Droid 4 as well, and turning off the screen and wiping it on my pants has so far resolved it every time. If it is persistent and/or stubborn, I'd definitely see about getting it warranty replaced once things get back to normal in China. If you don't wait until then, you'll likely be without it for some time.

Share this post


Link to post
Share on other sites

It is definitely persistent so I've contacted support, they will be sending out a replacement screen with instructions on how to replace it.

I had the option of sending it the phone off to a centre in London but decided I'd give it a go myself instead (I like a little tinkering).

Will update this post when it's replaced to advise on the outcome.

  • Like 3
  • Thanks 1

Share this post


Link to post
Share on other sites
12 hours ago, dt.white said:

Will update this post when it's replaced to advise on the outcome.

Thanks for any details you can give us on the process of what it took to replace it and how it works afterward.

Share this post


Link to post
Share on other sites

My phone has developed the same problem ūüėě
Was it easy to replace the screen?

 

  • Like 1

Share this post


Link to post
Share on other sites

@hka I'm still waiting for delivery of the screen replacement, I've just chased this up with support.

I am no longer experiencing the original issue of multiple registered touches - it has now evolved into simply being a dead part of the screen, approximately 8mm in height, so I am just working around that (useful to have a keyboard!)

  • Like 1

Share this post


Link to post
Share on other sites
3 hours ago, dt.white said:

@hka I'm still waiting for delivery of the screen replacement, I've just chased this up with support.

I am no longer experiencing the original issue of multiple registered touches - it has now evolved into simply being a dead part of the screen, approximately 8mm in height, so I am just working around that (useful to have a keyboard!)

Ah I see, yeah I am in contact with support, will have to see were that leads. Temporary solution is to use an app I found called "Partial screen" it supports putting touch masks over the screen, but they are not transparent so now I have an 8 mm high ribbon over the screen where I cant see, would be better if it was just dead and not phantom touches.

  • Like 1

Share this post


Link to post
Share on other sites

Just to update everyone - I have received a new screen through the post this morning. When I get a chance I will attempt to replace it and video it for reference.

  • Like 4
  • Thanks 1

Share this post


Link to post
Share on other sites

i just replaced my screen a few days ago - wasn't hard at all, see here. i followed for that TeZdevice's advice here.  you can do it in less tan half an hour.  my screen & digitizer worked thereafter flawlessly. 

the reboot also brought back some sound effects such as the glang when charging - which implies that Android isn't as stable as a full-fledged unix box.  my linux-based Nokia N900 was rock-stable and robust with uptimes up to a year or so...

 

 

  • Thanks 2

Share this post


Link to post
Share on other sites

OK so I've replaced the screen - thanks @pistikem for the references. I did film it but not sure it's worth uploading as the guides above are of much better quality.

Unfortunately, it appears the screen I've been sent has problems. While it's solved my initial issue, I've now got two "dead" zones running down each edge of the display, left and right. The reason I use the quotations is that it registers touch if I drag out from the middle of the display, but doesn't register a direct touch or dragging in from the edge of the display, which is most peculiar.

I replaced it again with the original just to make sure that I hadn't done something wrong, got the same original issue. Then replaced again with the new screen, and got this edge touch issue again - so nothing to do with the way I'm installing it I believe.

I think I'm going to have to request another screen, which is very frustrating given the length of time to receive this one..

  • Sad 5

Share this post


Link to post
Share on other sites
Posted (edited)

Just to add as well - I've also got light bleed around all four edges which I noticed last night once it was dark. Definitely going to be requesting another replacement, and going to put the original back on for now as it's more useable..

See attached video for a demonstration of the "dead" zones with new display.

Edited by dt.white
Typo

Share this post


Link to post
Share on other sites

Doesn't look like right. Maybe have been damaged in transit. We'll send another one. Will discuss with you over email.

  • Like 1
  • Thanks 5

Share this post


Link to post
Share on other sites
On 6/16/2020 at 2:38 PM, Erik said:

Doesn't look like right. Maybe have been damaged in transit. We'll send another one. Will discuss with you over email.

So I've now had an email from support which is basically insinuating that the engineers don't believe the video and that some software has been applied to cause the touches from the edge to not respond. This is pretty insulting and not a good look.

I will be refitting the replacement display and taking a video of the device to show the light bleed too as that is apparently what is required to convince F(x)tec that the display is faulty.

@Erik @Waxberry As a backer for your IndieGoGo campaign and therefore a loyal follower of your company up to this point, I think you need to address this. Frankly, it stinks.

  • Sad 2

Share this post


Link to post
Share on other sites
11 hours ago, Slion said:

@dt.white Sorry you are having so much problem with your hardware. You are not the only one unfortunately. Hope you get this sorted soon though to be honest considering FxTec current work load I doubt it.

I know there are a lot of hardware issues @Slion and it's not that which is the problem - it's the insinuation that I'm essentially lying in order to get another display..

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Terms