Jump to content

Pro1X, Physical keyboard layout issues [Fixed, other software interfering]


Recommended Posts

17 minutes ago, EskeRahn said:

That they worked initially is a good sign, so most likely you can avoid the full reset.

I agree with @Hook's suggestion, but start with any app that is mentioned as active under Accessibility - or just switch its rights off under accessibility. And if that does not do it, focus on anything keyboard-related, or 'fancy', the more complex the larger the risk of it trying to be clever and mess of stuff.

You could try to just STOP rather than uninstall stuff first, with the risk of them being brought back to live, making tests harder. A reboot often restarts a lot of junk you may have stopped - thanks Android.... ūü§Ę

You MIGHT need to do a reboot after uninstalling some stuff, to see the effect.

Note on the first thing, if you did a Google restore of apps this MIGHT take quite a while, so you could have seen the keys working before some settings messed things up.

Good hunting - and please report back when you narrow down the culprit.


Sometimes in life you are a lucky guy, and the problem-app begins with an "A". Anydesk was the influencer in my case. I did not even had to uninstall it.  Just removed all the rights in the special-rights chapter.  And my physical keyboard is giving me the proper values again.

Thanks to all !

  • Like 2
  • Thanks 2
Link to post
Share on other sites
1 hour ago, Tell-Son said:


Sometimes in life you are a lucky guy, and the problem-app begins with an "A". Anydesk was the influencer in my case. I did not even had to uninstall it.  Just removed all the rights in the special-rights chapter.  And my physical keyboard is giving me the proper values again.

Thanks to all !

Great, lucky you that it was not zx browser.... ūü§£

  • Haha 1
Link to post
Share on other sites
  • EskeRahn changed the title to Physical keyboard layout issues [Fixed, other software interfering]
  • 5 weeks later...

Slightly related - I had issues with FxService effectively disabling FinQwerty layouts on my Pro1x (only the default layouts worked correctly, FinQwerty layouts behaved as if I had the default stock QWERTY selected). I reported the issue to @Slion (the author of FxService), but he probably couldn't have analyzed it in detail due to only having Pro1 and not Pro1x.

  • Like 1
Link to post
Share on other sites
4 hours ago, xhajt03 said:

Slightly related - I had issues with FxService effectively disabling FinQwerty layouts on my Pro1x (only the default layouts worked correctly, FinQwerty layouts behaved as if I had the default stock QWERTY selected). I reported the issue to @Slion (the author of FxService), but he probably couldn't have analyzed it in detail due to only having Pro1 and not Pro1x.

I have recently ran into a similar issue on my Pro1.
I have installed AnyDesk which has installed a service and I had no FinQwerty-like layouts working until I have found that application was the cause of my issue and disabled its service.

(Pro1, LineageOS 18.1 here.)

  • Thanks 1
Link to post
Share on other sites
  • 2 weeks later...
On 8/18/2022 at 2:39 PM, Rob. S. said:

QWERTZ with 'Physical Keyboard' set to 'German' indeed generally works. Although there are two bugs in the layout which make both the accent grave or backtick < ` > and the apostrophe < ' > unavailable [...]

The FinQuerty app which now also has layouts for the Pro1 X (thanks to @EskeRahn for mentioning this), fixes this issue with the "FinQuerty F(x)tec Pro1 X, German for physical DE QWERTZ" layout. Excellent.

Edited by Rob. S.
  • Like 3
  • Thanks 1
Link to post
Share on other sites
  • EskeRahn changed the title to Pro1X, Physical keyboard layout issues [Fixed, other software interfering]

I just tried Pro¬Ļ-x for the first time today.¬† I have tried lots of things and cannot get pipe or backslash to come out of this keyboard, with layout set to both US and unset to default.¬†¬†¬†

Google Assistant has no accessbility permission.  The only thing that has accessibility permission is kde connect.

In any case, even tho the keys aren't printed right, semi colon and question mark are exactly where they should be for US layout.   

I think I'm gunna keymapper to turn Del to KEYCODE_BACKSLASH (and thus shift+del = pipe), and shift backspace to del and just avoid figuring out what weird thing fxtec did this time.   I will only use pipe when doing shell stuff and backslash only if i use dosbox, but slash, semnicolon, and question mark are part of normal English and I'm glad they work where they are already anyway.

Edited by Craig
Link to post
Share on other sites
3 hours ago, Craig said:

I just tried Pro¬Ļ-x for the first time today.¬† I have tried lots of things and cannot get pipe or backslash to come out of this keyboard, with layout set to both US and unset to default

Did you try FinQwerty? It now also has layouts for Pro1X.

Link to post
Share on other sites
2 minutes ago, EskeRahn said:

Did you try FinQwerty? It now also has layouts for Pro1X.

I did not.  I used Keymapper to assign keycode_backslash to delete key (which makes shift+"del" work automatically for pipe) and set shift+backspace to keycode_forward_delete.  So this particular issue is worked-around for me, even tho I could never make it work FxTec's way.

Edited by Craig
Link to post
Share on other sites
6 minutes ago, Craig said:

I did not.  I used Keymapper to assign keycode_backslash to delete key (which makes shift+"del" work automatically for pipe) and set shift+backspace to keycode_forward_delete.  So this particular issue is worked-around for me, even tho I could never make it work FxTec's way.

Have a look here: https://android.onse.fi/finqwerty/#pro1x

"English US" (no finqwerty) also includes them

 

image.thumb.png.361a1533ac903bc14b86b39165e87b36.png
 

  • Thanks 1
Link to post
Share on other sites
  • 4 months later...

Is there any way to make the stylized F-key NOT hide the active app on key release?

Theoretically, I get all the special characters I need on my QWERTY Pro1 X (recently replaced my QWERTZ Pro1 X with one) by using FinQwerty with the "U.S. intl. with dead keys for physical US QWERTY" layout for the Pro1. Its dead keys are entered with the F-key, though, and while that does work, the F-key also hides the active app on release, each and every time I enter any such character with it...

I have no idea what the F-key is actually doing there; I guess it somehow acts as the search key, but it doesn't really do what I find displyed in Settings -> System -> Languages and input -> Physical keyboard -> Keyboard shortcuts, either.

(I have no "Android Assistant" installed; I have also disabled "Google Assistant", which is to what the search key by itself is mapped according to that shortcuts overview.)

Edited by Rob. S.
realized that I was using a layout for the Pro1, not Pro1X
Link to post
Share on other sites
2 hours ago, Rob. S. said:

Is there any way to make the stylized F-key NOT hide the active app on key release?

It does this because F(x)tec makes the key generate KEY_HOMEPAGE. The fix is to change this in the kernel source, e.g. https://github.com/LineageOS/android_kernel_fxtec_sm6115/commit/41b535243dce9e057069adda494cbbaf8c720f35

  • Like 1
  • Thanks 1
Link to post
Share on other sites
1 hour ago, Sean McCreary said:

It does this because F(x)tec makes the key generate KEY_HOMEPAGE. The fix is to change this in the kernel source, e.g. https://github.com/LineageOS/android_kernel_fxtec_sm6115/commit/41b535243dce9e057069adda494cbbaf8c720f35

Thanks! Just noticed that the FinQuerty layout I had chosen was for the Pro1, not Pro1X... 

Edited by Rob. S.
  • Like 1
Link to post
Share on other sites

Made me try the¬†"U.S. intl. with Fn dead keys for physical US QWERTY" right now, which uses the arrow keys instead. Works like a charm‚ÄĒexcept that the question mark is missing (prints the semicolon instead)...¬†

Link to post
Share on other sites

The question mark is there, it's Alt-L! I completely overlooked that there is a fifth layer in that layout with the Alt key modifier, even if only a few keys are assigned there, and I only noticed it browsing through the .kcm files from github...

Even though these FinQwerty layouts were originally designed for the Pro1 with it's "shifted" physical QWERTY layout, they are still quite functional on the Pro1 X as they're overlays for actual keys like A or LEFT_BRACKET, not for lower-level keycodes. 

883799029_Bildschirmfotovom2023-03-1120-13-43.png.587c0ce01c5a5cebbeed25720f05f63a.png

There may still be some more minor differences to how it used to work on the Pro1 (see above),¬† but the good thing is, as long as we can remember to use Alt-L for '?'¬†and ? for ';', we¬†have a working US intl. keyboard layout for the QWERTY Pro1 X with an extreme wealth of special and international characters! ūüôā¬†

  • Like 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

Terms