Jump to content

Pro1X - Stock Android OS (Build Number: v2.1.2_20220707)

Recommended Posts

26 minutes ago, brunoais said:

Why not use a pen-drive and run from there?

Yes, that is about the same functionality. The great thing about the other solution, was that it was impossible for the systems to (even inadvertently) mess up each other, as the production disk was simply not mounted while running something else.
(I copied what ever data that needed to be shared to some usb-storage or SD with a RO-switch)
...For the most paranoid stuff, I had a disk with an OS with net removed, and unplugged the network cable....

Link to post
Share on other sites
  • Replies 80
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

NEW Version of guide here   Below the original text: (above inserted by EskeRahn)     If you're reading this, it seems like you miss the good old Android OS or you've acciden

F(x)tec will release flashing instruction using Qulcomms QFIL software on windows soon. The unofficial method to flash the provided EDL images that testers used on linux would be: Install EDL-T

My backup persist does have keys in it.  My persist flashed onto the device (for now) does have keys in it.  restorecon relabeled everything.  After a reboot, I still don't have attestation.  restored

Posted Images

I'm not a Windows or Mac user, but I'm pretty happy that we have two tools at hand, including one that's multiplatform, fully open source and based on an open source language. The alternatives to that would either be (i) nothing or (ii) proprietary software, which I would view as a much higher "infection" risk. 

I mean, at some point we'll have to install something on our machines to perform operations to reflash our Pro1(x), there's no other way, and them being flashable easily was one of their selling points. Python also is a language that can easily be containerized in a virtual environment, if that's a concern.

Edited by matf-kabouik
  • Like 3
Link to post
Share on other sites
  • 3 weeks later...

Hi all, I got my fx phone about a month ago. When I got it there was an android OS on it and I decided (wish I hadn't!) to try to put Lineage on it.

I don't know what I did but it ended up in what has been described by EskeRahn, on a reply to a previous posting on this thread, as the Bootloader screen, and I have been stuck on this screen ever since.


As you might gather, during the course of trying to fix this I made it worse because somehow I locked the bootloader screen

I've tried the all key combinations and the most I got out of it was I was able to shut the phone down when I pressed all the keys at once.

The "fastboot devices" works more often than not, so I can list the device on my terminal screen with that

However, no matter what I try it doesn't seem to connect with adb. I can try "adb devices" but it hasn't listed it at all. Same with all the "adb" commands I have tried.

Incedntally, I did try "fastboot flashing unlock" and it returned this:

FAILED (remote: 'Flashing Unlock is not allowed
fastboot: error: Command failed

Can anybody help? I'm a stroke survivor but haven't survived intact. Before, I was not bad at this kind of thing (you could describe me as a moderately skilled Linux user), but since that happened I have memory problems and I easily get confused.

Hope somebody can help


  • Sad 1
Link to post
Share on other sites

It should still be possible to flash the stock rom using EDL, probably even using fastboot.

Fastboot restore guide: https://drive.google.com/drive/folders/18Clj6qv4jXIFGfy0S1NO1K8DoN8bJ3Ms

A locked bootloader should only prevent you from installing custom ROMs.

I would still recommend you contact fxtech.


Edited by Benni
  • Like 1
  • Thanks 1
Link to post
Share on other sites

@maridavAre your sure to not mix up Pro¹ and Pro¹-X intructions and even images?
Those are two completely different devices due to different SoC and the Firmware is not interchangeable.
For the Pro¹, the unlock command is `fastboot oem unlock` for example.
Also, there is no LineageOS for Pro¹-X yet. so i figure you tried to flash the Pro¹ LOS files?
LineageOS for Pro¹-X has just now been booted up first time by a dev as reported on Telegram.

Edited by mosen
  • Like 1
  • Thanks 2
Link to post
Share on other sites

Thank you all, I will attempt to try the measures that you suggested. It may take a couple of days to unravel it and I'll keep you posted (if only to report success, or I get mixed up again)

I particularly take note of mosen's post as I very well may have mixed the Pro¹ and Pro¹-X up, in fact I didn't discern between the two at all. I just went to the box it came in and on the front of the quick start instructions


I think that means I have Pro 1 x, but I've definitely not check whether I'm downloading the wrong thing or followed the instructions for wrong phone. From now on I'll double check the instructions to see which phone it refers to

Thank you all again

  • Like 3
  • Thanks 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information