Jump to content

LineageOS 21.0 Official Release for Pro1 (QX1000)


Recommended Posts

(lineage-21.0-20240518-nightly-pro1-signed.zip on May 5 security patch installed smoothly (*) using adb sideload and MindTheGapps-14.0.0-arm64-20231025_234300)

And we still can only select one keyboard layout, so no easy layout switching, for multilingual usage.

  • Like 2
Link to post
Share on other sites
  • Replies 80
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Official Release: https://download.lineageos.org/devices/pro1/builds Changelog: https://download.lineageos.org/devices/pro1/changes First Build: INCLUDED IN LINEAGE-21.0-20240215-NIGHTLY-PRO

I have opened bug report on lineageos gitlab. https://gitlab.com/LineageOS/issues/android/-/issues/7410

Lineage-21.0-20240707nightly-pro1-signed.zip on July 5 (2024) security patch, installed smoothly using OTA BUT with these following issues: no camera no accelerometer + proximity sen

Can anyone tell me if this version has PPTP enabled.  I am considering to upgrade from my old  lineage 18.1 build as it is signed with a test key and have some play device integrity issue...

Link to post
Share on other sites

(lineage-21.0-20240615-nightly-pro1-signed.zip on May 5 security patch installed smoothly (*) using adb sideload and MindTheGapps-14.0.0-arm64-20231025_234300)

And we still can only select one keyboard layout, so no easy layout switching, for multilingual usage.

  • Like 2
Link to post
Share on other sites

Just had an update come through, dated 23 June. Now there is something up with the camera.

Torch wont work, says camera in use. Open camera says another app is using the camera. Disabling the Camera app made no difference. 

  • Sad 2
Link to post
Share on other sites
4 hours ago, Kzin said:

Just had an update come through, dated 23 June. Now there is something up with the camera.

Torch wont work, says camera in use. Open camera says another app is using the camera. Disabling the Camera app made no difference. 

Interestingly, when I check for an OTA update on my Pro1, which currently is on the June 15th update, it says no updates found.  And when I check their download page, June 15th is the latest.  Maybe they pulled it?

Link to post
Share on other sites
3 hours ago, Kzin said:

According to "npjohnson" on XDA "working on it, th official has the same issue".

Have you been using Npj's build all along or did you somehow install Npj's build over the official build, because the later might create problems of it's own.

Link to post
Share on other sites

Lineage-21-20240629-NIGHTLY-pro1 with June 5th security patch installed smoothly via OTA. MindTheGapps14, and root was maintained.

However:

The camera problem reported above for the Oddsoulutions version showed up here as well.  Neither the AOSP default camera,  nor Open Camera work.  Open Camera reports "Failed to open camera. Camera may be in use by another application?"

For now I will wait and see if this gets fixed in a future update since I don't really use the camera on my Pro1, but this would be mighty inconvenient otherwise.  I have even tried a "battery pull" restart which often fixes wonky things, but didn't make a difference.

  • Thanks 1
  • Sad 1
Link to post
Share on other sites
Posted (edited)

Lineage-21.0-20240629nightly-pro1-signed.zip on May 5 (2024) security patch, installed smoothly using OTA

BUT with these following issues:

  • no camera
  • no accelerometer sensor
  • no flashlight function
Edited by TeZtdevice
Link to post
Share on other sites
16 hours ago, Hook said:

The camera problem reported above for the Oddsoulutions version showed up here as well.  Neither the AOSP default camera,  nor Open Camera work.  Open Camera reports "Failed to open camera. Camera may be in use by another application?"

FWIW, I remember when I was still using the Pro1 that was what LOS 18.1 told me when the internal camera cable had come loose after the phone had taken a hit or drop. (Which could always be fixed by applying sufficient pressure to the phone's back in the right place to reattach the cable.) 

Edited by Rob. S.
Link to post
Share on other sites

Just to chime in here, the camera seems to still work fine with both the build in Camera app and the Open Camera app with the older build in lineage-21.0-20240615-nightly-pro1-signed.zip

So I would recommend to make sure to get a copy from here of that version until the bug (hopefully) gets fixed.
As not all bugs got high priority, the working build might disappear by age, as only the last five builds are available for download. (On the priority, e.g. the keyboard is still almost useless for bilingual usage and has been so in all the 21.0 releases this far, so I am considering reverting to 20.0, and see 21.0 as as dead as the AICP releases)

Remember that going to a previous build (almost) always will require you to wipe the user data.

PS: Do not get me wrong, Not criticising here! I know this is all done voluntarily by some awesome people.

  • Like 1
Link to post
Share on other sites
On 6/30/2024 at 9:31 PM, EskeRahn said:

Just to chime in here, the camera seems to still work fine with both the build in Camera app and the Open Camera app with the older build in lineage-21.0-20240615-nightly-pro1-signed.zip

Remember that going to a previous build (almost) always will require you to wipe the user data.

 

So reverting to a previous nightly, will probably require a wipe? 

Link to post
Share on other sites
10 hours ago, Kzin said:

So reverting to a previous nightly, will probably require a wipe? 

Most likely. You could try without, but I would certainly be sure to back up stuff first, since I think the risk of having to wipe is high.

(My point was more to download and save the file, and if the issue is not fixed shortly, you have a return path)

  • Like 1
Link to post
Share on other sites
10 hours ago, Kzin said:

So reverting to a previous nightly, will probably require a wipe? 

I agree with @EskeRahn.  I would wait for the next update and see if that fixes it. The Pro1x seems to have updated without that problem-- I don't know if that means they solved it, or that it was somehow exclusively a Pro1 problem, but they will get it fixed and most everything else still works.

Link to post
Share on other sites
Posted (edited)

Lineage-21.0-20240707nightly-pro1-signed.zip on July 5 (2024) security patch, installed smoothly using OTA

BUT with these following issues:

  • no camera
  • no accelerometer + proximity sensors
  • no flashlight function
Edited by TeZtdevice
  • Thanks 2
  • Sad 2
Link to post
Share on other sites

...July 13 update installed without problem via OTA.

Problems persist

*no camera

*no flashlight etc

 

+ still problems (maybe only by me)

*slow/lagging screen rotating

*sometime no dialing tuut tuut sound

 

 

QUESTION...can i switch slot B->A for boot my previous installed build?

 

Edited by CornholioGSM
  • Thanks 1
Link to post
Share on other sites
8 hours ago, CornholioGSM said:

QUESTION...can i switch slot B->A for boot my previous installed build?

I tried switching from 6-22 back to 6-15 that way (using magisk's "install to inactive boot slot"). My phone wouldn't get past bootloader afterwards and I had to flash 6-22 via ADB to get it working again (data was still there).

Going from 7-13 back to 7-6 might work better again though. I know I had switched the boot partition successfully at least once. That time I used fastboot fwiw.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Terms