Jump to content
tdm

LineageOS, Current status : 16.0 Test Builds

Recommended Posts

22 minutes ago, Craig said:

And what the fuck.  First time I'm using test4 int he dark.  And the friggen backligt doesnt come [email protected]?#!?@#      I mean wtf.   How could this not be resolved by [email protected][email protected]#[email protected]#[email protected]#   AFter ore than a month of using sailfishos, i figured this basic stuff wasn't even still an issue.   Friggen lockups constantly, no backlight, keys are ignored, this completley sucks btw.  commits to fix sym key or fxtec key still not implemented.  it just basically sucks.  test2 was better cuz at the time it was better than stock.  but this just sucks.   fuck lineage.  fuck fxtec.   this thing is trash.

You really should be more open with sharing how you feel. 😉

  • Like 2
  • Haha 3

Share this post


Link to post
Share on other sites
13 minutes ago, david said:

You really should be more open with sharing how you feel. 😉

Whiskey helps.   (is it spelled whisky?  I spent a friggen half hour in wikipedia to learn it doesnt really matter, just depends if scotch/canadian/irish/american and even then, only if they want to, some american bottles are labeled the other way - the main point is to avoid anything labeled bourbon, that's evil if you enjoy a touch of rye or brandy in yer whisk(e)y)

Edited by Craig
  • Like 1
  • Haha 2

Share this post


Link to post
Share on other sites
2 hours ago, Craig said:

And what the fuck.  First time I'm using test4 int he dark.  And the friggen backligt doesnt come [email protected]?#[email protected]#      I mean wtf.   How could this not be resolved by [email protected][email protected]#[email protected]#[email protected]#   AFter ore than a month of using sailfishos, i figured this basic stuff wasn't even still an issue.   Friggen lockups constantly, no backlight, keys are ignored, this completley sucks btw.  commits to fix sym key or fxtec key still not implemented.  it just basically sucks.  test2 was better cuz at the time it was better than stock.  but this just sucks.   fuck lineage.  fuck fxtec.   this thing is trash.

backlight was broken all the time.

try this app, it works fine now. 

 

Edited by mcdinner

Share this post


Link to post
Share on other sites
8 hours ago, Craig said:

And what the fuck.  First time I'm using test4 int he dark.  And the friggen backligt doesnt come [email protected]?#[email protected]#      I mean wtf.   How could this not be resolved by [email protected][email protected]#[email protected]#[email protected]#   AFter ore than a month of using sailfishos, i figured this basic stuff wasn't even still an issue.   Friggen lockups constantly, no backlight, keys are ignored, this completley sucks btw.  commits to fix sym key or fxtec key still not implemented.  it just basically sucks.  test2 was better cuz at the time it was better than stock.  but this just sucks.   fuck lineage.  fuck fxtec.   this thing is trash.

Isn't this a community project? Isn't this being worked on by unpaid volunteers?

  • Thanks 3

Share this post


Link to post
Share on other sites

Regarding the slider causing the device to sleep, this is a build time configuration that, as far as I know, has no run time setting.  So I guess whichever people like the most is what should be done.  Personally, I find it very frustrating when the device goes to sleep on closing the slider because I frequently open the slider to type some text and then close it to go back to portrait/touch mode.

 

Regarding wake on keypress, I've got an idea for that and it is both pretty simple and should work for all systems (including sailfish).  Just track the screen state in the keyboard driver and if it's off, send KEY_WAKEUP before anything else.

 

Regarding the keyboard backlight, I believe @Sean McCreary has a fix for that in his tree.  I'll probably take that for the next build.  Or at least it's a start.

 

Regarding the crashing issues, I have not changed anything related in the kernel since test2.  So whatever is causing this is likely in the vendor image.  It could be either the 20191028 blobs that I'm using or it could be the things that are getting built from source.  That will have to be narrowed down.  By the way, I'm using the 20191028 blobs because the 20191203 build caused the screen on my device to act weird (it blinked off momentarily every few seconds).  So I haven't tried to update yet.  And those are the only two builds that I currently have because IdeaLTE and FxTec have not shared any later builds, and I haven't bothered to go back to stock to take any OTA updates.

 

But yeah, none of this is done yet because I'm lazy and Lineage sucks.  You should probably have me fired and go find another developer that can do a better job.  I never do anything useful or good for this device.  🙄

 

EDIT: And also, I just spent half an hour explaining why things are the way thay are instead of fixing things.  This is why developers don't really like forums.  I have half a mind to just stop engaging with this thread entirely until the device is working fully.

 

Edited by tdm
  • Thanks 13

Share this post


Link to post
Share on other sites
14 minutes ago, tdm said:

.

.

EDIT: And also, I just spent half an hour explaining why things are the way thay are instead of fixing things.  This is why developers don't really like forums.  I have half a mind to just stop engaging with this thread entirely until the device is working fully.

 

Thank God it's just half a mind because your posts are super informative and I, for one, would sorely miss them.  Thanks for all you are doing for us!

  • Thanks 7

Share this post


Link to post
Share on other sites
2 hours ago, tdm said:

EDIT: And also, I just spent half an hour explaining why things are the way thay are instead of fixing things.  This is why developers don't really like forums.  I have half a mind to just stop engaging with this thread entirely until the device is working fully.

please don't !

  • Thanks 8

Share this post


Link to post
Share on other sites

@tdm I agree with Polaris your post are quite insightful and the work you are doing is very much appreciated 👍

  • Thanks 8

Share this post


Link to post
Share on other sites
4 hours ago, tdm said:

EDIT: And also, I just spent half an hour explaining why things are the way thay are instead of fixing things.  This is why developers don't really like forums.  I have half a mind to just stop engaging with this thread entirely until the device is working fully.

 

Thanks for all the info, its good to take a break from developing and explain things from time to time.  It really helps to know the state of the project.  It would be nice if FxTec took more of an interest in helping make the software work, after all they were advertising it as Linaege compatible.  In any case keep up the good work and don't mind the complainers.

  • Like 2
  • Thanks 7

Share this post


Link to post
Share on other sites

Sorry for my ridiculous rant earlier.  Dont even remember posting it.  But it explains the way I'm feeling today, and why it was so hard to get up this morning.  1.75L bottles are  big.  Nothing justifies what I said or the way I said it tho.

Edited by Craig
  • Thanks 8
  • Haha 1

Share this post


Link to post
Share on other sites
11 minutes ago, Craig said:

Sorry for my ridiculous rant earlier.  Dont even remember posting it.  But it explains the way I'm feeling today, and why it was so hard to get up this morning.  1.75L bottles are  big.  Nothing justifies what I said or the way I said it tho.

It takes a big man to admit when you were wrong. Thank you for doing so. I'm sure the people involved will forgive you. It's rather harder when the poster wasn't intoxicated and isn't sorry, which has also happened.

  • Like 3
  • Thanks 1

Share this post


Link to post
Share on other sites

I've been actually developing on the Pro¹ today, which is a bit of a strange experience. I'm using ConnectBot to ssh into my build box, enabling adb over network, and connecting back to the device to push files and etc. Then I run "adb reboot" and *poof* the terminal goes away and the device reboots.

 

Anyway... so I've been pulling in patches from @Sean McCreary
and it looks like he's got the keyboard backlight fixed and the wake on any key fixed. So I'll probably make another build with those changes tomorrow.

 

PS. Please forgive formatting errors, this forum does not seem to play well with FireFox mobile

  • Like 3
  • Thanks 2

Share this post


Link to post
Share on other sites
28 minutes ago, Craig said:

Sorry for my ridiculous rant earlier.  Dont even remember posting it.  But it explains the way I'm feeling today, and why it was so hard to get up this morning.  1.75L bottles are  big.  Nothing justifies what I said or the way I said it tho.

By my calculations, that's roughly 32 units of alcohol per bottle. Pardon the personal interjection, but I certainly hope you didn't go through the entire thing in one night. I mean, I've drank quite a bit in my day (but haven't in quite some time now) and I think that would have killed me even at my peak of drinking.

 

  • Like 1
  • Haha 1

Share this post


Link to post
Share on other sites

Oh and referencing my previous post, if anyone wants to help out, can you go back to stock and take the latest ota and then post a copy of the vendor image somewhere? That would save me a couple hours of work.

 

Share this post


Link to post
Share on other sites
8 minutes ago, tdm said:

Oh and referencing my previous post, if anyone wants to help out, can you go back to stock and take the latest ota and then post a copy of the vendor image somewhere? That would save me a couple hours of work.

 

I'm not sure I know exactly what to do but if you mean basically tar up a copy of /system/vendor I can do that.  I had to go back to stock for now.

  • Like 1

Share this post


Link to post
Share on other sites
15 minutes ago, bmccrary said:

I'm not sure I know exactly what to do but if you mean basically tar up a copy of /system/vendor I can do that.  I had to go back to stock for now.

Well vendor is on its own partition. What I usually do is boot into recovery and 'dd' the vendor partition to /tmp:

 

did if=/dev/block/by-name/vendor_a of=/tmp/vendor.img

 

Then you can gzip it and adb pull it.

 

In order to do that you would probably need to use TWRP since lineage recovery won't have your host adb key setup.

  • Like 1

Share this post


Link to post
Share on other sites
2 hours ago, tdm said:

I've been actually developing on the Pro¹ today, which is a bit of a strange experience. I'm using ConnectBot to ssh into my build box, enabling adb over network, and connecting back to the device to push files and etc. Then I run "adb reboot" and *poof* the terminal goes away and the device reboots.

 

Anyway... so I've been pulling in patches from @Sean McCreary
and it looks like he's got the keyboard backlight fixed and the wake on any key fixed. So I'll probably make another build with those changes tomorrow.

 

PS. Please forgive formatting errors, this forum does not seem to play well with FireFox mobile

Brave mobile. 😉

In all seriousness though, thank you for all your hard work. It appears that very soon LOS will be much better than stock.

  • Thanks 2

Share this post


Link to post
Share on other sites
5 hours ago, silversolver said:

That is so awesome! This is truly a community build! @tdm is clearly the fearless pioneer, but you and @Sean McCreary and probably other people I haven't noticed have made meaningful contributions as well. Bravo!

Yeah, Though I sit with one question for @tdm, @Sean McCreary and others helping: Where are your guys donate buttons, so we can send you 'a beer'?

  • Like 3

Share this post


Link to post
Share on other sites
11 hours ago, Craig said:

  But it explains the way I'm feeling today, and why it was so hard to get up this morning.  1.75L bottles are  big. 

Wish had been there for that session 😂🤣

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Terms