Jump to content

AICP Q: Discussion


Recommended Posts

On 2/4/2021 at 9:31 PM, EvilDragon said:

Hm, weird indeed. Maybe it has something to do with the Bluetooth protocol used...

Which one age you using?

Guess you are refering to which bluetooth devices I use? 

Kia Optima 2019, Peltor XPI Alert, plantronics something, JBL bluetooth speaker.

Link to post
Share on other sites
  • Replies 172
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

I've done a first build of AICP Q using the Lineage 17.1 sources as a base.  After it is tested for a while, I will probably try to get official support.   The boot image is used just as in

A brief update...   I've been working on a backup/restore solution for Linux (plus an Android app to drive it) that will be able to do full backup/restore, similar to TWRP.   This

The archiver is making good progress.  I got busy with "real" work the past couple weeks so it has slowed a bit.  The following is working: - backup and restore partitions and filesystems. -

Posted Images

4 hours ago, Hook said:

Just curious, given the small scale of this development effort.  Will this be portable to the Pro1x with a different SOC. or will it remain Pro 1 (SD 835) only?

It builds off Lineage, so I will just wait for Nolen and Bruno to do the hard work... 😄

 

  • Like 3
  • Haha 3
Link to post
Share on other sites

Just got my Pro1 bacjk from repair.  Superb.  Not a ghost touch anywhere.  Immediately installed the update of AICP and aside from a rookie mistake and a hiccup in the connection to my computer for a moment, everything went smoothly.  I love this ROM!!! @tdmThank you!

Thank you also FxTec for the great repair.

  • Like 6
Link to post
Share on other sites
2 hours ago, internationaltraitor said:

any wod of an update to AICP R ?? :))

There have been rumblings of starting official release builds, so I'm guessing in the next couple weeks.

 

  • Thanks 7
Link to post
Share on other sites

I'm having an interesting bug with alarm/notification/ringtones on AICP. Few days after flashing AICP I got a notification from some app but didn't hear the sound. I checked the app notification  setting and realized that all the builtin notification sounds were missing. I went and downloaded a library of android notification tones from internet and transferred them to my phone, but now it told me that actually there's stock tones also available... I have set a new notification tone for every app and every alarm, but looks like it sometimes just forgets the tone/setting. I have set vibration on for my alarms, and luckily I usually wake up by the vibration sound only. But even if I manually set the alarm tone for a new alarm, it will forget to play the tone maybe tomorrow or day after tomorrow. And the same happens with app notifications, like Fb messenger.

  • Sad 3
Link to post
Share on other sites

Just installed AICP. Still exploring, but love the extra features so far. Thanks @tdm. Your work on LOS and AICP has made the pro1 experience amazing!

I found a potential bug.
Looks like I can customize some advanced navigation commands. (in other words, when you long press/double tap navigation buttons.) I tried it out and it works for the most part. But I don't seem to get split screen functionality to work. Starting split screen the normal way works fine though.

Navigation command for camera don't work either, but I uninstalled the normal camera in favor of gcam, so that might be on me. Would be nice to be able to have it work with non-defaults as well though.

  • Thanks 2
Link to post
Share on other sites
17 hours ago, Jonathan said:

Just installed AICP. Still exploring, but love the extra features so far. Thanks @tdm. Your work on LOS and AICP has made the pro1 experience amazing!

I found a potential bug.
Looks like I can customize some advanced navigation commands. (in other words, when you long press/double tap navigation buttons.) I tried it out and it works for the most part. But I don't seem to get split screen functionality to work. Starting split screen the normal way works fine though.

Navigation command for camera don't work either, but I uninstalled the normal camera in favor of gcam, so that might be on me. Would be nice to be able to have it work with non-defaults as well though.

Yeah split screen seems a bit buggy. I think R is far enough along that any bug reports should probably wait.

  • Like 1
  • Thanks 2
Link to post
Share on other sites

After it being much-recommended, I've just been setting up AICP Q on my Pro1. I am stuck on a few rather simple points:

- As someone else asked, keyboard backlight.

- Set the status bar clock to 24-hour time (at present it is 12-hour AM/PM). For the life of me I can find no setting for this. SOLVED - Disable Settings -> System -> Date & time -> Use locale default, then choose 24-hour format.

- Navigation bar customisation - to add menu button, and change behaviour (e.g. I want to disable home button when on home screen from popping up recent apps). Actually, this may be a Nova Launcher issue.

- Nice to have: customize status bar icons to be more compact, e.g. smaller font size of battery level, compact display of "LTE" status alongside signal level etc.

- A bug/misfeature: in landscape orientation, after double pull-down from status bar, it is impossible to access settings button at bottom-right, since entire quick buttons display is too tall for screen.

- In the Google assistant settings, under Voice Match, it is not possible to enable "always on" Hey Google recognition. Is this a known limitation, or am I doing it wrong?

Incidentally, after some effort, I was able to get Magisk working and have root with full Safetynet functionality - so Google Pay works. 😄 I had to do a lot of digging for this, happy to go back over my process and write it up if anyone is interested.

Thanks for any tips!

Edited by mbecroft
Add to post
  • Like 6
Link to post
Share on other sites
1 minute ago, mbecroft said:

Incidentally, after some effort, I was able to get Magisk working and have root with full Safetynet functionality - so Google Pay works. 😄 I had to do a lot of digging for this, happy to go back over my process and write it up if anyone is interested.

I got safetynet passing with magisk prop hide on LOS, but it didn't suffice AICP. So yes, please, share what you got.

  • Like 2
Link to post
Share on other sites
3 minutes ago, Jonathan said:

I got safetynet passing with magisk prop hide on LOS, but it didn't suffice AICP. So yes, please, share what you got.

OK - I've been setting up my phone for the last 6 hours and it's midnight here, so I'll have a crack at writing a guide for this tomorrow instead 🙂 Ultimately it was not difficult but required a few different steps that I only figured out by reading many forum posts and trial-and-error...

  • Like 4
Link to post
Share on other sites
1 hour ago, pebert said:

Whith the latest OTA upgrade I have a bug with HDMI out. When I connect the USB-C cable to my device it goes tottaly black if I unlock it. 

 

I can se the lock-screen, but when I entered my pin-code all is black until I remove the cable.

 

What is the date of the last working build?

 

Link to post
Share on other sites
On 2/28/2021 at 1:16 AM, Jonathan said:

Looks like I can customize some advanced navigation commands. (in other words, when you long press/double tap navigation buttons.) I tried it out and it works for the most part. But I don't seem to get split screen functionality to work. Starting split screen the normal way works fine though.

Hi Jonathan,

I've been looking for that type of customization (setting action for long press and double tap of each nav button), but I couldn't find it. Where in the menu tree are these settings?

Cheers -Mario

Link to post
Share on other sites
On 3/1/2021 at 12:10 AM, Jonathan said:

I got safetynet passing with magisk prop hide on LOS, but it didn't suffice AICP. So yes, please, share what you got.

I've just posted the root/Magisk process I used...I may have missed some details, but it's largely correct. Feel free to correct me in-thread if I've missed anything!

 

  • Like 1
  • Thanks 1
Link to post
Share on other sites
20 hours ago, mbecroft said:

Hi Jonathan,

I've been looking for that type of customization (setting action for long press and double tap of each nav button), but I couldn't find it. Where in the menu tree are these settings?

Cheers -Mario

The options for extra functionality for navigation can be found at:

Settings - AICP Extras - Navigation - On-screen naviation

  • Thanks 1
Link to post
Share on other sites
On 3/4/2021 at 1:37 AM, tdm said:

Oh my fault, I was thinking lineage. Did any previous aicp versions ever work properly with HDMI out?

Yes, it worked great, both with a simple USB-C to HDMI adapter and my Dell WD19 USB-C/Thunderbolt docking station, here I get both the 3 monitors and the USB-devices like mouse and keyboard. 

 

Now the monitor gets activated, detects a source, but both the monitor and the phone display stays black until I remove the USB cable again.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Terms