Jump to content
rejujacob

Discussion and testing on features and known&potential issues

Recommended Posts

2 minutes ago, auvo.salmi said:

Well, I downloaded the Netflix apk from apkmirror and it works. But of course it would be great if it'd work officially.

i'm sure it won't be very long until they push and update and google pay, netflix, hdmi, etc work perfect 🙂 they know of the issues

Share this post


Link to post
Share on other sites
1 hour ago, auvo.salmi said:

But didn't Erik just confirm that Pro1 has passed the Google certification? So it shouldn't be a problem anymore. But do you think that if I could find the Netflix apk from somewhere else, I should be able to install and also use it then? Haven't searched from alternate stores yet.

Yes, but it might take some time to for Google to handle this so it can be seen on the individual devices. But it IS on Google's public list as certified. See this

  • Thanks 1

Share this post


Link to post
Share on other sites
1 hour ago, EskeRahn said:

But it IS on Google's public list as certified. See this

Any way to get them to update the marketing name to Pro¹ ?  Not that it matters, but would look cooler in the play store device list.... I'm assuming that's the name that comes up when you install something from play store using pc and it asks which device...

  • Like 2

Share this post


Link to post
Share on other sites
1 minute ago, Craig said:

Any way to get them to update the marketing name to Pro¹ ?  Not that it matters, but would look cooler in the play store device list.... I'm assuming that's the name that comes up when you install something from play store using pc and it asks which device...

I wondered about that too, and have forwarded it to the staff, and hope they can get that detail fixed.

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

Do you have occasional incidents where hwkb stops working? It has happened to me two or three times, so not too often but still quite annoying. Reboot helps but is there anything else to do, to restore hwkb connection via OS and avoid reboot?

Share this post


Link to post
Share on other sites
On 12/4/2019 at 1:21 AM, auvo.salmi said:

Do you have occasional incidents where hwkb stops working? It has happened to me two or three times, so not too often but still quite annoying. Reboot helps but is there anything else to do, to restore hwkb connection via OS and avoid reboot?

Odd, It is at the least half a year ago I saw that (and hence on the pre-prod unit). So could it be some particular software I'm not using that triggers the bug? Can you see any pattern in when?

  • Like 2

Share this post


Link to post
Share on other sites
9 minutes ago, EskeRahn said:

Odd, It is at the least half a year ago I saw that (and hence on the pre/prod unit). So could it be some particular software I'm not using that triggers the bug? Can you see any pattern in when?

No I can't imagine a pattern. But at least it hasn't ever happened like, in the middle of typing a message or so. Every time it has been on that state when I unlock the phone and start typing. At least once it has occurred when I try to type in Whatsapp and at least once when trying to type in browser. And when it occurs, the hwkb stays inactive in any app I try to type in. I believe Fx button still works (brings me to home screen), but nothing else.

And it has happened both before and after firmware upgrade.

Edited by auvo.salmi
  • Like 1
  • Sad 1

Share this post


Link to post
Share on other sites
46 minutes ago, auvo.salmi said:

No I can't imagine a pattern. But at least it hasn't ever happened like, in the middle of typing a message or so. Every time it has been on that state when I unlock the phone and start typing. At least once it has occurred when I try to type in Whatsapp and at least once when trying to type in browser. And when it occurs, the hwkb stays inactive in any app I try to type in. I believe Fx button still works (brings me to home screen), but nothing else.

And it has happened both before and after firmware upgrade.

Do you use the software keyboard app that came on the phone or something different?

  • Like 1

Share this post


Link to post
Share on other sites
5 minutes ago, netman said:

Do you use the software keyboard app that came on the phone or something different?

 

The stock virtual keyboard, and FinQwerty app for Finnish layout with QWERTY hwkb (I ordered QWERTZ but got QWERTY, I'll got it changed when preorders have been fulfilled). First time this happened I guess I even tried to change the hwkb layout, but it didn't affect to the problem. And in case I wasn't accurate enough: The virtual keyboard still works when hwkb stops working.

  • Like 1

Share this post


Link to post
Share on other sites
Just now, auvo.salmi said:
 

The stock virtual keyboard, and FinQwerty app for Finnish layout with QWERTY hwkb (I ordered QWERTZ but got QWERTY, I'll got it changed when preorders have been fulfilled). First time this happened I guess I even tried to change the hwkb layout, but it didn't affect to the problem. And in case I wasn't accurate enough: The virtual keyboard still works when hwkb stops working.

I'm asking it because it's possible (although somewhat unlikely) that the IME somehow stops passing trough hardware keys (even with sw keyboard invisible), so maybe the info turns out usable later :). Does @EskeRahn use FinQwerty also?

  • Like 1

Share this post


Link to post
Share on other sites
1 minute ago, netman said:

I'm asking it because it's possible (although somewhat unlikely) that the IME somehow stops passing trough hardware keys (even with sw keyboard invisible), so maybe the info turns out usable later :). Does @EskeRahn use FinQwerty also?

Yes he does. Although with QWERTZ keyboard but this shouldn't make a difference, I believe.

  • Like 1

Share this post


Link to post
Share on other sites
27 minutes ago, auvo.salmi said:

Yes he does. Although with QWERTZ keyboard but this shouldn't make a difference, I believe.

Yup I use FinQWERTY, and use it in QWERTY variants on the Pre-production unit and the "Final sample", and the QWERTZ variant on my Retail unit. There have been no issues of that sort. (The only issues were that some earlier test-versions had some keys mapped a sub-optimal ways).

As far as I knows FinQWERTY only adds a keylayout file, it does not even alter the KeyCharacterMap level, nor the basic functionality of the keyboard.

  • Thanks 3

Share this post


Link to post
Share on other sites
9 hours ago, auvo.salmi said:

No I can't imagine a pattern. But at least it hasn't ever happened like, in the middle of typing a message or so. Every time it has been on that state when I unlock the phone and start typing. At least once it has occurred when I try to type in Whatsapp and at least once when trying to type in browser. And when it occurs, the hwkb stays inactive in any app I try to type in. I believe Fx button still works (brings me to home screen), but nothing else.

And it has happened both before and after firmware upgrade.

This has happened to me exactly once now.

It happened before the OTA and has not happened again, but I don't think the OTA has anything to do with it.

I am using Swiftkey for portrait mode, but it also interferes with hw keyboard settings. Maybe it has something to do with it, but I don't think so.

  • Like 1
  • Thanks 2

Share this post


Link to post
Share on other sites
4 hours ago, d said:

I am using Swiftkey for portrait mode, but it also interferes with hw keyboard settings. Maybe it has something to do with it, but I don't think so.

It also happening with swiftkey pretty much rules out keyboard app being at fault I guess :).

  • Like 1

Share this post


Link to post
Share on other sites
32 minutes ago, abielins said:

Could anyone test the Lawnchair launcher? https://play.google.com/store/apps/details?id=ch.deletescape.lawnchair.plah&hl=en_US

With my Bluetooth keyboard arrow keys, pressing up or down crashes it 😞

It works fine with the arrow keys (better than most, including widgets). The icon grid is the same in landscape and portrait, so it is squeezed in one direction and/or stretched in the other. (Most launchers has this bug). Both app drawer and desktop. There seems to be no way to access the app drawer by keyboard.

  • Thanks 1

Share this post


Link to post
Share on other sites

I'm having the hwkb problem again, right now. Is there anything I could do for testing?

Also, just tried screen mirroring via usb to hdmi. Not sure if bug or feature, but media volume jumps to maximum and stays there (sound output via hdmi, don't know if this could be switched to device speakers simultaneously. Not a big problem since most displays/tv's with speakers also have volume adjust, but anyway.

  • Sad 1

Share this post


Link to post
Share on other sites
5 minutes ago, auvo.salmi said:

I'm having the hwkb problem again, right now. Is there anything I could do for testing?

Also, just tried screen mirroring via usb to hdmi. Not sure if bug or feature, but media volume jumps to maximum and stays there (sound output via hdmi, don't know if this could be switched to device speakers simultaneously. Not a big problem since most displays/tv's with speakers also have volume adjust, but anyway.

Does caps lock change? Can you exit stuff with Esc, or only the Logo-ley?

...And there are some issues around speaker/microphone volume. Handsfree calls are not perfect....

Share this post


Link to post
Share on other sites
9 minutes ago, auvo.salmi said:

I'm having the hwkb problem again, right now. Is there anything I could do for testing?

Also, just tried screen mirroring via usb to hdmi. Not sure if bug or feature, but media volume jumps to maximum and stays there (sound output via hdmi, don't know if this could be switched to device speakers simultaneously. Not a big problem since most displays/tv's with speakers also have volume adjust, but anyway.

Try to install Logcat from Play Store and check the logs when you have issues. Logcat via ADB would be even better for next time

https://play.google.com/store/apps/details?id=com.nolanlawson.logcat

https://www.xda-developers.com/guide-sending-a-logcat-to-help-debug-your-favorite-app/amp/

  • Thanks 1

Share this post


Link to post
Share on other sites
18 minutes ago, EskeRahn said:

Does caps lock change? Can you exit stuff with Esc, or only the Logo-ley?

...And there are some issues around speaker/microphone volume. Handsfree calls are not perfect....

Nope, only logo key works. Caps lock led doesn't. Led backlight still works though, but doubt that means anything.

11 minutes ago, FlyingAntero said:

Try to install Logcat from Play Store and check the logs when you have issues. Logcat via ADB would be even better for next time

https://play.google.com/store/apps/details?id=com.nolanlawson.logcat

https://www.xda-developers.com/guide-sending-a-logcat-to-help-debug-your-favorite-app/amp/

Thanks, installed. Not too familiar with the adb stuff (could have used it years ago when was my previous experience with android), and I feel quite helpless doing debugging on android, compared to a linux system for example. 

In my case this won't be a big problem as I'll get my device replaced anyway, but if many people is experiencing this, it would be a bad thing for the company. And now I have had this error like two days in a row. Too early to make conclusions, but it already feels like it is getting more frequent. Hope it's not the case 😞

  • Thanks 2

Share this post


Link to post
Share on other sites
5 minutes ago, auvo.salmi said:

Thanks, installed. Not too familiar with the adb stuff (could have used it years ago when was my previous experience with android), and I feel quite helpless doing debugging on android, compared to a linux system for example. 

In my case this won't be a big problem as I'll get my device replaced anyway, but if many people is experiencing this, it would be a bad thing for the company. And now I have had this error like two days in a row. Too early to make conclusions, but it already feels like it is getting more frequent. Hope it's not the case 😞

Try to get screenshot of the logs right after you notice an issue. Maybe that will help devs to figure it out.

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites
1 hour ago, EskeRahn said:

It works fine with the arrow keys (better than most, including widgets). The icon grid is the same in landscape and portrait, so it is squeezed in one direction and/or stretched in the other. (Most launchers has this bug). Both app drawer and desktop. There seems to be no way to access the app drawer by keyboard.

Thank you for the testing! Since it's open source I may hack it to add those features and improve it.

  • Thanks 2

Share this post


Link to post
Share on other sites
32 minutes ago, abielins said:

Thank you for the testing! Since it's open source I may hack it to add those features and improve it.

That would be nice. The clever idea of two blocks of icons placed next to or above each other used by the build in launcher might be worth copying for a(ny) device with a elongated 2:1 or similar display.....

  • Like 1

Share this post


Link to post
Share on other sites

Thank you all for the feedback! Team is working on the fix for the keyboard unresponsive issue. It's quite random and cannot replicate easily. But we will do out best and solve ASAP.

  • Like 3
  • Thanks 6

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Terms