Jump to content

How to install AICP (or other ROM), Magisk, and root with SafetyNet, Certified Device & Google Pay working

Recommended Posts

I just recently installed AICP on my Pro1 and, in another thread, I was asked how I went about getting root and Safetynet working, including Google Pay working. It was pretty straight-forward really, but I had to dig around a bit to figure it out. Here are the exact steps, as best I recollect them. This may not be the best or only way, but it worked for me. And thanks to a number of developers/contributors and forum posts which I consulted while figuring out this process.

- Wipe phone, fastboot flash Lineage recovery, then adb sideload AICP and NikGapps ZIPs. Checked phone boots into Android no problem.

- Install the Magisk app (apk) latest version 22.0.

- (In Magisk app, "Check SafetyNet" fails for ctsProfile at this point.)

- Go to Magisk github (https://github.com/topjohnwu/Magisk/releases) -> Releases, and download Magisk-v21.4.zip . The last version that is available as a zip.

- Reboot to recovery, adb sideload Magisk-v21.4.zip. Reboot back to Android. (Do not instead try to install from the app. It does not work.)

- In Magisk app, now use the option to install/update to version 22.

- In Magisk app, Install MagiskHide Props Config module. Now use it to spoof fingerprint:

- Reboot, open terminal or adb shell, become root (type su) then type props: follow the directions, option 1, f, then find Fxtec and The Pro1 in the list. Follow the instructions and exit. Reboot.

- Turn on airplane mode

- Clear Google Play and Google Play services data+cache. Reboot. Check that Play store Settings, scroll to bottom, "Play Protect Certification" should now read "Device is certified."

- (You now have root, SafetyNet passes, and App Store sees certified device - all good!)

- If you do not need Google Pay, or if you clear cache and data of Google App and/or Google Pay and it works, you can stop here. Otherwise continue for Google Pay-specific fix...

- In Magisk settings, turn on MagiskHide

- Install Magisk modules: Busybox for Android NDK; SQLite for ARM aarch64 devices (available here: https://forum.xda-developers.com/t/working-magisk-with-google-pay-as-of-gms-17-1-22-on-pie.3929950/page-9#post-79643248).

- I *think* the process was to clear cache+data, then run Google Pay, then exit and continue with the next step. I think a reboot may be needed here as well.

- Finally, install module: GPay SQLite Fix (from same URL above).

- You should now be able to add cards to Google Pay, without the message "your device has been altered...". After adding card, reboot. This is necessary for the GPay fix to work. UPDATE - although the forum post I was working from stated this step was necessary, everything worked fine for me without rebooting after adding a card.

I may have missed something in the above - everyone please feel free to add to/correct me on any of this! The key thing was flashing Magisk 21.4 ZIP first, then updating it from the Magisk app. Root works really well, and you can selectively hide Magisk from certain apps and so on, it is really flexible and seems to work perfectly in every way.

I am not sure what happens if you now alter the system partition - for instance to change the keymap files. I haven't tried this yet, but I hope with Magisk set up as above, it will not be a problem - will find out soon...



Edited by mbecroft
add new info
  • Like 2
  • Thanks 10
Link to post
Share on other sites
  • 3 weeks later...

This didn't quite work for me. I've had my Pro 1 on the stock firmware up until today, where I installed LineageOS 18.1 20210401.

I followed this guide, did the magisk hideprops config, and cleared the google play settings, but afterwards the safetynet would still not pass (even in magisk's own check).

I googled a bit, and installed https://github.com/kdrag0n/safetynet-fix (downloaded + installed via magisk), then hid magisk and did the clear data/cache/reboot dance again, and afterwards safetynet passes.

I also installed Google Pay and was able to set up NFC and everything seems to work fine (I didn't need the fix).

  • Like 1
  • Thanks 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information