Jump to content

Recommended Posts

Hello,

 

I got video playback working by creating a file:  /etc/gst-droid/gstdroidcodec.conf

 

with the following content (as mentioned as a quirk for the old Pro1x):


[decoders]
video/hevc=1

[decoder-quirks]
video/mp4v-es=use-codec-supplied-height;use-codec-supplied-width
video/avc=use-codec-supplied-height;use-codec-supplied-width

 

The directory does not exist. You must create it before creating the file. After creating the file, I ran as root dconf update , deleted /home/defaultuser/.cache/gstreamer-1.0/registry.aarch64.bin and rebooted the device.

After rebooting, the LLsvPlayer plays videos fluently but if the Browser is going to play an embedded video, it still crashes.

Can anybody confirm this?

If not, please try also to repair the broken codec links in /etc:

lrwxrwxrwx    1 root     root            35 Sep  2 14:05 /etc/audio_platform_info.xml -> /system/etc/audio_platform_info.xml
lrwxrwxrwx    1 root     root            36 Sep  7 18:35 /etc/media_codecs.xml -> /android/vendor/etc/media_codecs.xml
lrwxrwxrwx    1 root     root            35 Sep  2 14:05 /etc/media_codecs_ffmpeg.xml -> /system/etc/media_codecs_ffmpeg.xml
lrwxrwxrwx    1 root     root            49 Sep  7 18:37 /etc/media_codecs_google_audio.xml -> /android/vendor/etc/media_codecs_google_audio.xml
lrwxrwxrwx    1 root     root            46 Sep  7 18:37 /etc/media_codecs_google_c2.xml -> /android/vendor/etc/media_codecs_google_c2.xml
lrwxrwxrwx    1 root     root            52 Sep  7 18:37 /etc/media_codecs_google_c2_audio.xml -> /android/vendor/etc/media_codecs_google_c2_audio.xml
lrwxrwxrwx    1 root     root            52 Sep  7 18:37 /etc/media_codecs_google_c2_video.xml -> /android/vendor/etc/media_codecs_google_c2_video.xml
lrwxrwxrwx    1 root     root            53 Sep  7 18:37 /etc/media_codecs_google_telephony.xml -> /android/vendor/etc/media_codecs_google_telephony.xml
lrwxrwxrwx    1 root     root            49 Sep  7 18:37 /etc/media_codecs_google_video.xml -> /android/vendor/etc/media_codecs_google_video.xml
lrwxrwxrwx    1 root     root            52 Sep  7 18:37 /etc/media_codecs_google_video_le.xml -> /android/vendor/etc/media_codecs_google_video_le.xml
lrwxrwxrwx    1 root     root            48 Sep  7 18:37 /etc/media_codecs_performance.xml -> /android/vendor/etc/media_codecs_performance.xml
lrwxrwxrwx    1 root     root            38 Sep  7 18:36 /etc/media_profiles.xml -> /android/vendor/etc/media_profiles.xml
lrwxrwxrwx    1 root     root            35 Sep  7 18:38 /etc/mixer_paths.xml -> /android/vendor/etc/mixer_paths.xml

This step is probably senseless but that is what I tried first and didn't solve the problem. But maybe, it is also required; I don't know.

  • Like 1
  • Thanks 1
Link to post
Share on other sites
  • Replies 81
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Following @esialb's thread on Ubuntu Touch, here's one showing that SailfishOS works too: ——— Instructions: - First and foremost, backup your "persist" partition

LXC containers work (with Xsession, but the setup is not as user friendly as it was on Pro1 in 2020😞 Still no luck with Waydroid despite my attempts, but theoretically this shou

Adam helped me to get Waydroid to work!   And shadow.tech works in Waydroid (no sound nor keyboard, though, so it's somewhat limited):   See how

Posted Images

Thanks for trying it @GoaSkin! I remember that I wanted to try it myself some weeks ago as I did on the Pro1 back in the time with that small PR, but got sidetracked to other time sinks and then simply forgot because I don't play much video outside of my LXC container. Great to hear that it (kinda) works. 

Edited by matf-kabouik
Link to post
Share on other sites

Hi All,

First time poster here, apologies if this is the wrong thread.

I've flashed sailfish to my pro 1-x with the instructions from this first post (I originally flashed from stock android to ubuntu touch and now to sailfish) and it works really well!

I've got a couple of problems though, I was hoping you guys could help with. I can't rsync to my sd card over WLAN (ssh works fine though) from my laptop and I also tried to install nano via the command line with "devel-su pkcon install nano" but it keeps failing (don't have the phone with me to tell you the actual error message) but I'll edit the post later with the actual error message. There's only approx 10GB space in the userdata folder (this is fine if I could get my sd card working) and I have the blue 8GB/256GB model

Any help is greatly appreciated and I'm loving sailfish!

Edit: I feel stupid.... Nano and rsync can be installed by typing "devel-su" then press return (i.e. become root), then type pkcon install nano or whatever package you want, apologies for the ill thought out post above. Still loving sailfish though....

Edited by ethelfrith
update post
Link to post
Share on other sites

What I found out so far now by evaluating:

- any app which crashed before when starting a video still does crash. This includes the sailfish-browser and the ytplayer

- any apps which were able to start a video before but performed a software rendering with only one frame each 2-3 seconds now run fluently. This includes the LLS vplayer and any Android video app running in Waydroid.

 

Regarding the crashing apps, I made some experiments a few weeks before with enviroment variables forcing the apps to use different renderers. And the result was that they showed the behavior like the LLS vplayer before (one frame each few seconds).

May be the right enviroment variable in combination with the gstdroidcodec.conf  is the solution. But I forgot which enviroment variable I set and it is too long ago to find it in my bash history.

 

 

  • Like 1
Link to post
Share on other sites
  • 2 weeks later...

The installation procedure of SFOS creates a filesystem that matches the size of the 128GB version of the Pro1X.

With a few quirks after the installation, it is possible to expand the filesystem if you have the 256GB version. For this, open a shell, become root and execute the following command:

resize2fs /dev/sda13

Because the partition already ends at the last sector of the disk and just the filesystem does not use the full partition size, it is easy to change this even on a running system.

The size of the user home folders still remain at 80GB and I don't recommend to change the size of /home.img or avoid the image to be mounted at /home because the configuration of the home folder encryption is part of a software package and any changes on it may get overwritten during system updates.

  • Like 1
  • Thanks 2
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Terms