Jump to content

agent008

Members
  • Content Count

    221
  • Joined

  • Last visited

  • Days Won

    3

Everything posted by agent008

  1. I second that, I've been corresponding with tech support in order to see if my Pro1's no-keyboard and no-touch issue can be solved, and the rep at support has been quick to reply and also stated they have the USB board and display on stock.
  2. Whoa, then it has finally started! Around what number is your contribution? Mine is in the 2100's.
  3. Hi, I'm curious, does the Fold work well for those who like to type a lot? Does it have a "keyboard" function that could emulate the Pro1?
  4. Hi, how can I help with this? Even though I believe my case is different (no touch at all, touch driver absent from i2c bus, whereas the problem here is insensitive touch margins). Last thing I attempted was flashing an older Lineage version (17.1) and running the display firmware upload APK. The apk never was able to update the display always complaining that firmware update wasn't supported.
  5. Perfect, I figured this one would be conductive and left it there. I just didn't remove the black film "backing" from the old screen to put it on the new one.
  6. You mean the silver "mail" or "fabric" type tape. Correct? I kept all the pieces that were there, in their original places.
  7. I wish. I wonder what the black backing stickers do? Are they related to touch detection on the screen? Last year when I replaced my screen for the first time I didn't reuse the old black sticker from the original screen, and it worked fine.
  8. Thanks! I had just found this very same post.
  9. I've taken a photo of the chipset inside my first replacement screen which worked fine for a year until I broke its glass. It's not very legible on the photo but it's a GT9286.
  10. I've also asked to switch my option to Android in order to avoid further delays. Got confirmation after a few minutes.
  11. So where can I find the screen fix APK? Thanks
  12. Hi! At this point I would be willing to try this. Since not even my old screen (glass broken, touch perfect) worked with touch anymore, I'm not very hopeful it might fix but, why not try? I would flash an older LineageOS and try to run this APK. At the moment the only way I can interact with my Pro1 is by connecting a USB-C hub to it with a mouse and keyboard plugged in. Or with a bluetooth keyboard but in order to pair the phone and the keyboard I still had to plug a mouse into the phone. No phone keyboard and no touchscreen for me. Pretty bummed and had to resort back to a Moto Z2 Play
  13. Here's an idea. My phone was delivered on August 5th 2020. So, not yet 2 full years from purchase. Do you believe I could have it fixed on warranty terms? Thanks EDIT: I also have a Pro1x on order. Maybe that will ship sooner rather than later now. Hehe
  14. About a couple weeks ago. It didn't work, I rebooted, it started working again. Then later on the same day it died permanently. I hadn't been using it during the last couple months prior to the first symptom a couple weeks ago. Always my fingernails or a plastic cellphone pry tool. I can try looking at the whole motherboard assembly and the screen connectors with a magnifying glass. But only will be able to do so during the weekend. But this wouldn't explain the keyboard failing by itself prior to the screen replacement.
  15. It worked out of the box for me. Boot to Lineage or AICP recovery, choos apply update via ADB, then on the host PC: 'adb sideload Magisk-v24.3.apk' Good to know it worked for you. One important comment is that if you are coming from a fresh ROM install, you should flash your ROM via sideload, then flash MindtheGapps or OpenGapps, then reboot to system. After you get to the Android screen, reboot to recovery again and then sideload Magisk. I'm not sure if the reboot to full Android screen is needed, or just a reboot back to recovery is enough. So I always reboot to system first.
  16. The fingerprint sensor works. I have been using the phone with a USB -C hub with a mouse connected to it, that is how I can navigate the system and how I was able to install Termux and run i2cdetect. Every time after flashing I use the mouse to pair a bluetooth keyboard+touchpad, it's fun to use an Android device without touch, haha. 😪 Apart from the fingerprint, I have devices 0x08 (microphone?) and 0x09 (unknown device?) on bus 7, and on bus 6 I have 0x28 (NFC). I spent 2½ days troubleshooting this and now don't have much time to look further into it until the weekend. If I ha
  17. I checked the connectors and flat cables. They all seem fine. Both display connectors & flat cable, and the keyboard connector & flat cable. I checked i2c bus 6, and I also do not have the keyboard present ("--" on row 0x50, column 8). So that is why my keyboard is not working either...
  18. @VaZso : bingo! I don't have any drivers using address 0x14 (just "--" instead of "UU" on row 0x10, column 4). So I'm now suspecting a hardware issue, either flat cable misconnected or something else. Did I understand this right? Any other testes I could carry out to confirm there is nothing at address 0x14? Thanks
  19. Okay, before opening the phone again to check the screen connector etc I'll flash Lineage or AICP and Magisk for root then I'll run i2cdetect and report back here. Tks
  20. Thanks. Yes, I did. In fact the phone is on right now in hopes the OTA might come yet. haha If I remember correctly, last time it took an OTA to solve the screen too. However, I will reopen the phone this evening and recheck all connections. Maybe something is not right in there. I also can try the old screen and a third new one I have still on the box. Thanks for everyone's inputs!
  21. Thanks. With my Samsung laptop, it doesn't work. Or it might be my Pro1's already a bit worn out USB port? The saga continues...
  22. I used two different ports from my laptop, will try a third one. Thanks
  23. I see. I might try an older stock then, if OTA is still up i might be lucky. I only found older stock firmware at @tdms link but they are EDL files and his Linux tool didn't work for me. I'll try the windows tool. EDIT: or if anybody has the older fastboot image I'll be thankful if you share it with me. Fastboot works well with my Linux box.
  24. I flashed the 20200825 fastboot firmware from the Back to Stock guide thread: https://community.fxtec.com/topic/2466-guide-restore-to-stock-firmware-using-fastboot-method/?do=findComment&comment=33838
×
×
  • Create New...

Important Information

Terms