Jump to content

LineageOS 18.1 Official Release for Pro1


Recommended Posts

8 hours ago, EskeRahn said:

There might be something rotten in the new version, it eats battery at an alarming rate while idle.

Although I have problems with charging (as having a faulty USB connector) and today it was only charged to around 80%, I haven't noticed any additional battery drain so far.

However, I use it daily using two SIM cards, so it may happen I would not notice a relatively small aditional battery drain... (I mean small compared to aditional power consumption of two online SIMs).

So that does not mean it would be unnecessary to investigate its background, simply it may don't have huge impact on a daily driver I think...

  • Like 1
Link to post
Share on other sites
  • Replies 525
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

So, just one last update on that slightly off-topic discussion from few weeks ago: Following @Sean McCreary's suggestions, I was indeed able to build an up-to-date (unofficial) LOS 16.0. It

As much as I enjoy the fact that LineageOS on the Pro1 seems to be alive and well, I am puzzled by the practice of removing previous major releases from the build systems as soon as a new version is m

No, it defeats one purpose of using lineage.  Having up-to-date security patches, a more stable version  of Android, having just the Gapps you prefer and not all installed as system apps are also reas

Posted Images

On 3/16/2022 at 11:41 AM, EskeRahn said:

There might be something rotten in the new version, it eats battery at an alarming rate while idle.

What ever it was, it fixed it self about 3d after install.... See this collage of roughly 2x5 days stitched together. (So must have been an app-issue, or net glitch after all)

Screenshot_20220320-081710_3C_All-in-One_Toolbox.png

Note the slope of the two added green lines. 10 percent point a day idle consummation is not bad. :)

  • Thanks 2
Link to post
Share on other sites

By the way, regarding my several charging problems, new observations substantiate a suspicion that those cases in which my phone simply drops to 'discharging' and stays there are now caused by the USB socket slowly becoming unreliable, even though I've been using magnetic adapters all the time...

  • Sad 1
Link to post
Share on other sites
6 minutes ago, Rob. S. said:

By the way, regarding my several charging problems, new observations substantiate a suspicion that those cases in which my phone simply drops to 'discharging' and stays there are now caused by the USB socket slowly becoming unreliable, even though I've been using magnetic adapters all the time...

Using magnetic adapters my self, you might try to take a magnifying glass and see if some ferromagnetic dirt might have crept in, in either side. Normal dust from the garden soil can contain enough iron to cause issues, and can be quite hard to brush or blow away.

  • Thanks 1
Link to post
Share on other sites
2 hours ago, Rob. S. said:

By the way, regarding my several charging problems, new observations substantiate a suspicion that those cases in which my phone simply drops to 'discharging' and stays there are now caused by the USB socket slowly becoming unreliable, even though I've been using magnetic adapters all the time...

This kind of charging problem exists for me since several months but I have noticed its cause is my worn USB connector.

I did not use magnetic connector but I have found last year that only one direction works reliable for me... closer to the end of last year, I had problems with both directions...

I have started to use a magnetic end but it did not look to be reliable from start because of my worn connector, so I have started to twist in one or other direction to have a mostly reliable charging... now I have reached a state where I starting to switch magnetic and normal cable as none of them are reliable but twisting is necessary to get even to do something.

Now I am even happy if it starts charging using "quick charge" which I don't like as it may potentially degrades my battery but it may reach a state where it charges (it may not even called quick charge speed but sometimes does)...

Also, sometimes it starts cycling between charging, fast charge, not charging... and it can drop charging after a while or simply has LED indication but no charging...
(It is very frustrating looking at my phone at morning and it only has 20% left despite of "charging" as it has stopped minutes after connecting...)

That is a hardware failure for me...

I have tried to search for the actual USB connector of Pro1 (based on photos of the board) but I haven't found this kind of connector yet - if I can see the connector well in the photo, it does not seem to be a very common one and I don't even know if it also has connectors underneath...

I have a potentially similar connector anyway but in the photo, Pro1's connector looks to have a different connection arrangement which I have found unusual...
So if I could find the right connector, I may have tried to replace it on my board but not even F(x)tec told me what is its part number or better, where I may obtain it...

  • Thanks 2
Link to post
Share on other sites

@EskeRahn I tried pressurized air, but to no avail... Both the USB socket and the magnet adapter seem clean...

@VaZso Sounds very similar to how my issue developed over the last few months. Mine is still in the state that charging is mostly reliable (although sometimes varying in current...) once it has started, as long as I don't touch the phone... 

I wonder whether the Pro1X might still have the same connector board, which would increase the dim chance to ever get such a thing from Fxtec as a spare part... My soldering skills wouldn't be up to the task of replacing the connector on the board myself even if the exact part could be sourced.

My best hope for now seems to be that at least one of the the two ordered Pro1X phones arrives before my Pro1 dies from USB socket failure. And with the spare parts situation being what it has been, I'll probably keep the second one as a backup for fear something might happen to the first one, instead of selling it as a relief to my bank account...

  • Thanks 1
Link to post
Share on other sites
8 minutes ago, Rob. S. said:

I wonder whether the Pro1X might still have the same connector board, which would increase the dim chance to ever get such a thing from Fxtec as a spare part... My soldering skills wouldn't be up to the task of replacing the connector on the board myself even if the exact part could be sourced.

That board will be definitively somewhat different as they wrote in one of their update that they had to modify it because of some radio/reception problems...

However, I don't know how it affects Pro1.
Generally, I would think the new board may have the very same fixing and conection, but it would be good to know what was the problem with original board and how it may work (better or worse) if it was installed in Pro1.

For example, it may have a charging controller which has some noise what causes problems at some bands of the SDM662-related board... but we know nothing about it.

However, they told me they are waiting for such additional boards together with Pro1X manufacturing, so they will have replacement (service) boards then...

  • Thanks 1
Link to post
Share on other sites

(lineage-18.1-20220321-nightly-pro1-signed.zip on March 5 security patch installed smoothly using OTA )

...But the reintroduced (early August 2021) Accessibility / keyboard bug is not (yet?) fixed.

The stage after download and install called "Finalising package installation" is surprising slow though)

  • Thanks 1
Link to post
Share on other sites

(lineage-18.1-20220328-nightly-pro1-signed.zip on March 5 security patch installed smoothly using OTA )

...But the reintroduced (early August 2021) Accessibility / keyboard bug is not (yet?) fixed.

The stage after download and install called "Finalising package installation" is surprising slow though)

  • Thanks 1
Link to post
Share on other sites
On 3/28/2022 at 11:24 PM, EskeRahn said:

The stage after download and install called "Finalising package installation" is surprising slow though)

Anyway, the first few times you mentioned this slow process I have not really noticed what you are speaking about.
...but the last few times it became really slow also for me which is the speed you are mentioning I think.

As it works in the background, I don't really care but I think it is not really a bug but something related to the OS usage, user data, installed apps or anything related I think.

  • Like 1
Link to post
Share on other sites
9 hours ago, VaZso said:

Anyway, the first few times you mentioned this slow process I have not really noticed what you are speaking about.
...but the last few times it became really slow also for me which is the speed you are mentioning I think.

As it works in the background, I don't really care but I think it is not really a bug but something related to the OS usage, user data, installed apps or anything related I think.

Yes, but oddly it is much slower than when doing it as flashing, even if you make sure the screen stays on.

Link to post
Share on other sites
4 hours ago, EskeRahn said:

Yes, but oddly it is much slower than when doing it as flashing, even if you make sure the screen stays on.

Do you mean sideloading?

Link to post
Share on other sites

(lineage-18.1-20220404-nightly-pro1-signed.zip on March 5 security patch installed smoothly using OTA )

...But the reintroduced (early August 2021) Accessibility / keyboard bug is not (yet?) fixed.

The stage after download and install called "Finalising package installation" is surprising slow though)

  • Thanks 1
Link to post
Share on other sites
  • 2 weeks later...

(lineage-18.1-20220411-nightly-pro1-signed.zip on March 5 security patch installed smoothly using OTA )

...But the reintroduced (early August 2021) Accessibility / keyboard bug is not (yet?) fixed.

The stage after download and install called "Finalising package installation" is surprising slow though)

  • Thanks 1
Link to post
Share on other sites

(lineage-18.1-20220418-nightly-pro1-signed.zip on April 5 security patch installed smoothly using OTA )

...But the reintroduced (early August 2021) Accessibility / keyboard bug is not (yet?) fixed.

The stage after download and install called "Finalising package installation" is surprising slow though)

  • Thanks 1
Link to post
Share on other sites

(lineage-18.1-20220425-nightly-pro1-signed.zip on April 5 security patch installed smoothly using OTA )

...But the reintroduced (early August 2021) Accessibility / keyboard bug is not (yet?) fixed.

The stage after download and install called "Finalising package installation" is surprising slow though)

  • Thanks 1
Link to post
Share on other sites
  • 1 month later...

Note that they have now purged the oldest of the four releases with 18.1, so expect them all to be gone within weeks. So IF you are interested in 18.1, then make sure to pull a copy ASAP....

(They did the same with 17 after 18 was released)

  • Thanks 3
Link to post
Share on other sites
  • 2 weeks later...
On 6/7/2022 at 10:22 AM, EskeRahn said:

Note that they have now purged the oldest of the four releases with 18.1, so expect them all to be gone within weeks. So IF you are interested in 18.1, then make sure to pull a copy ASAP....

(They did the same with 17 after 18 was released)

Last chance.... One left, that is likely to be gone in a day or two....

  • Like 1
Link to post
Share on other sites

I have this one installed nor for a few days but I don't know if it's possible to recover the .zip file in the system. Or maybe via adb ?

Link to post
Share on other sites
1 hour ago, raymo said:

I have this one installed nor for a few days but I don't know if it's possible to recover the .zip file in the system. Or maybe via adb ?

I have sent him an own link for download.

  • Like 1
  • Thanks 1
Link to post
Share on other sites
  • 4 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Terms