Jump to content

Pro1x with SailfishOS


Recommended Posts

  • Replies 124
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Following @esialb's thread on Ubuntu Touch, here's one showing that SailfishOS works too: ——— Instructions: - First and foremost, backup your "persist" partition

Adam helped me to get Waydroid to work!   And shadow.tech works in Waydroid (no sound nor keyboard, though, so it's somewhat limited):   See how

Okay!  Got Debian Sid up and running in lxc, by fumbling my way through @matf's guide.  It works!  😄 

Posted Images

Thanks for trying it @GoaSkin! I remember that I wanted to try it myself some weeks ago as I did on the Pro1 back in the time with that small PR, but got sidetracked to other time sinks and then simply forgot because I don't play much video outside of my LXC container. Great to hear that it (kinda) works. 

Edited by matf-kabouik
Link to post
Share on other sites

Hi All,

First time poster here, apologies if this is the wrong thread.

I've flashed sailfish to my pro 1-x with the instructions from this first post (I originally flashed from stock android to ubuntu touch and now to sailfish) and it works really well!

I've got a couple of problems though, I was hoping you guys could help with. I can't rsync to my sd card over WLAN (ssh works fine though) from my laptop and I also tried to install nano via the command line with "devel-su pkcon install nano" but it keeps failing (don't have the phone with me to tell you the actual error message) but I'll edit the post later with the actual error message. There's only approx 10GB space in the userdata folder (this is fine if I could get my sd card working) and I have the blue 8GB/256GB model

Any help is greatly appreciated and I'm loving sailfish!

Edit: I feel stupid.... Nano and rsync can be installed by typing "devel-su" then press return (i.e. become root), then type pkcon install nano or whatever package you want, apologies for the ill thought out post above. Still loving sailfish though....

Edited by ethelfrith
update post
Link to post
Share on other sites

What I found out so far now by evaluating:

- any app which crashed before when starting a video still does crash. This includes the sailfish-browser and the ytplayer

- any apps which were able to start a video before but performed a software rendering with only one frame each 2-3 seconds now run fluently. This includes the LLS vplayer and any Android video app running in Waydroid.

 

Regarding the crashing apps, I made some experiments a few weeks before with enviroment variables forcing the apps to use different renderers. And the result was that they showed the behavior like the LLS vplayer before (one frame each few seconds).

May be the right enviroment variable in combination with the gstdroidcodec.conf  is the solution. But I forgot which enviroment variable I set and it is too long ago to find it in my bash history.

 

 

  • Like 1
Link to post
Share on other sites
  • 2 weeks later...

The installation procedure of SFOS creates a filesystem that matches the size of the 128GB version of the Pro1X.

With a few quirks after the installation, it is possible to expand the filesystem if you have the 256GB version. For this, open a shell, become root and execute the following command:

resize2fs /dev/sda13

Because the partition already ends at the last sector of the disk and just the filesystem does not use the full partition size, it is easy to change this even on a running system.

The size of the user home folders still remain at 80GB and I don't recommend to change the size of /home.img or avoid the image to be mounted at /home because the configuration of the home folder encryption is part of a software package and any changes on it may get overwritten during system updates.

  • Like 2
  • Thanks 2
Link to post
Share on other sites
  • 1 month later...

Hi @GoaSkin,

Did you have any more luck changing the size of the home folders? I have been wanting to sort out this before I start using this phone. I asked on discord and @piggzshared some thoughts:

For the partition size, you could try the following
Boot into recovery
adb shell
mount userdata
delete the file etc/sailfish-device-encryption-community/config.ini
edit the file etc/sailfish-device-encryption-community/devices.ini and change the size as required
delete home.img
reboot

However, I have been able to get into adb shell. My device is 'unauthorised'. To this, Piggz suggested:

flash the userdebug recovery from the 2.7.3 build

But I am not sure what this means, so I haven't managed. I was hoping somebody had had success in moderating the size of the root partition to 10G and making the other 200+G into home storage?

Any advice? Thanks so much,

Justin.

Link to post
Share on other sites
  • 3 weeks later...

Hi All,

So I have finally made some time to expand the /home storage on my Pro1X. Piggz gave me the instructions on discord some weeks ago (and echoed here a few posts above), but they were suitably vague. I will share what I did, though it may or may not be wise to do the same. I bumbled my way through, not carefully considered my way through.

EDIT: I should have noted that this will delete all your /home, so back up anything of importance.

  1. On the SFOS install i ran as devel-su "resize2fs /dev/sda13" as per @GoaSkin instructions here.
  2. I had to replace the stock recovery with the ubtouch recovery in order to get adb working. Not sure if this is a problem with my device or a wider problem. Note that Piggz suggested to "flash the userdebug recovery from the 2.7.3 build". I couldn't work out what that meant. So instead flashed the ubtouch recovery.img. That allowed me to use adb as per Piggz instruction. Note well, that I tried to flash back the stock recovery, but I have not been able to. There is an error of some description. So it seems it is probably unwise to do as I have done here. I downloaded the Ubtouch recovery.img from here. And flashed using parts of the instruction here.
  3. Then entering recovery mode on the Pro1X I could enter ADB shell.
  4. I then mounted userdata as suggested with "mount -o rw /dev/block/sda13 /data"
  5. I could then delete conifg.ini
  6. I could edit devices.ini with "busybox vi devices.ini". Piggz has the default size set at 80000. I altered this to 202000, but think you could safely select up to 204800.
  7. I then managed to delete home.img
  8. Finally a reboot.

This has left me with user data storage of 191GB and still a very large amount of space for system data.

Happy to provide further info if anyone else needs its?

Apparently resizing the home.img in this way is ok. Though not necessarily the way I have done it or the size.

 

Edited by Justin
  • Like 1
  • Thanks 3
Link to post
Share on other sites

I just expanded the size of the root partition without modifying the size of home.img because I had the situation that there wasn't anymore space left on the root partition but only around 20% of the capacity of the home folder was used.

Most software packages are deploying their files into the generic linux folders instead of the users home directory and if the diskspace of /dev/sda13 is almost used for a big home.img, this is a problem.

  • Thanks 1
Link to post
Share on other sites

Any suggestions on where to start troubleshooting a networking issue where the Jolla store will load and install apps and some apps will load data but it is limited. For example, the built in weather app appears to update when I look for a new city but the browser will not connect to any page. This is happening on both Wifi and Data. However, I am also starting to doubt my T-Mobile service is working even though it shows all the network info because when I go to reconnect to a new SSID the 'sim' option for Internet is shown in white and not blue (which I am learning is the indicator of an active service in SFOS).

 

Thanks ahead of time.

  • Sad 1
Link to post
Share on other sites

@DillonM I might have the same issue (original Pro1 SFOS 4.4.0.64). Sometime in the last week, some of my apps cannot connect to the internet via wifi or cellular. Weather seems to be working again, but the browser and hackernews don't connect.

Your post reminded me to investigate further. I notice both work fine when started from the terminal, e.g. sailfish-browser, or harbour-sailhn.

Not sure what's different, but it's a workaround at least.

  • Like 1
Link to post
Share on other sites
10 minutes ago, epninety said:

@DillonM I might have the same issue (original Pro1 SFOS 4.4.0.64). Sometime in the last week, some of my apps cannot connect to the internet via wifi or cellular. Weather seems to be working again, but the browser and hackernews don't connect.

Your post reminded me to investigate further. I notice both work fine when started from the terminal, e.g. sailfish-browser, or harbour-sailhn.

Not sure what's different, but it's a workaround at least.

Ya  that is exactly what I am seeing. Let me try launching from terminal and see if that is a good work around.

Link to post
Share on other sites

OK, maybe it's not the same problem, wierd coincidence though.

For me, looks like some issue with SailJail. I edited /usr/share/applications/harbour-sailhn.desktop and inserted

Sandboxing=Disabled 

into the [X-Sailjail] section and that now works normally when started from the icon. Not an ideal solution of course.

The same fix didn't work for the browser on the first launch, though it did for subsequent launches.

 

Link to post
Share on other sites
13 minutes ago, epninety said:

OK, maybe it's not the same problem, wierd coincidence though.

For me, looks like some issue with SailJail. I edited /usr/share/applications/harbour-sailhn.desktop and inserted


Sandboxing=Disabled 

into the [X-Sailjail] section and that now works normally when started from the icon. Not an ideal solution of course.

The same fix didn't work for the browser on the first launch, though it did for subsequent launches.

 

hmm ya too bad that work around didn't resolve it. 

Thanks for the suggestion. What would you try next to troubleshoot? Seems weird that the Jolla store will install and load but not the browser.

Actually when I ping google in terminal, It appears to be resolving via IPv6. That makes sense to me why I might not be able to resolve other sites but I am not sure how to proceed.

Link to post
Share on other sites

For my problem, it's clearly related to Sailjail so I will dig into that further when I have some time.

Since your issue seems different, I'm not sure where I would look next. I'm a hardware guy, rather than software, so I might try routing the phones internet through a machine running Wireshark so I could understand what it is and isn't doing at the network interface level. Come to think of it, I think wireshark is (or was) available for SFOS so you could do the packet capture on the device itself.

Not sure what I would expect to learn, but for me it's a familiar tool, so I'd just be hoping to spark an idea.

Link to post
Share on other sites
  • 1 month later...

Hi

Thanks for the information in this thread, it has been a great help in getting Sailfish up and running (especially the resizing of the home image).

I have recently received my pro1x, 256 GB with Scandinavian keyboard, and I have found come problems:

  • Physical keyboard: On the ö/ø key, i have an underscore character, on ä/æ key i have ø, on the </> key i have 1/2 (one half), shift 4/€ gives ¤, until now I have been unable to find the @, and more. How can i change the layout? I'm using danish layout, Norwegian is closer to the physical keyboard, but still wrong.
  • The weather app is preinstalled, but I'm unable to remove it, neither from the Jolla store (it's intalled in the overview, but not when I try to remove it), the desktop (nothing happens) or pkcon. Any ideas how to get rid of the app ?
  • Storeman is unable to login to my own repository, any ideas to why?
Link to post
Share on other sites

After fiddling some more, I still have the keyboard problems, and weather and the other pre-installed Jolla apps all are there and then not.

The storeman problem was solved by trying many times.

I have found one app I was unable to install, because of a version conflict between libargon2 and the one used by the community encryption.

Otherwise everything seems to work as expected.

Now I just have to solve the keyboard problem, and I have the perfect phone!

@piggzand co. : Great work.

Edited by kif
Typos
Link to post
Share on other sites

Android Support untested

Set password for dev mode needed for sudo

Turn on 3-party installs

once installed https://repo.sailfishos.org/obs/sailfishos:/chum//4.4.0.72_aarch64//aarch64/sailfishos-chum-gui-0.5.0-1.6.1.jolla.aarch64.rpm

Open CHUM install Waydroid

Open Terminal use devel-su for root

run waydroid init

https://together.jolla.com/question/184233/solved-auth-failed-for-root-user-or-devel-su-in-terminal-app/

https://forum.sailfishos.org/t/announcing-sailfishos-chum-gui-0-3/9839

https://chumrpm.netlify.app/

(M_P)

Edited by Milky_Pimms
  • Thanks 1
Link to post
Share on other sites
  • 1 month later...
58 minutes ago, kif said:

Does anyone know where we can report errors?

https://github.com/sailfish-on-fxtecpro1/droid-config-halium-qx1050/issues

Quote

👋Want to contribute to sailfish-on-fxtecpro1/droid-config-halium-qx1050?

If you have a bug or an idea, browse the open issues before opening a new one. You can also take a look at the Open Source Guide.

would be my guess, but there are other repositories that looks like qx1050 related here

Link to post
Share on other sites
  • 2 weeks later...

Been using this as my daily driver for about 2 weeks now and the biggest complaint I have is that all my MMS messages from both android and ios users do not come through.  (any suggestions)

There are times that I lose all network connectivity and I have to reboot but that has only been 1 or 2 times a day. 

 

  • Sad 1
Link to post
Share on other sites

Not to rule out the possibility that it's a Sailfish or phone issue, but I've frequently been having problems with MMS—ever since my first theoretically MMS capable phone... Often it was an APN setting that was missing or amiss.

That said, MMS as such has started being phased out at least in parts of this world. My primary mobile carrier (Vodafone Germany) has switched off MMS on January 17. No more MMS for me. 

Edited by Rob. S.
Link to post
Share on other sites

Ya I am trying to figure out another option for receiving MMS and RCS. My current thought is to use Waydroid and then something like Signal (I know they no long support SMS/MMS but just an example). But I am curious if there has been any work on getting the Android UI resolution to not appear as stretched when using the keyboard? And will any notifications from an android app pass through to the SFOS notifications?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Terms