Jump to content
gg2112

F(x)tec on Verizon?

Recommended Posts

This morning my phone signal went dead.  I went to the phone menu (*#*#4636#*#*) and all the Volte and Voice over Wifi switches were turned off.  This is the second time this has happened to me since December, so the good news is it doesn't happen often.  Thankfully, because I have no clue as to why.  But I just wanted to make folks aware this is a possibility.  If you suddenly lose signal on Verizon, check the phone menu.

  • Thanks 5

Share this post


Link to post
Share on other sites
On 3/23/2020 at 9:20 AM, Hook said:

This morning my phone signal went dead.  I went to the phone menu (*#*#4636#*#*) and all the Volte and Voice over Wifi switches were turned off.  This is the second time this has happened to me since December, so the good news is it doesn't happen often.  Thankfully, because I have no clue as to why.  But I just wanted to make folks aware this is a possibility.  If you suddenly lose signal on Verizon, check the phone menu.

And now I have the mysterious problem that a few others have hit with Verizon where being able to send sms stops working.   I can send mms, and I can receieve sms and mms, but I cannot send sms.  I think I am about to give up on Verizon.  I have an AT&T sim on the way.  When it gets here I'll put the Verizon sim in my old phone just to make sure Verizon isn't just messing up in general (I seriously doubt it) and I will make sure that AT&T still works properly. I will probably then try LOS again and if it works with AT&T, I'm afraid that will be it for Verizon. 

I was actually hit with this Verizon SMS thing once before.  It did go away when I did a complete reflash of my phone, though I am hesitant to attach causality to that sequence. 😉 But I'm getting tired of all this dancing around with Verizon, ffs.

Share this post


Link to post
Share on other sites
8 hours ago, Hook said:

And now I have the mysterious problem that a few others have hit with Verizon where being able to send sms stops working.   I can send mms, and I can receieve sms and mms, but I cannot send sms.  I think I am about to give up on Verizon.  I have an AT&T sim on the way.  When it gets here I'll put the Verizon sim in my old phone just to make sure Verizon isn't just messing up in general (I seriously doubt it) and I will make sure that AT&T still works properly. I will probably then try LOS again and if it works with AT&T, I'm afraid that will be it for Verizon. 

I was actually hit with this Verizon SMS thing once before.  It did go away when I did a complete reflash of my phone, though I am hesitant to attach causality to that sequence. 😉 But I'm getting tired of all this dancing around with Verizon, ffs.

i never fixed my sms issues. adb wasnt hooking properly with my device when connected over usb3 (probably need to use usb2?). ive had to use adb before on my old droid 4 but that was on an old machine.

since i dont do this often enough i dont remember how to set it up and i dont have as much time as i did back then so im just patiently waiting for magical software updates from tdm (lineageOS) or fxtech.

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

Sadly, I have given up. I ordered an AT&T SIM on-line, put it in the phone (Lol, I hate dealing with that SIM tray) and everything just works.  No need to fiddle with preferred networks or find the right APN.  All the switches already flipped on in the phone menu.  Good 4G with calls and texts all working and good data speeds and signal around town and at home.  Painless.  The funny thing is I used AT&T for years and love their prepay because in 2009 they were the only US prepay that let you have data (A Nokia 5800 was my first smartphone)-- I've never done contracts and never will. I only moved to Verizon prepay (which they greatly improved-- used to be terrible) when my wife was traveling to rural Arizona which only had a Verizon tower.

I hate to give up a fight but Verizon on the Pro1 is just too much work.  When it works (and truthfully, it did most of the time) it is great... until it suddenly doesn't work, for no apparent reason.  Which is just too frustrating.  I'm done.

My wife will keep Verizon on her Pixel 2XL.

Edited by Hook
  • Like 1

Share this post


Link to post
Share on other sites
On 3/27/2020 at 7:15 AM, Hook said:

Sadly, I have given up. I ordered an AT&T SIM on-line, put it in the phone (Lol, I hate dealing with that SIM tray) and everything just works.  No need to fiddle with preferred networks or find the right APN.  All the switches already flipped on in the phone menu.  Good 4G with calls and texts all working and good data speeds and signal around town and at home.  Painless.  The funny thing is I used AT&T for years and love their prepay because in 2009 they were the only US prepay that let you have data (A Nokia 5800 was my first smartphone)-- I've never done contracts and never will. I only moved to Verizon prepay (which they greatly improved-- used to be terrible) when my wife was traveling to rural Arizona which only had a Verizon tower.

I hate to give up a fight but Verizon on the Pro1 is just too much work.  When it works (and truthfully, it did most of the time) it is great... until it suddenly doesn't work, for no apparent reason.  Which is just too frustrating.  I'm done.

My wife will keep Verizon on her Pixel 2XL.

For the record, I'm still unable to send SMS, and don't want to deal with reflashing my phone. As such I'm currently looking into AT&T unless something magically happens before then. 

  • Like 1

Share this post


Link to post
Share on other sites
On 1/27/2020 at 10:45 PM, windraver said:

Just got the Pro1 today and somehow got it working on Verizon based on the instructions here.

Context: I have an existing account with Verizon. I've been swapping my sim to new devices for years. I've been carrying my sim from Droid Turbo, Turbo 2, Moto Z force, Moto Z2 force, Pixel 3 and now to the FXtec Pro1.

Steps I took:

  1. Insert existing active sim from Pixel 3.
  2. Skip initial setup step to setup network
  3. Connect to wifi
  4. Update to latest update
  5. go to dialer
  6. enter *#*#4636#*#*
  7. Enable all toggles under phone 1
  8. Set network to LTE only
  9. Restart

It now shows it is connect to 4G.

  • Data confirmed working. Web browsing, connected to Google account, downloaded apps.
  • SMS sent and received
  • MMS sent and received
  • Call made and received 

Anything else I should be testing?

  • update 1: Added clarifying information
  • update 2: tested and confirmed call and SMS both ways
  • update 3: test and confirmed MMS both ways.
  • update 4: cleanup

Featuring this post, thank you for sharing.

Share this post


Link to post
Share on other sites
4 hours ago, Erik said:

Featuring this post, thank you for sharing.

@Erik Yes, that works and it is a very nice summary of the instructions that those of us on (or who were on 😉 ) Verizon have used (I found Global worked nicely as network setting).  The only caveat is that, for some of us, it doesn't keep working, the most common failure seeming to be that you can receive but not send SMS.  Why?  I don't know, I certainly don't think it's the phone.  I'd love to find an explanation. It happened to me twice.  On the other hand, the phone worked wonderfully on Verizon for the better part of 3 months. However, especially in these times, I didn't feel I could tolerate undependable communication.  Since I had a choice, I went to AT&T which works flawlessly without any jury rigging.

My recommendation is that if you already have Verizon, it's worth a shot.  But I would not pick Verizon as a new service for the Pro 1 unless you have no choice.

  • Like 2

Share this post


Link to post
Share on other sites

My pro 1 stopped sending SMS last week.  I sent several days working with Verizon Tec support who I have say was really great.  Each time we did not get it figured out they elevated me to more knowledgeable higher skilled technicians.  I finally got to a women who immediately knew why the pro 1s did not send SMS.  (She gave me a lot of information that I did not understand but I can give you the basic). She said Verizon pushed out a up date to their system.  That up date changed the language that their network uses to send and receive messages to mobile phones.  So when a pro 1 sends a SMS the Verizon network can't translate that anymore.  She said the problem has nothing to do with the pro 1 not being on their approved list of phones. (She explained millions of Verizon customer have phones not on their list that still work fine.)  I confirmed that by Turing on a Cat S41 that is also not on the Verizon approved phone list but it sent SMS perfectly.  She offered to talk to someone from FxTech to explain to them what update need to be pushed to all the pro1 phones to get them to work again, I passed that on to the Fxtec support in several emails but Fxtec ignored all of those requests to talk to Verizon directly.  The Verizon Tec said all the pro 1 will lose the ability to text on their network if Fxtec dose not push out the required up date.  

 

So I had a second pro 1 on order that I cancelled because I can't switch to another network and I switched back to my old BlackBerry Priv,  my current Pro1 has become a paper weight.

 

I really hope Fx Tech pushes out what ever update is needed and I get to go back to my Pro 1 some day.

 

I have to say I was very let down with Fx Tech refusing to talk with the Verizon Tec to get the problem worked out.  But they did issue me my refund from my second pro 1 the very next day so that was good.

 

Thanks Jason 

  • Thanks 1

Share this post


Link to post
Share on other sites
6 hours ago, Jayfb said:

I really hope Fx Tech pushes out what ever update is needed and I get to go back to my Pro 1 some day.

Maybe Lineage is the way to go for you? These guys seems VERY attentive to suggestions that can fix bugs. Have a look in this thread:

 

Share this post


Link to post
Share on other sites
Posted (edited)

Actually, I think if we want it resolved in lineage, someone will have to send @tdm a verizon SIM (that had been activated on another device already).  Hook recently tested Verizon LTE only under lineage and had issues too, so unfortunately it's not currently a solution.

Edited by Craig
  • Sad 1

Share this post


Link to post
Share on other sites
31 minutes ago, Craig said:

Actually, I think if we want it resolved in lineage, someone will have to send @tdm a verizon SIM (that had been activated on another device already).  Hook recently tested Verizon LTE only under lineage and had issues too, so unfortunately it's not currently a solution.

Actually, more issues than stock.  Nothing worked and all the switches that might make it work in the phone menu were grayed out.  Luckily, I did have an option to switch networks.

  • Sad 1

Share this post


Link to post
Share on other sites

If Verizon is changing how they send and receive sms they must be doing it in stages, and my area isn't affected yet.  I just sent my work phone a test message and it worked, same as usual.  I've had zero problems ever since activating my Pro 1 for the second time, after the adoptable storage sd card failure back in February.

My phone is still on rooted 20200106 since I had modified the system partition and it won't accept a newer OTA until I flash it back to box-stock and start over.  Not super motivated to do that since it's working just fine and I haven't experienced any of the problems fixed in the newer release.

 

 

Share this post


Link to post
Share on other sites

Bumping this thread. I ported my number to Red Pocket (Verizon mvno). 

LineageOS doesn't support volte out of the box. Maybe it needs some hacking with magisk and the like but I didn't investigate further. 

I went back to stock and have so far been successfully using it. You'll need a mule phone to get past the imei check for the sim purchase but once you're through you'll have big red bliss. My advice is to buy a tracfone (the 20$). The imei will pass the check. No need to activate it but you might as well hold onto it in case you need another cheap mule. 

The instructions posted work so far and I haven't had any issues with volte being disabled. Will keep everyone posted. 

I missed Verizon, g*d damn they run a tight network. 

 

Share this post


Link to post
Share on other sites

Has anyone with a phone that failed to send a text tried the verizon messenger app? I think it uses a different protocall it has those features that iphones have to see when someone is typing and stuff like that, so maybe it is a good workaround?

I'm intrested in this phone but only if it works on verizon

Share this post


Link to post
Share on other sites

Going on 2 weeks now without any issue.  If you run stock then you can use Verizon just fine!

Share this post


Link to post
Share on other sites
3 hours ago, D1ggs said:

Going on 2 weeks now without any issue.  If you run stock then you can use Verizon just fine!

And I went 3 months with no problems.  😉  Good luck.  Really, I'm hoping it's all fine for you.

  • Thanks 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Terms