Jump to content

Recommended Posts

For info (as the above on fingerprint is a bit scary for potential customers): I did not have to re-enter my fingerprint after this update. It still works.

I guess the reason is that I only recently set up the fingerprint (in the previous stock version) and I did not experience the early bugs of the first stocks (February-June).

 

  • Like 1
Link to post
Share on other sites
  • Replies 134
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Hey, some very good news on twitter, finally looks like some software fixes coming: https://twitter.com/chenliangchen/status/1280900929273958402 I'm hoping that whatsapp thing means the

An update has been delivered to my device!

Posted Images

31 minutes ago, OKSun said:

For info (as the above on fingerprint is a bit scary for potential customers): I did not have to re-enter my fingerprint after this update. It still works.

Same thing for me also. Fingerprints still work after update. I have entered them only once before (2x thumb and 2x index finger at the same time).

Link to post
Share on other sites
9 hours ago, tdm said:

Check logcat for something crashing.

 

Logcat isn't showing much. Only one a bit suspicious is WeChat (I know, I don't want to use it either but no choice for a few people I talk to) which was updated on Sept 3rd and quite chatty, and another more obvious one that looks like a crash, but I don't see it part of the drain:

Quote

09-06 08:10:37.742  5424  5424 E ActivityThread: Activity com.android.launcher3.Launcher has leaked IntentReceiver [email protected] that was originally registered here. Are you missing a call to unregisterReceiver()?
09-06 08:10:37.742  5424  5424 E ActivityThread: android.app.IntentReceiverLeaked: Activity com.android.launcher3.Launcher has leaked IntentReceiver [email protected] that was originally registered here. Are you missing a call to unregisterReceiver()?
09-06 08:10:37.742  5424  5424 E ActivityThread:     at android.app.LoadedApk$ReceiverDispatcher.<init>(LoadedApk.java:1429)
09-06 08:10:37.742  5424  5424 E ActivityThread:     at android.app.LoadedApk.getReceiverDispatcher(LoadedApk.java:1210)
09-06 08:10:37.742  5424  5424 E ActivityThread:     at android.app.ContextImpl.registerReceiverInternal(ContextImpl.java:1476)
09-06 08:10:37.742  5424  5424 E ActivityThread:     at android.app.ContextImpl.registerReceiverAsUser(ContextImpl.java:1463)
09-06 08:10:37.742  5424  5424 E ActivityThread:     at android.content.ContextWrapper.registerReceiverAsUser(ContextWrapper.java:653)
09-06 08:10:37.742  5424  5424 E ActivityThread:     at android.content.ContextWrapper.registerReceiverAsUser(ContextWrapper.java:653)
09-06 08:10:37.742  5424  5424 E ActivityThread:     at android.content.ContextWrapper.registerReceiverAsUser(ContextWrapper.java:653)
09-06 08:10:37.742  5424  5424 E ActivityThread:     at android.widget.TextClock.registerReceiver(TextClock.java:591)
09-06 08:10:37.742  5424  5424 E ActivityThread:     at android.widget.TextClock.onAttachedToWindow(TextClock.java:532)
09-06 08:10:37.742  5424  5424 E ActivityThread:     at android.view.View.dispatchAttachedToWindow(View.java:18351)
09-06 08:10:37.742  5424  5424 E ActivityThread:     at android.view.ViewGroup.dispatchAttachedToWindow(ViewGroup.java:3409)
09-06 08:10:37.742  5424  5424 E ActivityThread:     at android.view.ViewGroup.dispatchAttachedToWindow(ViewGroup.java:3409)
09-06 08:10:37.742  5424  5424 E ActivityThread:     at android.view.ViewGroup.dispatchAttachedToWindow(ViewGroup.java:3409)
09-06 08:10:37.742  5424  5424 E ActivityThread:     at android.view.ViewGroup.addViewInner(ViewGroup.java:5082)
09-06 08:10:37.742  5424  5424 E ActivityThread:     at android.view.ViewGroup.addView(ViewGroup.java:4870)
09-06 08:10:37.742  5424  5424 E ActivityThread:     at android.view.ViewGroup.addView(ViewGroup.java:4810)
09-06 08:10:37.742  5424  5424 E ActivityThread:     at android.view.ViewGroup.addView(ViewGroup.java:4783)
09-06 08:10:37.742  5424  5424 E ActivityThread:     at android.appwidget.AppWidgetHostView.applyContent(AppWidgetHostView.java:456)
09-06 08:10:37.742  5424  5424 E ActivityThread:     at android.appwidget.AppWidgetHostView.access$000(AppWidgetHostView.java:53)
09-06 08:10:37.742  5424  5424 E ActivityThread:     at android.appwidget.AppWidgetHostView$ViewApplyListener.onViewApplied(AppWidgetHostView.java:509)
09-06 08:10:37.742  5424  5424 E ActivityThread:     at android.widget.RemoteViews$AsyncApplyTask.onPostExecute(RemoteViews.java:3474)
09-06 08:10:37.742  5424  5424 E ActivityThread:     at android.widget.RemoteViews$AsyncApplyTask.onPostExecute(RemoteViews.java:3403)
09-06 08:10:37.742  5424  5424 E ActivityThread:     at android.os.AsyncTask.finish(AsyncTask.java:695)
09-06 08:10:37.742  5424  5424 E ActivityThread:     at android.os.AsyncTask.access$600(AsyncTask.java:180)
09-06 08:10:37.742  5424  5424 E ActivityThread:     at android.os.AsyncTask$InternalHandler.handleMessage(AsyncTask.java:712)
09-06 08:10:37.742  5424  5424 E ActivityThread:     at android.os.Handler.dispatchMessage(Handler.java:106)
09-06 08:10:37.742  5424  5424 E ActivityThread:     at android.os.Looper.loop(Looper.java:193)
09-06 08:10:37.742  5424  5424 E ActivityThread:     at android.app.ActivityThread.main(ActivityThread.java:6746)
09-06 08:10:37.742  5424  5424 E ActivityThread:     at java.lang.reflect.Method.invoke(Native Method)
09-06 08:10:37.742  5424  5424 E ActivityThread:     at com.android.internal.os.RuntimeInit$MethodAndArgsCaller.run(RuntimeInit.java:493)
09-06 08:10:37.742  5424  5424 E ActivityThread:     at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:858)
 

My SOT time at 35% is now just a bare 2 hours.

Edited by ToniCipriani
Link to post
Share on other sites
10 hours ago, EskeRahn said:

That is very interesting. What do you get with 2.4GHz then?

The consumption you get seems more like what I would have expected, a tad more than 2.4GHz but not extremely much more.

MY router is a somewhat dated Huawei B525s 23a. (I use 4G as a fall-back connection when the fibre is out of order)

Switched to to 2.4GHz and you are right, I am having about 0.6%, less than on 5GHz. But difference is not that much and I am not sure that it's a bug (in my case).

Do you have access to any other 5GHz network? May be this problem is related to some Huawei specific issue?

I don't have any Huawei wifi hardware around at the moment but give me some time..

  • Like 1
Link to post
Share on other sites

Here's something I just noticed is also fixed in the latest 0825 update: Android PhotoScan finally works. Before it would freeze or crash - not sure I saw anyone else report this bug (some other photo scan apps would crash too).

  • Thanks 1
Link to post
Share on other sites
1 hour ago, tdm said:

Yes, that thread.  I guess he thought persist was not necessary.  Here is a copy:

Have flashed persist.img now. For doing it i need first unlock bootloader (and unlocking is full wipe), then flashing persist, then lock again - with unlocked BL Google pay doesn't work 😞

But, now i has worked fingerprint! Thanks

  • Like 2
Link to post
Share on other sites
1 minute ago, Ilrilan said:

Have flashed persist.img now. For doing it i need first unlock bootloader (and unlocking is full wipe), then flashing persist, then lock again - with unlocked BL Google pay doesn't work 😞

But, now i has worked fingerprint! Thanks

 

Yes, Pay and Netflix and some banking apps require a locked bootloader.  You can lock it again from fastboot.

 

  • Thanks 1
Link to post
Share on other sites
On 9/5/2020 at 6:40 PM, EskeRahn said:

On 1. Here there still is a substantially larger idle power drain when connected to my router using 5GHz rather than 2.4GHz

(With 4G, BT and NFC It is about 0.7%/h with 2.4GHz Wifi, but 2.8%/h with 5GHz WiFi)

This seems to be related to the specific dated router model Huawei B525s-23a!

Half a day ago I tried to change the Pro1's connection to a newer Huawei router (B535-232), and it seems to make a HUGE difference. I will need more time, but I currently estimate that that the consumption went down around 0..5%/h, but take that number with a BIG pinch of salt for now. (Confirmed over a 12h time span).   Just wanted to state that it is NOT the Pro1 as such, but the combination that is the issue, so if amyone see a disproportional drain, you might want to consider to upgrade your router.

(the B535 can do automatic handling of the two ranges as one net, but I explicitly turned that off and made two independent networks to do the test fairly)

Link to post
Share on other sites
On 9/5/2020 at 6:32 PM, LAMENT said:

An update has been delivered to my device!

Screenshot_20200905-195834.jpg

in my case, the update seems to have really fixed the issue related to the "Wifi signal lost => phone crashing". In the past days, I have switched off my second wifi access point and connected directly to the router only (to test). Previously the phone would crash within 30 seconds due to loss of wifi signal.

in the past days, not a single crash (as they promised).

What surprises me is that now the wifi signal reception on the phone is constant, even in the most remote room (without the second wifi access point). It seems that the signal reception has improved (or is it the weather??)

Edited by OKSun
  • Like 5
Link to post
Share on other sites
9 hours ago, ToniCipriani said:

I got one crash today which made me late for an appointment because my phone was sitting at the "Draw your pattern to unlock your Android" boot screen.

I can't tell for sure if it was due to the Wi-Fi bug though. ¯\_(ツ)_/¯

I have also had a restart yesterday (update installed when it became available) while I wanted to take a photo using Gcam Port's camera.
Display became green and I think a watchdog restart happened.

I have a problem which I still have not dug into so Android keeps restarting a while when I reboot my phone or connecting a charger so it has started its "usual" reboot loop.

...but there is a difference. My reboot loop does not affect the kernel, so practically the hardware does not restarts but the Android on top.

The watchdog restart above was a complete freeze or panic so also kernel became stuck.

I don't even remember if this kind of restart ever happened with my phone, however, it can be an independent thing including something triggered by Gcam mod which may be a rare combination of things. 🙂

  • Sad 1
Link to post
Share on other sites

I went back to stock yesterday. I haven't typed a lot, but so far no keyboard issues.
It took over an hour to install al the system updates. My phone rebooted (crash) during the fourth update if I recall correctly. I didn't pay much attention, just kept on updating.
I see that the rotation bug is still in effect. But what annoys me the most are the DPI-settings. I can't recall where you can adjust that. Was it in build.prop? I remember vaguely I had to edit that back when on Cyanogenmod.
And if so, does anyone have the correct location and setting similar to the smallest screen settings in LoS?

Edited by DieBruine
Link to post
Share on other sites
42 minutes ago, DieBruine said:

I went back to stock yesterday. I haven't typed a lot, but so far no keyboard issues.
It took over an hour to install al the system updates. My phone rebooted (crash) during the fourth update if I recall correctly. I didn't pay much attention, just kept on updating.
I see that the rotation bug and the backlit bug are still in effect. But what annoys me the most is the DPI-settings. I can't recall where you can adjust that. Was it in build.prop? I remember vaguely I had to edit that back when on Cyanogenmod.
And if so, does anyone have the correct location and setting similar to the smallest screen settings in LoS?

You can find it from hidden developer settings. It is called "smallest widht". Here is the documantation:

Screenshot_20200910-082303.thumb.png.21bbeec14168ccbd878069db383cc253.png

 

Also, you can tune display and font size from Accessibility settings under display.

Edited by FlyingAntero
  • Like 1
  • Thanks 2
Link to post
Share on other sites

Has anyone found a way to disable APT-X HD? since it doesn't work, I would prefer it to be disabled. I own a BT headphone that can connect with either APT-X HD or AAC. It defaults to APT-X HD and therefore doesn't work. So disabling that which does not work anyway would seem logical and in my case at least enable AAC over AD2P.

Edited by DieBruine
Link to post
Share on other sites
14 minutes ago, DieBruine said:

Has anyone found a way to disable APT-X HD? since it doesn't work, I would prefer it to be disabled. I own a BT headphone that can connect with either APT-X HD or AAC. It defaults to APT-X HD and therefore doesn't work. So disabling that which does not work anyway would seem logical and in my case at least enable AAC over AD2P.

Try "Developer options" , "Bluetooth Audio Codec", and try one of the many options not mentioning APT-X HD.

Link to post
Share on other sites

That

2 minutes ago, EskeRahn said:

Try "Developer options" , "Bluetooth Audio Codec", and try one of the many options not mentioning APT-X HD.

That doesn't affect the handshake process unfortunately. Tried all possible combinations already. Under LoS it does connect over AAC. So I'm guessing there should be a way to disable APT-X.

  • Sad 1
Link to post
Share on other sites
15 minutes ago, DieBruine said:

That

That doesn't affect the handshake process unfortunately. Tried all possible combinations already. Under LoS it does connect over AAC. So I'm guessing there should be a way to disable APT-X.

I found something that might be related here, someone suggests to turn off Bluetooth before changing the setting in developer options - worth a try. Most likely you should also make sure that it is un-paired if it shows up as paired (though not working), as it might else remember the APTX for the device.

Link to post
Share on other sites
1 hour ago, internationaltraitor said:

what does that do for the phone if you change the DPI settings ? and to what settings (amount of DPI) do you change it to for your preference?

Smaller screen and spacing in combination with small font. First I change it to 540. Then the system changes it to somethin else, after that I set it to 581 and keep it there.
I would like to use 620, but then the navigation buttons move from the right side to the bottom in landscape. If I type 581 the navigation buttons stay at the bottom. When I use 540 and then go to 581 I still notice the difference. I use 581 because that is what the system once chose and I like.

so, if someone knows how I can use a higher value while retaining the navigation buttons on the right, please let me know.

Ow how nice it is to be able to type all of this without errors (apart some user errors that is)!!!

Edited by DieBruine
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Terms