Jump to content

LineageOS 17.1 Official Builds: Discussion


Recommended Posts

After the update my camera app doesn't save the pictures on the SD card anymore. Works fine if i choose Internal storage.

I can see my SD card in the file manager and all the files on it. But doesn't save the pictures on it.

Link to post
Share on other sites
  • Replies 88
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

I falshed mine, with no issues. Starting from LOS16.0, MindTheGapps and addonsu. Downloaded LOS17.1 https://download.lineageos.org/pro1 OpenGApps nano, ARM64, Android10.0 https://opengapps.o

Updated yesterday via sideload with nano opengapps and Magisk. No problems so far, even banking apps with nfc payments are working! 😀

Android 10 seems to present some additional challenges with the external SD card.  With Open Camera, I had to go to "more camera settings" as usual, but unlike with Android 9, I had to toggle on "Use

Posted Images

45 minutes ago, Breeze said:

After the update my camera app doesn't save the pictures on the SD card anymore. Works fine if i choose Internal storage.

I can see my SD card in the file manager and all the files on it. But doesn't save the pictures on it.

Have a look over here, where a browser have troubles saving using 10.0 , Could be the same issue that @Slion got with his browser.

  • Thanks 1
Link to post
Share on other sites

Android 10 seems to present some additional challenges with the external SD card.  With Open Camera, I had to go to "more camera settings" as usual, but unlike with Android 9, I had to toggle on "Use Storage Access Framework."  Then it allowed me to give permission for the "Save Location" to access a folder on my SD card and now Open Camera is saving to the SD card again.

Google seems to be determined to make things as difficult as possible for using SD cards. Grrrr

Edited by Hook
  • Thanks 4
Link to post
Share on other sites

I use stock camera. I can choose SD card in the settings but it doesn´t save the picture. I see the taken picture in the little circle (last taken picture) but nothing happens when i tap on it. It should open the picture.

Forgot to mention that my old pictures before the update doesn't show up in the gallery anymore...

Edited by Breeze
More info!
Link to post
Share on other sites
On 11/10/2020 at 10:06 PM, EskeRahn said:

Done, went super smooth and fast 🙂

IF we got mindthegapps while on 16.0 It seems to be important instead to install opengapps during in the 17.1 process.


(That is as Mindthegapps in this version is not supported on 17.1, we can not leave it there, but have to have opengapps replacing it - as @Wheeljack did above too )

Hi

So is this information correctly? For somereason I thought it would not matter which gapps we should use. Heck, don't even remember which I installed last time. 

Anyway, so adb 17.1 (can be done with old recovery), reboot, adb opengapps and Magisk -> good to go? No data loss?

Link to post
Share on other sites

When installing GApps it needs to be tailored for the installed Android version. Since MindTheGApps hasn't been updated in a while and there is no package for Android 10, we have to go with OpenGApps.

I followed the official upgrade guide (which for some reason uses "adb reboot sideload" to skip that one button press in recovery). After flashing Lineage and rebootinga1g into the new recovery, I flashed OpenGapps Nano - from the package description it sounded the closest to what MTG included. And if you previously had OpenGApps installed, there should be no trouble, if you accidentally choose a package with a different amount of included apps.

I don't have any experience with Magisk yet.

  • Thanks 1
Link to post
Share on other sites
On 11/18/2020 at 9:44 PM, EskeRahn said:

(lineage-17.1-20201116-nightly-pro1-signed.zip on November security patch installed smoothly using sideload, No spontaneous reboots .... yet)

And well Got he reboot again...

ADD: This seems to be related to apps, see later posts.

Link to post
Share on other sites

Hi

 

I have issues adding my google account. 

 

Wiped the phone, flashed boot with "lineage-17.1-20201110-recovery-pro1.img" , sideloaded "lineage-17.1-20201110-nightly-pro1-signed.zip", Rebootet to recovery, sideloaded "open_gapps-arm64-10.0-nano-20201112.zip"

after bootup, followed the wizard to configure the phone. 

 

Logs attached, 7

 

 

logcat.txt radio.txt

Screenshot_20201115-142906_Settings.png

Screenshot_20201115-125851_System_UI.png

Screenshot_20201115-125805_System_UI.png

Edited by pebert
Adding screenshots
Link to post
Share on other sites

one thing more, I am using finQWERTY for swedish layout. I can´t get the "fn" button to work, or it works just as a "shift"

So fn+2 (which should give me @) gives me ", which is the same as shift+2 give me. 

 

same for both 16.0 and 17.1

 

 

Link to post
Share on other sites
On 11/19/2020 at 8:18 AM, EskeRahn said:

And well Got he reboot again...

Reboots about every second hour or so, will try to re-flash, if that does not help, factory reset is next. 16.0 worked really well, but the upgrade to 17.1 was bad. But pretty sure it is the lack of a wipe that is at the root of it. As AICP-Q on what I believe is the same port is stable after a wipe.

ADD: This seems to be related to apps, see later posts.

Link to post
Share on other sites
57 minutes ago, pebert said:

Wiped the phone, flashed boot with "lineage-17.1-20201110-recovery-pro1.img" , sideloaded "lineage-17.1-20201110-nightly-pro1-signed.zip", Rebootet to recovery, sideloaded "open_gapps-arm64-10.0-nano-20201112.zip"

after bootup, followed the wizard to configure the phone. 

Hmm, maybe wipe is not the solution for me then - could be related to the crashes I get. (note that a six day newer Lineage exists 20201116)

Add there are also newer OpenGapps available, with a little luck that makes a difference...

Link to post
Share on other sites

The "Emergency" function added on the Power button, is there a way to get rid of that? (it is optional on AICP-Q)

Or does it at the least have some sort of confirmation dialogue? I have not (yet) accidentally activated it, but would just hate to waste their time due to some not thought through phone-function...

Do not get me wrong, the idea with easy access to emergency is fine, but it is not fine if we end up wasting their time with accidental calls....

If each of us do this accidentally say every three years, that is almost 1000 random calls a day in a one-million-city....

Link to post
Share on other sites
4 hours ago, EskeRahn said:

Reboots about every second hour or so, will try to re-flash, if that does not help, factory reset is next. 16.0 worked really well, but the upgrade to 17.1 was bad. But pretty sure it is the lack of a wipe that is at the root of it. As AICP-Q on what I believe is the same port is stable after a wipe.

My guess is that the wlan kernel driver is causing this. I'm sure it got updated.

 

Link to post
Share on other sites
10 hours ago, tdm said:

My guess is that the wlan kernel driver is causing this. I'm sure it got updated.

Interesting Idea. I have just tried to disable WiFi, and will report if it helps. But the same issue is NOT affecting your AICP-Q

ADD: This seems to be related to apps, see later posts.

Link to post
Share on other sites

Hi, updated via OTA, with nano opengapps and root with Magisk. Works really better for wifi, I use the keyboard patch for qwertz models thanks to @tdm

Works fine, and Fingerprings works really better...

But I have yet a GPS problem. No mor GPS. I tried GPS Test and many others, but no more position, no GNSS. Could this be a hardware problem ?
I precise my phone fall (one mor time) last week, and I have little use from the GPS, it could be broken in LOS 16.0.

Any advices ? Thanks !

Link to post
Share on other sites
8 hours ago, EskeRahn said:

Interesting Idea. I have just tried to disable WiFi, and will report if it helps. But the same issue is NOT affecting your AICP-Q

That was quick, it just rebooted again - WiFi disabled, will try Aeroplane-mode....

ADD: This seems to be related to apps, see later posts.

Link to post
Share on other sites
15 hours ago, EskeRahn said:

Add there are also newer OpenGapps available, with a little luck that makes a difference...

No luck. Still there with opengapps-nano-20201119 though

ADD: This seems to be related to apps, see later posts.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Terms