Jump to content

LineageOS 18.1 Official Release for Pro1


Recommended Posts

  • Replies 472
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

So, just one last update on that slightly off-topic discussion from few weeks ago: Following @Sean McCreary's suggestions, I was indeed able to build an up-to-date (unofficial) LOS 16.0. It

As much as I enjoy the fact that LineageOS on the Pro1 seems to be alive and well, I am puzzled by the practice of removing previous major releases from the build systems as soon as a new version is m

Its purpose is to bring the tap-insensitive display borders back from too wide to normal after a display replacement. If you need a display replacement and you get one from any other source than

Posted Images

Does the latest version of lineage have a Dex like function when connected to a monitor (I mean separate desktop mode) and can you make the settings and notifications dark too?

Those would be the only reasons I would like to try it for.

  • Like 1
Link to post
Share on other sites
On 4/23/2021 at 5:34 PM, claude0001 said:

Sorry, I won't. As I wrote several times in this thread, I believe that having AGPS disabled is actually a sane default.

ah sorry not caught everything in this thread

Link to post
Share on other sites
On 4/23/2021 at 6:34 PM, claude0001 said:

Sorry, I won't. As I wrote several times in this thread, I believe that having AGPS disabled is actually a sane default.

Some might choose LineageOS specifically for privacy reasons, so I think it is better to have AGPS as an opt-in feature, even if that means one needs to root-edit the system config.

Of course, best would be having the option user-configurable in the phone settings, but I do not know if that is (easily) possible.

That said, @marmistrz intended to submit a patch (to LOS 18.1, I think). Do not know if it happened.

The patch was submitted here. https://review.lineageos.org/c/LineageOS/android_device_fxtec_pro1/+/308056
As I said, feel free to submit an issue to https://gitlab.com/LineageOS/issues/android and request a user-configurable option. At this moment I'm unsure how they want device-independent bugs to be reported and I'm quite busy these days.

Edited by marmistrz
Link to post
Share on other sites
27 minutes ago, marmistrz said:

As I said, feel free to submit an issue to https://gitlab.com/LineageOS/issues/android and request a user-configurable option.

I feel like I do not care enough about LineageOS to do that work. I'll keep camping on my rooted LOS 16 for the foreseeable future anyway.

Should I ever need to reinstall my system, I'll probably try to switch to SFOS (or UT if that has matured by then), as, honestly, I'm getting a bit tired of Android ...

Sorry.

Edited by claude0001
  • Like 1
Link to post
Share on other sites

Can someone help me. I'm desperate. So I updated to latest nightly build through the built in updater. Then attempted to flash the patched boot image and it failed. Now I can boot into lineage recovery and lineage will boot up but my fastboot appears to be messed up as I can't run any fastboot commands. When I type fastboot devices it shows ?????? Then kicks me out of fastboot. Same goes with all fastboot commands. Now I'm stuck. This is the same pc and fastboot as well as the same cord that I used to flash boot images before so I know it's not outdated fastboot drivers or faulty cord. Can someone please help me either figure out how to fix fastboot or restore device back to stock. I am not comfortable with edl without someone capable of helping ne walk through it. I'm stuck. I also am not comfortable taking my device apart using TDM's method to restore stock given there appears no other way to restore or get into EDL mode. I asked on discord and no one was able to help. 

Edited by JordanKirsch83
  • Sad 2
Link to post
Share on other sites
6 hours ago, JordanKirsch83 said:

Now I'm stuck. This is the same pc and fastboot as well as the same cord that I used to flash boot images before so I know it's not outdated fastboot drivers or faulty cord.

I unfortunately do not have any miracle solution. BUT as something went wrong with a flashing I would still suspect the connection.

double check that no 'pocket lint' have sneaked in, for all connections, and possibly try a different cord, port or PC.

If you do have access to alternatives, try connecting any different USB-C phone, and try to transfer a large amount of data (e.g. images & videos) in both directions and double check that they transferred correctly.

  • Haha 1
Link to post
Share on other sites
8 hours ago, JordanKirsch83 said:

Can someone help me. I'm desperate. So I updated to latest nightly build through the built in updater. Then attempted to flash the patched boot image and it failed. Now I can boot into lineage recovery and lineage will boot up but my fastboot appears to be messed up as I can't run any fastboot commands. When I type fastboot devices it shows ?????? Then kicks me out of fastboot. Same goes with all fastboot commands. Now I'm stuck. This is the same pc and fastboot as well as the same cord that I used to flash boot images before so I know it's not outdated fastboot drivers or faulty cord. Can someone please help me either figure out how to fix fastboot or restore device back to stock. I am not comfortable with edl without someone capable of helping ne walk through it. I'm stuck. I also am not comfortable taking my device apart using TDM's method to restore stock given there appears no other way to restore or get into EDL mode. I asked on discord and no one was able to help. 

If you are trying to use Magisk to get root in Lineage, you don't need to do that dance with patching the bootloader.  Just use adb sideload to flash the Magisk zip from HERE and you will have root, no muss no fuss. (I'm still using an old one, 21.0) I never even open Magisk Manager, although the zip installs it.

I'm sorry, I don't know what's going on with fastboot.  I assume you are booted into the bootloader, not recovery, when you are doing that (I'm not trying to be insulting by pointing to the obvious-- when I get frantic I can miss incredibly obvious things and am happy when people point them out).

Edited by Hook
  • Like 2
  • Thanks 2
Link to post
Share on other sites

ineage-18.1-20210503-nightly-pro1-signed.zip on April 5 security patch installed smoothly using adb sideload.  Haven't updated to the April MindTheGapps yet and still using Magisk 21.0.  I'll get around to updating those one of these weeks, but everything works nicely. I don't do passing SafteyNet, don't care about it.  I don't even open Magisk Manager at all.

  • Thanks 1
Link to post
Share on other sites
Posted (edited)
6 minutes ago, Slion said:

Can you run Google Play on Lineage or do you use other app stores?

That's what installing Gapps does for you.  It is the actual Google Play framework and some of the Google Apps, from Google, which is why it is a separate install.

Edited by Hook
  • Like 1
  • Thanks 1
Link to post
Share on other sites

(lineage-18.1-20210503-nightly-pro1-signed.zip on April 5 security patch installed smoothly using adb sideload and MindTheGapps-11.0.0-arm64-20210412_124247)

  • Like 2
Link to post
Share on other sites
36 minutes ago, Slion said:

Don't you get auto updates then once MindTheGapps is installed?

You can (inside the Android market app) select to have apps - including their own ones - autoupdated. And you actually need to remember to explicitly turn this OFF if you do not want them to constantly wasting battery and bandwidth for checking for new versions. Just like on stock. (Note that they choose to ignore your selection, turning it back on, when you install on a new device with same G-account BTW)

  • Like 1
  • Thanks 1
Link to post
Share on other sites
1 hour ago, Slion said:

Don't you get auto updates then once MindTheGapps is installed?

I think you got the wrong impression from my talking about using a newer Gapps package.  There's no compelling reason to do so. Sometimes, if the play services have been updated, it can mean less ota updating when you first install, but really, I could use the same MindTheGapps package for as long as I'm using Lineage 18,x (until Lineage releases version 19/Android 12) and it wouldn't make a difference. Someone can correct me if I'm wrong, but that's my understanding.

  • Like 2
Link to post
Share on other sites
Posted (edited)

Hi all, has anyone managed to successfully migrate from the Stock ROM to the latest LOS build? I'm following the instructions on the LineageOS wiki but not having any luck with getting the LOS recovery to boot or flash to my device.

Device is unlocked - Device State shows as unlocked on the bootloader, and so does the OEM Unlock Settings in Android.

When I try to flash or boot into LineageOS recovery ( lineage-18.1-20210503-recovery-pro1.img ) using fastboot (v31.0.2 on Arch Linux. running as root),  nothing happens - if I try to flash the image, it just hangs on the terminal with no response, and there's no activity on the phone either. The phone is stil responsive though and if I restart the bootloader from the phone, the terminal goes back to normal and I get back my prompt.

If I run "fastboot boot", it gets stuck on "Sending 'boot.img' (65536 KB) " and nothing happens.

"fastboot devices" does detect the device, and other fastboot/adb commands work as well (eg: reboot). So not sure what's wrong. Is there any other recovery that I could try? Do I need to be on some specific firmware/bootloader version before I can flash/boot LineageOS recovery?

If I reboot the device from fastboot during the stuck state, I got an error back on the terminal saying:

fastboot: error: boot partition is smaller than boot image

I've verified that the  sha256sum matches as well: cc14ae7d8678af03c48180e6b18e52584b6a3451d7257ed3ad3885cef3ffb360

I've also tried the LOS 17.1 recovery - lineage-17.1-20210329-recovery-pro1.img but I can't get it to boot either.

Also tried changing USB cables and ports, and rebooting my laptop, no dice.

I'm kinda lost at this stage - anyone have any ideas how to proceed further? Thanks!

image.gif

Edited by dextersgenius
  • Like 1
Link to post
Share on other sites
On 4/28/2021 at 4:38 AM, JordanKirsch83 said:

Can someone help me. I'm desperate. So I updated to latest nightly build through the built in updater. Then attempted to flash the patched boot image and it failed. Now I can boot into lineage recovery and lineage will boot up but my fastboot appears to be messed up as I can't run any fastboot commands. When I type fastboot devices it shows ?????? Then kicks me out of fastboot. Same goes with all fastboot commands. Now I'm stuck. This is the same pc and fastboot as well as the same cord that I used to flash boot images before so I know it's not outdated fastboot drivers or faulty cord. Can someone please help me either figure out how to fix fastboot or restore device back to stock. I am not comfortable with edl without someone capable of helping ne walk through it. I'm stuck. I also am not comfortable taking my device apart using TDM's method to restore stock given there appears no other way to restore or get into EDL mode. I asked on discord and no one was able to help. 

Try using a PC that has a USB 2.0 Port. Flashing with a USB 3.0 Port seems to have problems and can either 1. Mess up or fail or 2. Won't work at all. Also buy a new USB C cable as well. The USB C cables tend to be more fragile than the standard micro USB cables. 

  • Like 1
Link to post
Share on other sites
On 5/3/2021 at 8:38 AM, Slion said:

Can you run Google Play on Lineage or do you use other app stores?

That defeats the purpose of using Lineage. Lineage is designed to be used with G apps. It gets you away from the tracking/privacy features that google loves to hide from you. 

  • Like 1
Link to post
Share on other sites
Posted (edited)
On 5/3/2021 at 2:38 PM, Slion said:

Can you run Google Play on Lineage or do you use other app stores?

I'm using F-Droid exclusively, I don't have or want gapps on my device. I'm using Lineage because it's the easiest way of having an up-to-date Android version on myy device.

Edited by marmistrz
  • Like 1
Link to post
Share on other sites
6 hours ago, RagingSkittlez said:

That defeats the purpose of using Lineage. Lineage is designed to be used with G apps. It gets you away from the tracking/privacy features that google loves to hide from you. 

No, it defeats one purpose of using lineage.  Having up-to-date security patches, a more stable version  of Android, having just the Gapps you prefer and not all installed as system apps are also reasons. 😉

  • Like 3
  • Thanks 2
Link to post
Share on other sites

(lineage-18.1-20210510-nightly-pro1-signed.zip on May 5 security patch installed smoothly using adb sideload and MindTheGapps-11.0.0-arm64-20210412_124247)

  • Thanks 2
Link to post
Share on other sites
On 4/27/2021 at 7:47 AM, Rud said:

Does the latest version of lineage have a Dex like function when connected to a monitor (I mean separate desktop mode) and can you make the settings and notifications dark too?

Those would be the only reasons I would like to try it for.

Sorry for insisting, but would anyone know the answer to my question?

I'd get on Lineage ASAP if it's a "yes".

  • Like 1
Link to post
Share on other sites
Posted (edited)

When I connect my Pro1 I just get a mirrored screen. No additonal settings. The peripherals all work (connected to my screen) but no separate settings for a desktop-environment.

And my phone has been configured to complete darkness 😉

Edited by DieBruine
  • Like 1
  • Thanks 2
Link to post
Share on other sites
22 hours ago, Rud said:

you make the settings and notifications dark too?

That should work from Android 10 so I would say yes. I never tried LOS myself though.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Terms