Jump to content

QWERTZ User Layout Setup


Recommended Posts

10 hours ago, raymo said:

I had same issue, you must go in system - advanced options - Keyboard and then :

Layout : qwertz

Custom keymap : ON

so it works perfect for me

Do you mean that FinQwerty layouts are working just like on stock If you enable "custom keymap" on LOS?

Link to post
Share on other sites
  • Replies 146
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

For all the QWERTZ users, please set-up the physical keyboard layout after the initial setup. (Only needs to do this once) ADD (EskeRahn): During the initial set-up use the touch keyboard to ente

I can add one in the next FinQwerty version 🙂 Does the below layout look OK? Or should I perhaps swap Y/Z (if both are wanted by people here, I can also add both), or any other suggestions?

Yes, the current QWERTZ layout is different from a standard one (it was made by the community) So we currently put this layout under German. In the future we could expand it into other German-speaking

Posted Images

6 hours ago, FlyingAntero said:

Do you mean that FinQwerty layouts are working just like on stock If you enable "custom keymap" on LOS?

 

FYI ... "custom keymap" is a bit misleading...

 

If you do have a custom keymap file in /persist, this option allows you to control whether it is loaded at boot or not.

 

If you do not have a custom keymap file in /persist, this option does nothing.

 

  • Thanks 2
Link to post
Share on other sites

I don't use Finqwerty

But if I don't check the 'custom keyboard' option I have the upper line yellow layouts who are broken, like !"§$%&/()=?

I don't know if this is normal or not, I have try and it works...

I have intalled LOS twice, with complete wiping data, and it has'nt work without 'custom keyboard'

  • Thanks 1
Link to post
Share on other sites
  • 1 month later...

 

11 minutes ago, EskeRahn said:

If you can use "Russian Mac style", they are hidden away is on Sh+6 and Sh+7....

Thank you! It is working!

But is it possible to modify layout manually? I tried to find something like "keyboard_layout_russian.kcm" to bind dot&comma on the same place as on US layout, but failed. I'm not familiar with Android architecture. 

And another question. What is the yellow arrow and "F" next to the control means?

Link to post
Share on other sites
33 minutes ago, MMSergeevich said:

Thank you! It is working!

But is it possible to modify layout manually? I tried to find something like "keyboard_layout_russian.kcm" to bind dot&comma on the same place as on US layout, but failed. I'm not familiar with Android architecture. 

And another question. What is the yellow arrow and "F" next to the control means?

Unfortunately you can not directly change the layout without rooting. But a tool like FinQWERTY is open source, so you could make your own APK and side-load it. (no rooting needed)
On stock android the Yellow arrows are used as "Fn" key. The Logo-F as a jump to launcher Home.

  • Like 1
Link to post
Share on other sites
  • 3 weeks later...

My pro1 is a qwertz one and the settings for the built in physical keyboard of the phone is "Finqwerty, German physical DE QWERTZ."

I am using sometimes my Pro1 with an external logitech keyboard and mouse (I mean in this post a real desktop keyboard not the nice built in physical keyboard of the phone).

The external keyboard is a qwertz one, and work as such when I use it for my laptop. However when I use it for the phone, it acts as a QWERTY keyboard...

I found out that I need to go to

Settings

System

Language & input

Physical keyboard

Here it is a bit confusing, since the menu lists three different fx tec keyboards with the same denomination fx tec keyboards (they are in fact: built in, mouse, and external keyboard).

I found out that the 3rd one is the external keyboard. Now which layout should I choose for this one?

If I use german android it is shifted (q is W).

 

 

Edited by OKSun
Link to post
Share on other sites
  • 4 weeks later...

I have no luck with LOS and swedish keyboard on my QWERTZ phone. Whatever I try I can not write the swedish characters and @ with the same configuration. One of them is always broken (at the moment I can write å, ä, ö but yellow key plus q just gives a capital Q). I have tried with and without FinQWERTY with no luck. All help is appreciated.

Link to post
Share on other sites
On 11/4/2020 at 12:04 PM, proprog said:

I have no luck with LOS and swedish keyboard on my QWERTZ phone. Whatever I try I can not write the swedish characters and @ with the same configuration. One of them is always broken (at the moment I can write å, ä, ö but yellow key plus q just gives a capital Q). I have tried with and without FinQWERTY with no luck. All help is appreciated.

The Lineage keyboard driver tries to make the keyboard look like a "normal" keyboard to Android.  Because the print is in German, the default QWERTZ layout is the same as a German keyboard.  I would be happy to work with you to adjust this for Swedish.  Please send me a PM.

 

  • Thanks 1
Link to post
Share on other sites
On 11/4/2020 at 9:04 PM, proprog said:

I have no luck with LOS and swedish keyboard on my QWERTZ phone. Whatever I try I can not write the swedish characters and @ with the same configuration. One of them is always broken (at the moment I can write å, ä, ö but yellow key plus q just gives a capital Q). I have tried with and without FinQWERTY with no luck. All help is appreciated.

Note that in AICP @tdm has already handled this so Sym+2 gives us a @  🙂

So pressed alone Sym gives the symbol-list as on LOS, but it can ALSO be used as a modifier. 😎

Link to post
Share on other sites
6 hours ago, EskeRahn said:

Note that in AICP @tdm has already handled this so Sym+2 gives us a @  🙂

So pressed alone Sym gives the symbol-list as on LOS, but it can ALSO be used as a modifier. 😎

What? AICP should behave the same as Lineage. The kernel is exactly the same code.

 

Link to post
Share on other sites
1 hour ago, tdm said:

What? AICP should behave the same as Lineage. The kernel is exactly the same code.

Yes, was too hasty. Sorry,

The keyboard has an odd state that can be entered in two ways

1) Press Sym and get the symbol-selector and do NOT select a symbol, but press Sym again, to have the selector go away
2) Press Sym+Key where nothing is assigned, e.g. Sym+J

It leaves the keyboard in an odd state, ignoring normal letter presses.

To get out of this state either
a) Press Sym, Press e.g. a letter key, Press Sym again
b) Press Sym+Key with an assigned key (e.g. 2)

 

  • Thanks 2
Link to post
Share on other sites
  • 1 month later...

Thanks @raymo!!! I have installed LOS17.1. Ones more for all Germans: 

Activation of the hardware keyboard QWERTZ and the yellow keys without installation of FinQwerty:
System → Languages and input → Physical keyboard → Builtin keyboard → "German Android keyboard"
System → Keys → EXTRAS: Other keys → Hardware keyboard: Layout "qwertz" and Custom keymap "on"
After that, the key layout works perfectly, including the yellow arrow keys and the yellow special characters, like
  ! "§ $% & / () =?` @ € µ

  • Like 2
  • Thanks 2
Link to post
Share on other sites

@reiner.popp
ah...you know, I'm using LOS17 (last version) now without "custom keyboard" activated.
If I understood correctly it is only if you have some custom keymapping in a system folder somewhere, as tdm said.
However, this is not the first weid thing happening on this phone, I suspect also hardware problem somewhere. My GPS is working only when he wants, and often I can't answer a phone call, (no button available), and with the known bug of proximity sensor...

But it is the only smartphone I can be friend with, and the hope in a stable Ubuntu touch, a possible dual-boot...so many fun in this interesting hardware.

Link to post
Share on other sites
  • 1 month later...
On 1/17/2021 at 5:11 PM, milp said:

I had to select the dutch layout from finqwerty, because with the german layout the ß/? key does not work properly, no ? is available there - i can't believe it takes this much setting up to get the STOCK rom to work properly

Hm, for me and Stock QWERTZ it works fine, Shift+ß for ? (like on a real keyboard), although other yellow symbols are used with the yellow arrow (like alt on a traditional keyboard if you want to look at it like that..). I can not really reproduce your issue there. On early builds there was acutally a mis-mapping  (` for example was a lookalike), but ?/ß was not one of them.

Link to post
Share on other sites
On 1/17/2021 at 5:11 PM, milp said:

I had to select the dutch layout from finqwerty, because with the german layout the ß/? key does not work properly, no ? is available there - i can't believe it takes this much setting up to get the STOCK rom to work properly

Yellow + ß/? produces a ? for me on FinQWERTY German QWERTZ.

  • Thanks 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Terms