Jump to content
Waxberry

Pro1 Known Bugs [Updated 19 Nov 2019]

Recommended Posts

51 minutes ago, elvissteinjr said:

I'd like to urge F(x)tec to provide updated flashable images along the OTA updates or at least updated boot.img that can be patched with Magisk later.

Root is technically not an advertised feature like the alternative OS support, but I hope F(x)tec understands the desire of their customers wanting to be able to root the official Android OS without missing out on updates.

I plan on using LOS, but I second this request.

Share this post


Link to post
Share on other sites

All boot.img are now in thread about magisk, on following updates i'll upload boot images to the same Google drive folder.

 

After installing all OTA i have a bug: fingerprints are lost after each reboot 😞

Edited by Ilrilan
  • Sad 1

Share this post


Link to post
Share on other sites
28 minutes ago, Ilrilan said:

After installing all OTA i have a bug: fingerprints are lost after each reboot 😞

I have the same bug but I also had it before last (keyboard-related) update (I wrote it above).

The most annoying thing for me is the audio volume of earpiece (I mean the in-call volume).
I use it using lowest possible audio level but it is still too loud and if the other party speaks too loud, I can not do anything - also people around me may hear the other party.
So it would be very welcome to reduce software gain or have an option to set gain as soon as possible.

However, I have not experienced keyboard lockouts since last update, so it seems it may be resolved.

Also, I would be happy to activate also top speaker in hands-free mode.

Edited by VaZso

Share this post


Link to post
Share on other sites

Had you try this app? It also can adjust different volume with connected headset/without it

Screenshot_20200110-151537.png

Edited by Ilrilan

Share this post


Link to post
Share on other sites
On 1/7/2020 at 5:37 AM, silversolver said:

As much as I love root access, I'll probably do without it for awhile on my clack when it arrives as it sounds like there's currently a certain amount of disruption in making it work. Perhaps @Waxberry will get the software people to add the root access switch in developer settings like LOS has. Not that this is terribly important, but I know I would appreciate it, and I'm sure I wouldn't be alone.

Lineage OS is dropping the support for its own root access, starting from LOS 17 (Android 10). Magisk is the way to go in future.

  • Like 2
  • Sad 1

Share this post


Link to post
Share on other sites
10 minutes ago, Ilrilan said:

Had you try this app?

Now I have tried it.
At minimum level, "Call volume" displays 20%. I can adjust it to go below it but I don't know if it affects call volume, however, it goes back to 20% automatically.

  • Sad 1

Share this post


Link to post
Share on other sites

I'll put this here, as I'm not sure if it's a bug or something confined to my Pro1. Maybe a widget misbehaving, but I've disabled all widgets one at a time as a process of elimination but haven't been able to find out where it's coming from.
Not sure what it is but I get this grey area at the bottom right of my screen after closing the slider and the screen going back to portrait mode. When I tap it it disappears, other than that it doesn't do anything at all.
Anybody have any ideas?

spacer.png

Share this post


Link to post
Share on other sites
6 hours ago, MickH said:

I'll put this here, as I'm not sure if it's a bug or something confined to my Pro1. Maybe a widget misbehaving, but I've disabled all widgets one at a time as a process of elimination but haven't been able to find out where it's coming from.
Not sure what it is but I get this grey area at the bottom right of my screen after closing the slider and the screen going back to portrait mode. When I tap it it disappears, other than that it doesn't do anything at all.
Anybody have any ideas?

spacer.png

Sure looks like an add-on misbehaving to me. You may have to go into applications and force stop them one by one until the box leaves, and then you'll know what's spawning it.

EDIT: it could also be a glitch in the rotation prompt. It shouldn't be presenting at all because auto rotate is on, but for some reason it's still half-presenting.

Edited by silversolver
  • Like 1

Share this post


Link to post
Share on other sites
11 hours ago, silversolver said:

EDIT: it could also be a glitch in the rotation prompt. It shouldn't be presenting at all because auto rotate is on, but for some reason it's still half-presenting.

That's what I'm thinking, as that's the exact spot where the manual rotation icon flashes up if auto-rotate is turned off. I have 4 screens active and it actually appears on each one.

  • Like 1

Share this post


Link to post
Share on other sites

Seems like keyboard unresponsiveness bug is almost gone by the OTA update. Actually it seemed to be totally gone, but yesterday my keyboard stopped working for few times. Every time it happened it was right after screen timeout while having keyboard out (I left the phone lying on the table with keyboard opened for a while.) But earlier only reboot helped to fix the issue, but now it started to work again after I closed the keyboard, rotated the phone to portrait, switched to some other app, opened virtual keyboard, typed something, opened the keyboard again, went back to original app and then it worked again. So looks like the "permanent" problem is gone.

  • Like 3
  • Thanks 1

Share this post


Link to post
Share on other sites
On 1/11/2020 at 1:22 PM, MickH said:

That's what I'm thinking, as that's the exact spot where the manual rotation icon flashes up if auto-rotate is turned off. I have 4 screens active and it actually appears on each one.

Strictly it depends on your settings, if you selected the classic buttons (Settings, System, Gestures, Swipe up on Home button), it would be the app-list button that is in this slot. (Autorotate is pushed further towards the edge)

 

Screenshot_20200112-140049~01.png

  • Like 1

Share this post


Link to post
Share on other sites

Yeah, they call it the "Overview Button" in the settings. Only supposed to show up if you have "Swipe Up" switched off.

Share this post


Link to post
Share on other sites

Stereo speakers, left and right are transposed.

I guess this is an easy one.

Build: QX1000_EEA_20200106110245

Edited by Loader009
  • Thanks 2
  • Haha 2

Share this post


Link to post
Share on other sites
25 minutes ago, wish42offcl97fxtec said:

Stereo speakers, left and right are transposed.

I noticed this in sailfishOS but hadn't tested in Android to be sure...

  • Thanks 1

Share this post


Link to post
Share on other sites
31 minutes ago, Craig said:

I noticed this in sailfishOS but hadn't tested in Android to be sure...

be funny if they wired them the wrong way round....

  • Haha 1

Share this post


Link to post
Share on other sites
3 minutes ago, _DW_ said:

be funny if they wired them the wrong way round....

It seems they did.... Just tested in Android. YouTube search "Stereo Test". Headphones are OK though.

Hope they can swap them it in a software-driver...

  • Thanks 1
  • Haha 1
  • Sad 1

Share this post


Link to post
Share on other sites

Anyone got random reboots after the certification update? Thought that it was related to locking the bootloader, unlocked it, but still got them. Tried disabling multiple apps, no difference.

Share this post


Link to post
Share on other sites
1 hour ago, EskeRahn said:

It seems they did.... Just tested in Android. YouTube search "Stereo Test". Headphones are OK though.

Hope they can swap them it in a software-driver...

oh dear....

but yes can be fixed in software 😄

  • Like 1
  • Haha 1

Share this post


Link to post
Share on other sites
18 minutes ago, ddark-il said:

Anyone got random reboots after the certification update? Thought that it was related to locking the bootloader, unlocked it, but still got them. Tried disabling multiple apps, no difference.

Nope, not here. And the standard IT-support question for almost anything: Have you tried rebooting? 😇😝

  • Thanks 1
  • Haha 4

Share this post


Link to post
Share on other sites

In theory, after Jan 3rd update there should be no more issues with screen frozen and keyboard lost.

We are working on the current issues and hopefully to deliver a build not too long after the Chinese New Year:

- To fix the driver with keyboard that enables any two keys to press together (already fixed under Sailfish OS)

- To fix the sound cracking issue with some music and whatsapp

- To Re-map the esc key back to esc instead of back

- reduce the sensitivity of double clicking power button so the camera short cut doesn't launch often

And more fixes on the pipeline...

  • Like 8
  • Thanks 7

Share this post


Link to post
Share on other sites
55 minutes ago, Waxberry said:

And more fixes on the pipeline...

Hope it includes lost fingerprints...

  • Like 3
  • Sad 1

Share this post


Link to post
Share on other sites
8 hours ago, EskeRahn said:

Hope it includes lost fingerprints...

I'd be good with just disabling the fingerprint reader permanently. :O

OK, I'll go back to the nursing home now......

  • Like 1
  • Haha 1

Share this post


Link to post
Share on other sites
10 hours ago, Waxberry said:

And more fixes on the pipeline...

I also would like to have these solved:
- ability to decrease in-call volume further - so I mean the lowest in-call volume is also too loud
- only bottom speaker is working in hands-free mode (being in portrait state), top one is silent - it would be good to also use top one
- screen colours are incorrect below ~50% of brightness

  • Like 2

Share this post


Link to post
Share on other sites

- Multiple people have reported that the phone doesn't come with a built-in Recovery

- Can't boot into a custom recovery with fastboot, without flashing, by using: fastboot boot boot.img

- Instructions for how to remove encryption so that TWRP and ADB can read the /data partition

  • Like 4

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Terms